Modem unter Suse 7.2 einrichten

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Homer_J, 26. September 2001.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Homer_J

    Homer_J Byte

    Registriert seit:
    25. Februar 2001
    Beiträge:
    56
    Hallo,
    ich hab ein Elsa MicroLink 56k Modem und schaffe es nicht es unter Linux zum Laufen zu bringen. Wenn ich mich versuche einzuwählen (ich galube mit KInternet) dann sendet der Computer die InitStrings an das Modem und dies reagiert nicht. Ich habe auch schon alle Schnitttstellen ausprobiert. Ich hoffe jemand kann mir helfen. Oder jemand sagt mir ein paar Links, wo ich sonst noch Hilfe finden kann.

    Schon mal Danke
    MfG Homer:J
     
  2. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    Ja tut mir wirklich leid wenn ich dir hofnung gemacht habe.
    Aber als ich das erstemal Linux aufspielte hate ich auch ein WinModem und 4h gebraucht bis ich das rausgefunden habe.
    Wenn du glück hast schreibt vielleicht jemand eine treiber oder hat das vielleicht schon gemacht.

    [Diese Nachricht wurde von quereller am 16.10.2001 | 17:06 geändert.]
     
  3. yogamaster

    yogamaster Byte

    Registriert seit:
    17. März 2001
    Beiträge:
    17
    FInd ich gut bloß woher bekomme ich einen treiber für mein ELSA ISDN USB MODEM?
     
  4. sfx67

    sfx67 Byte

    Registriert seit:
    25. Juni 2001
    Beiträge:
    117
    hallo,
    ok wie weiter unten bereits geschrieben könnte es sich um ein winmodem handeln, dann sieht}s weniger gut aus.
    also erst checke mal ob du das modem als /dev/modem z.b.
    in kppp eingetragen hast. den entsprechenden link auf /dev/ttyl*
    sollte yast entsprechend deines internen modems gesetzt haben. die dns usw. für otelo bekommst du von deren
    seite, wenn nicht mail noch mal, ich hatte den otelo call by call
    auch früher genutzt und irgendwo habe ich die adressen noch.
    probiere doch mal als einwahlprogramm KWvDial .dort hast du
    unter anderen auch eine option für eine win 95/98 emulation
    wenn dein (win ???-modem) unter linux funktionieren sollte.
    nochmal zur config ...auch wenn yast das modem nicht erkennt,
    kann man es z.b. mit kppp oder kwvdial zu laufen bekommen.
    schau doch auch mal auf die suse webseite, in die
    hardwaresupportdatenbank ob dein pci-modem dort steht.
    ansonsten finden sich dort auch umfangreiche artikel zur konfiguration.
    ich habe hier zwar auch einen artikel aus einem linuxmagazin gefunden aber der wäre ziemlich umfangreich um ihn in}s forum
    zu posten...
    viel glück....
    mfg.swen
     
  5. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    Gute Idee, aber 2 sec in der Suse SDB nachgeschaut und du siehst das die meisten ELSA modems unterstützt werden.
     
  6. feo84

    feo84 Byte

    Registriert seit:
    16. Juni 2000
    Beiträge:
    49
    Könnte es sein, dass dein Modem ziemlich billig war? Dann handelt es sich mit an Sicherheit grenzender Wahrscheinlichkeit um ein sogenanntes Win-Modem. Das funktioniert, wie der Name schon sagt, nicht unter Linux :( Deswegen bringen auch die Init-Strings nichts.
     
  7. 1kalli

    1kalli Byte

    Registriert seit:
    3. November 2000
    Beiträge:
    10
    /usr/sbin/chat -v -f /etc/ppp/t-online.chat\' $device $pppflags $localip:$remoteip

    Eine weitere Möglichkeit für die Authentifizierung ist ein eigen benanntes File. Dann muß man noch als Option +ua FILENAME angeben. In FILENAME steht dann in zwei (!) Zeilen der Username und das Passwort. Die Option user ist dann nicht nötig.

    Der eigentliche Modem-Dialog fuer das chat-Programm ist in der Datei /etc/ppp/t-online.chat beschrieben:

    /etc/ppp/t-online.chat
    TIMEOUT 30
    ABORT "NO CARRIER"
    ABORT BUSY
    ABORT ERROR
    "" +++ATZ
    OK ATDT0191011
    CONNECT ""

    Das persönliche Kennwort muss in der Datei /etc/ppp/pap-secrets eingetragen werden, die dann (sofern Sie nicht alleine auf Ihrem Rechner zugreifen) die Permission 600 erhalten sollte:

    /etc/ppp/pap-secrets
    "000123456789961518659#0001" * passwort
    Wichtig sind die Anführungszeichen, da sonst das # als Kommentarzeichen interpretiert wird und die Authentifizierung nicht klappt! Natürlich muß man noch das Passwort durch das eigene ersetzen.

    Dann muß noch im Startup-Script /etc/rc.config (bei SuSE-Distributionen in der Datei /etc/resolv.conf) der Eintrag NAMESERVER=194.25.2.129 stehen.

    In den jetzt verwendbaren Mail-, News oder WWW-Browserprogrammen müssen evtl. noch weitere Angaben gemacht werden damit sie Verbindung zu den entsprechenden Servern aufnehmen können.

    mfg.
    kalli
     
  8. Homer_J

    Homer_J Byte

    Registriert seit:
    25. Februar 2001
    Beiträge:
    56
    Hey,
    tschuldigung. daß ich so spät schreibe aber mein Rechner hatte ein paar Probleme gemacht. So nun zu deinen Fragen: Ich hab ein Internes PCI-Modem. Eingerichtet hab ich es sowohl mit Yast1 als auch mit Yast2. Ich benutze übrigens einen Call by Call Zugang von Otelo.
    Hab die Einwahl auch mit kppp probiert, hat das Modem nicht erkannt oder meinte es wäre besetzt.
    Ich hoffe du hast nun eine Idee.

    MfG Homer_J
     
  9. sfx67

    sfx67 Byte

    Registriert seit:
    25. Juni 2001
    Beiträge:
    117
    hallo,
    wie ist das am modem am pc angeschlossen ? seriell oder über usb? hast du es z.b. vorher mit yast2 oder yast 1 eingerichtet ?
    hast du mal die einwahl mit kppp probiert ?benutzt du einen
    call by call zugang oder z.b. aol oder t-online ?
    sorry für die vielen fragen...aber das problem muß näher eingegrenzt werden.
    mfg. swen
     
  10. yogamaster

    yogamaster Byte

    Registriert seit:
    17. März 2001
    Beiträge:
    17
    danke für den tipp ich probiers gleich aus
     
  11. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    Nach einem forumseintrag gibt es keine Linux Unterstützung für dieses modem.
    (Und Elsa interesiert das nicht die bohne)
    und sieh mal hier (ganz unten):
    http://sdb.suse.de/de/sdb/html/hoe_isdn_terminaladapter.html
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen