mplayer erkennt GTK-devel nicht

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von MasterOfVDL, 4. Juli 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. MasterOfVDL

    MasterOfVDL ROM

    Registriert seit:
    4. Juli 2005
    Beiträge:
    6
    Hi,
    Ich wollte gerade den mplayer installieren, um meine WMA-Files anhören zu können, aber beim Ausführen von "./configure --enable-gui" kommt die folgende Fehlermeldung:
    Code:
    Error: The GUI requires GTK devel packages (which were not found).
    Wenn ich nun mit Yast2 nachschaue, sehe ich, dass GTK-devel aber installiert ist. Weiß irgendjemand, wie man das Problem lösen könnte?
     
  2. cirad

    cirad Kbyte

    Registriert seit:
    24. Februar 2001
    Beiträge:
    509
    Wo sind sie installiert? Über die Umgebungsvariablen CPPFLAGS=-I/pfad kannst Du den Pfad zu den GTK-devels angeben. Für Libs gilt entsprechend LDFLAGS=-L/pfad.
     
  3. Jörg Thoma

    Jörg Thoma Kbyte

    Registriert seit:
    3. September 2004
    Beiträge:
    144
    Bei Suse liegen die Gtk-libs und headers unter /opt/gnome.
    ./configure --help gibt Aufschluss über Pfadangaben.
    Benötigt wird /<pfad_zu_gnome>/bin/gtk-config.
     
  4. MasterOfVDL

    MasterOfVDL ROM

    Registriert seit:
    4. Juli 2005
    Beiträge:
    6
    Danke.
    Danach trat das gleiche Problem mit der Glib-devel auf, aber es konnte analog dazu geloest werden.

    Ich schreibe hier mal die Befehlszeile, damit jemand, der das gleiche Problem hat, sie gleich hat...

    Code:
    ./configure --enable-gui --enable-largefiles --language=de --with-gtk-config=/opt/gnome/bin/gtk-config --with-glib-config=/opt/gnome/bin/glib-config
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen