1. Bitte immer die Rechnerkonfiguration komplett posten!
    Vollständige Angaben zur Konfiguration erleichtern die Hilfestellung und machen eine zügige Problemlösung wahrscheinlicher. Wie es geht steht hier: Klick.
    Information ausblenden

MTU einstellen aber WO??

Dieses Thema im Forum "Heimnetz und WLAN" wurde erstellt von Bamm-Bamm, 25. Februar 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Hallo zusammen!

    Ich hab ein kleines funktionierendes peer-to-peer Netzwerk zu Hause. Nur ein W98SE-Rechner ist etwas unwillig. KLEINE Dateien (ein paar Kilo) können ohne Probleme ins/vom Lokale Netz (normales Ethernet) kopiert werden (also sind Datei-Rechte OK; keine Firewall vorhanden). Nur GROßE Dateien will er nicht senden. Hier die Windows-typische Fehlermeldung:

    "Fehler beim Kopieren einer Datei
    xxxxx kann nicht kopiert werden: Die angegebene Netzwerkressource oder das Gerät ist nicht mehr verfügbar.
    OK "

    Dies sieht trotz dieser Meldung aus wie ein MTU-Problem (zu großer Wert). Wie kann ich das einstellen? Ich hab kein DFÜ-Netzwerk auf dem Rechner, da kein Modem angeschlossen ist. Auch der Registry-Eintrag fehlt (ipmtu). Auch in der Netzwerkumgebung fehlt die Option mit der Paketgröße.

    Ich hab es auch schon mit MTU-Speedmanager 4.10 probiert. Ohne Erfolg. Er hat kein IP-Protokoll gefunden (komisch, hat er doch???).

    Ist es vielleicht die Registry, die einen Schuß hat? (Scanreg /fix ist auch schon gelaufen)

    Ich weiß einfach nicht mehr weiter... Kann mir jemand helfen?
    Wo/wie kann ich noch den MTU-Wert in W98SE einstellen???

    mfg
    Raphael
     
  2. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    @zirkon
    In Zeiten des Terrabytes ;-) passieren solche kleinen Fehler. Es waren bei den ersten Tests nur 100 bytes!

    Inzwischen hab ich die "Deadline" jedoch genauer ausgetestet. Die Grenze liegt irgendwo zwischen 100 und 500 KILObyte. Größer geht nur VON "böse" nach "gut" nicht.
    Fehlermeldung auf "Böse": Netzwerk überlastet
    Traffic war jedoch so gut wie keiner vorhanden (3 Rechner am Netz)

    Mein Dritter Rechner mit Suse 7.2 und Samba kann mit "gut" ohne Probleme Daten tauschen. Suse und "böse" klappt auch nicht richtig

    OK, MTU scheidet angesichts der Größen wohl aus. Nun ja, aber was sonst??

    Beim Testen ist mir aufgefallen, das diese Dateien bei fast gleicher Größe unterschiedlich lang brauchen. Zwischen "Flupp" und 20 Sekunden. Gut, es ist nur ein 10 base 2 (="bnc") Netz, aber trotzdem. Jawohl, Terminatoren sind dran.
    Das Senden zu diesem "bösen w98" Rechner geht immer und um Welten schneller, als zurück zum "guten w98" Rechner (wenn überhaupt).

    --------------------------------------------------
    "Böser" W98SE (AntiVir, Keine Firewall):
    Zugriffssteuerung auf Freigabeebene
    Client für M$-Netzwerke
    Netzwerkkarte NE2000 eigentlich UMC/UM9003AF
    - "erweiterter NDIS-Treiber-Modus mit 16/32 Bit" und Bindung TCP/IP
    - kein Reiter "erweitert", sondern nur "Ressourcen" (kein konflikt)
    TCP/IP
    - Feste IP
    - Wins deaktiviert (natürlich)
    - Gateway (IP des Linux-Router)
    - DNS aktiviert (Host:eigener Computername, keine Domäne, zwei DNS-Server aus dem Internet)
    - Bindung am M$-NW und Dateifreigabe
    - Bindung an ATM zulassen: Nein
    - Netbios grau
    Datei- und Druckerfreigabe
    - LM-Dienst: Nein
    - Suchfunktion: Automatisch
    --------------------------------------------
    "Guter" w98se (AntiVir, Norton Personal Firewall, Vertraute Rechner eingetragen, auch schon mal deaktiviert ohne Änderung):

    Alles gleich bis auf IP-Adresse (logisch) und Unterschied in der Netzwerkkarte (intel 2104) erweitert:
    Burst length; Connection Type; Extra Receive Buffers; Extra Receive Packets; Interrupt Mititgration; No Cable Indication; Nway Protocol; Process Transmit First; Receive Buffers; Snooze Mode; Transmit Threshold; Underrun Max Retries
    Diesen ganzen Kruscht bisher nicht angetastet, aber alles einstellbar
    --------------------------------------------------

    Vielleicht ist es die NoName Netzwerkkarte mit Chip UM9003AF? Treiber? Bisher nur w95-treiber gefunden (Ich weiß, geht auch, aber wenn, dann richtig)

    Sollte ich irgendwas relevantes vergessen haben? Ich hoffe nicht.

    mfg
    Raphael
     
  3. Schugy

    Schugy Viertel Gigabyte

    Registriert seit:
    10. Juli 2001
    Beiträge:
    2.587
    Wie gross ist denn der Wert auf dem Linuxrouter?

    Mach xterm auf
    su
    <rootpasswort>

    Und dann gib mal ifconfig ppp0 ein.

    Im allerbösesten Fall ist eine MTU von 1452 erlaubt.
    Also eintippen:
    ifconfig ppp0 mtu 1452

    Dann sollte man auf dem Router schonmal alle Seiten erreichen können.

    Für Win-Clients gibt es ein kostenloses Tool DFÜ-Speed (Google), mit dem man das einfach in der Registry ändern kann.

    MfG

    Schugy
     
  4. Zirkon

    Zirkon Megabyte

    Registriert seit:
    28. November 2001
    Beiträge:
    1.210
    Als "kleine Pakete" würd ich 100KB nicht bezeichnen. Standardmäßig ist die MTU 1500 bzw. 1492 (8 Byte für Routinginformationen) Byte, deine 100KB-Dateien werden mit genauso großen IP-Paketen übertragen wie die 100MB-Dateien.
    Vielleicht stören sich ja verschiedene Protokolle? Was ist denn alles an die Netzwerkkarte gebunden?
     
  5. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    @zirkon
    Danke für die Antwort.
    Alle kleinen Pakete (z.B. 100 KB) im LAN funktionieren. Ping als erstes getestet. Bisher läuft auch Internet (DSL) über linuxrouter. Wahrscheinlich weil von dort noch keine großen Dateien übers Internet gingen.

    Nur "große" Dateien abgehend von diesem Rechner mit z.b. 2-3 MB streiken. :-(

    Mir ist das Problem auch neu. Es kann nur MTU sein (?) Was sonst??
     
  6. Zirkon

    Zirkon Megabyte

    Registriert seit:
    28. November 2001
    Beiträge:
    1.210
    In LAN ist die MTU unerheblich. Typischerweise treten MTU-Probleme mit Kabelmodem- oder DSL-Verbindungen auf, wenn ein Router verwendet wird (fürs Masquerading werden noch ein paar Byte benötigt, wodurch die Paketgröße geringfügig ansteigt).
    Muß bei Dir an etwas anderem liegen. Check mal, ob wirklich auf allen Rechnern, besonders der 98er Kiste TCP/IP verfügbar ist (einfach in der Eingabeaufforderung ping 127.0.0.1 probieren, das muß funktionieren).
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen