Multy-Boot-Problem

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von kazhar, 17. Oktober 2001.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. kazhar

    kazhar Viertel Gigabyte

    Registriert seit:
    21. Juni 2001
    Beiträge:
    4.420
    Hallo,

    Ich habe auf meinem Athlon 500/256 MB-Ram ein Multi-Boot-System mit Win98, Win2k und zum experimentieren Linux (Suse 7.0).
    Bisher habe ich es nicht geschafft, LILO in mein (Win2k-) Bootmenu einzubauen. Bis jetzt boote ich Linux mit einer "Magic" Diskette, die ich weder unter DOS/Windows ansehen, noch unter Linux mounten kann.
    Meine Fragen: Wie kopiert man den Bootsektor dieser Diskette in eine Datei? Und würde es funktionieren diese Datei über die Boot.ini einzubinden (wie das geht weiß ich)?

    Danke im Voraus, KazHar.
     
  2. ast

    ast Guest

    s doch nicht um ein Rennen der Poster. Wer hilft is\' doch egal, Hauptsache es läuft.
    Über den Bootman von NT lasse ich Lilo starten allerdings auf einer extra Part nur für "Little Lilo".
    Na egal nächstes mal bist Du vielleicht schneller, *LOL*.
     
  3. feo84

    feo84 Byte

    Registriert seit:
    16. Juni 2000
    Beiträge:
    49
    LILO kann bei mir Win2k nicht booten (ja, ich hab die Version ohne 1024-Zylinder-Grenze, Linux liegt auch sonstwo auf meiner 80-Gig-Platte und lässt sich ohne Probleme booten).
    Deswegen danke euch für die Tipps, werd ich mal testen.
     
  4. kazhar

    kazhar Viertel Gigabyte

    Registriert seit:
    21. Juni 2001
    Beiträge:
    4.420
    Danke, aber schon erledigt!
     
  5. kazhar

    kazhar Viertel Gigabyte

    Registriert seit:
    21. Juni 2001
    Beiträge:
    4.420
    Danke!

    Hat prima hingehaut!

    (nachdem ich versehentlicherweise den Win2k-Bootsektor mit dem Linux-Bootsektor überschrieben hatte *LOL*)
     
  6. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Warum nimmst du nicht einfach LiLo als Bootloader? Der kann alle 3 Systeme booten, zumindest bei mir. ;-) Ach ja, wegen dem 1024. Zylinder Problem. Einfach von ftp.suse.com die neueste LiLo-version für 7.0 ziehen.

    Hier ist trotzdem eine Anleitung:
    dd if=/dev/hdXX of=/root/bootsek.lin bs=512 count=1
    Bootsekor wird erstellt. /dev/hdXX duch die Gerätedatei deiner Linuxpartition ersetzen. Pfad der Outputdatei eventuell anpassen.
    Bootsektor auf mit vfat formatierte Diskette kopieren.
    Windows 2000 starten und Datei auf C: kopieren.
    Folgenden Eintrag in boot.ini machen:
    C:\bootsek.lin = "Linux"

    Mist, da war einer schneller! ;-)

    @AST: Kann es sein, dass du das Buch Linux - Das Große Buch von Data Becker besitzt? ;-)
    [Diese Nachricht wurde von Marsch am 17.10.2001 | 20:29 geändert.]
     
  7. ast

    ast Guest

    unter linux:
    als root eingeben: dd if=/dev/hda? of=/root/bootsek.lin bs=512 count=1

    ?=Partitionsnr.
    Dann nach z.B. Diskette kopieren
    als root: mcopy /root/bootsek.lin a:

    Neustart mit /sbin/reboot
    Die Datei nach C:\ kopieren und in die Boot.ini als letzten Eintrag:

    C:\bootsek.lin = "Linux" hinzufügen.
    Beim nächsten Neustart sollte Linux starten.

    Geändert da Schreibfehler
    ast
    [Diese Nachricht wurde von ast am 17.10.2001 | 20:15 geändert.]
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen