mysql auf SUSE7.1

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Thomas.Teubert, 15. Juni 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Thomas.Teubert

    Thomas.Teubert Guest

    Registriert seit:
    10. Februar 2001
    Beiträge:
    8
    Ich habe das mitgelieferte mysql-paket installiert. Nach der installation lief der mysql-server auch.

    Nach dem ersten neustart - (ca. vier tage später) plötzlich nicht mehr - alle dateien scheinen dort zu liegen, wo sie hingehören.
    Bei der eingabe von "mysql" auf der konsole bekomme ich nur die fehlermeldung, das der server nicht läuft....

    Hat jemand eine Ahnung, woran das liegen kann?
     
  2. Thomas.Teubert

    Thomas.Teubert Guest

    Registriert seit:
    10. Februar 2001
    Beiträge:
    8
    Jo - no läuft es! Ich habe gerade ge-updatet - merkwürdig ist nur, das alle Dateien genau den gleichen (die für die conf) Inhalt haben! Sie liegen auch an der selben Stelle! Very strange. Der Zugriff über TCP/IP lief auch nach der Erst-Installation - dafür hab ich das Ding ja gebraucht!

    Aber danke für die Antworten!

    Zur Info:

    Das ganze läuft auf einem PI 133 mit 64 MB als Intranet, Mail u. DB-Server nun zur vollsten Zufriedenheit!
     
  3. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Du kannst auch noch versuchen die Datenbank anstatt über Unix Domain Sockets über eine TCP Netzwerkverbindung zu erreichen. Du könntest es eventuell mit einem neueren Paket für deine Distribution versuchen. Hast du schon mit ps aux nachgeschaut ob der mysqld tatsächlich läuft?
     
  4. Thomas.Teubert

    Thomas.Teubert Guest

    Registriert seit:
    10. Februar 2001
    Beiträge:
    8
    Ist alles da, wo es hingehört - ich hab den ganzen kram dann mal runtergeschmissen und neu installiert - super - lief sofort - bis zum ersten neustart....
    Nun ist alles wie vorher - die gleichen fehlermeldungen!
     
  5. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Existiert die Datei /var/lib/mysql/mysql.sock wirklich? Existiert vielleicht eine Datei namens /tmp/mysql.sock? Du musst auf jeden Fall in der Datei /etc/my.cnf o.ä. die Option socket in den Sektionen client und mysqld so ändern, dass beide die gleiche Socketdatei benutzen.
     
  6. Thomas.Teubert

    Thomas.Teubert Guest

    Registriert seit:
    10. Februar 2001
    Beiträge:
    8
    Jaja - das hab ich auch schon probiert - ich bekomme folgende Fehlermeldung:
    ERROR 2002: Can\'t connect to the local MySQL server through socket /var/lib/mysql/mysql.sock (111)

    Wie schon gesagt - die Dateien sind alle an dem Ort, wo sie auch hingehören!!!!

    Die Startdateien sind auch gesetzt - beim Booten keine Fehlermeldung!!????

    Ja - ich weiss nun nicht weiter -

    vielleicht hat ja noch jemand eine Idee

    Danke im Voraus

    Thomas
     
  7. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Der MySQL Server wurde bei dir vermutlich gleich nach der Installation gestartet, allerdings hat er anscheinend keine Veränderung an den Startskripten vorgenommen, so dass er beim Hochfahren nicht gestartet wird. Ich kenn mich jetzt mit SuSE bzw. YAST nicht so wirkllich aus, aber du solltest irgendwo in YAST die Möglichkeit haben, die Startprozedur anzupassen, so dass MySQL bei jedem Start gestartet wird. Um den MySQL Dämon selbst zu starten muss ich z.B. bei Debian folgendes einegeben: "/ect/init.d/mysql start" Bei SuSE wird es ähnlich funktionieren, nur das der Pfad eventuell anderst heist.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen