1. Bitte immer die Rechnerkonfiguration komplett posten!
    Vollständige Angaben zur Konfiguration erleichtern die Hilfestellung und machen eine zügige Problemlösung wahrscheinlicher. Wie es geht steht hier: Klick.
    Information ausblenden

Netzwerk und Email

Dieses Thema im Forum "Heimnetz und WLAN" wurde erstellt von Carsten R., 3. März 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Carsten R.

    Carsten R. Kbyte

    Registriert seit:
    26. Mai 2002
    Beiträge:
    183
    Hallo Netzwerktechniker und Outlookexperte J,

    ich hoffe ich habe alles eindeutig beschrieben und erhalte Rückmeldung zur Lösung meines Netzwerksproblems...

    - ich habe 2 PC und ein DSL-Modem an einem Switch
    - auf PC_1 läuft ein Proxy-Server (analogx)
    - jeder PC kann alleine ins Internet
    - PC_2 (Client) kann auch ins Internet, wenn PC_1 die Internetverbindung aufgebaut hat (via Proxy, dazu habe ich bei PC_2 unter Extras àInternetoptionen àVerbindungen àLAN-Einstellungen; die IP des Proxys eingestellt)

    Nun besteht folgendes Problem:

    - auf PC_2 ist ein email-account bei gmx eingerichtet (Outlook_Express)
    - PC_2 kann, wenn er selbst die Internetverbindung aufgebaut hat, emails senden und empfangen.

    Ich möchte, dass der email-account von PC_2 auch funktioniert, wenn PC_1 (Server) die Internetverbindung aufgebaut hat.

    Dazu habe ich auf PC_1 (Server) ein ?Portmapper? (analogx) installiert und konfiguriert. Dann habe ich auf PC_2 (Client) den gleichen gmx-email-account in Outlook hinzugefügt und statt der Mailserver die IP und Ports des Server angegeben.

    Auf PC_2 ist also zweimal der gleiche gmx-email-account in Outlook eingerichtet einmal für die direkte Internetverbindung und einmal für die Verbindung via PC_1 (?Client à Server?).

    1) Der Mailempfang und ?versand via ?Client à Server? funktioniert. Nur muß man jedes Mal, wenn man eine email schreibt angeben ob diese mittels des Standard-email-accounts oder ?ClientàServer-account? versand werden soll. (Problem 1)

    2) Ein weiters Problem ist, dass beim Abrufen des email-accounts immer eine Fehlermeldung kommt, da entweder der Standard-email-account oder der ?ClientàServer-account? nicht abgerufen werden kann (da ja immer nur eine Verbindung möglich; entweder von PC_2 selbst aufgebaut oder via ClientàProxy). (Problem 2)

    Wie kann man dieses umgehen???

    Der Explorer auf PC_2 erkennt doch auch, ob eine direkte Internetverbindung besteht oder ob er den ?Umweg? über den Proxy machen muß...

    Vielen Dank
    Carsten
     
  2. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Guten Abend!

    Tja, das sind eigentlich keine richtigen Fehler, sondern sieht (für einen Proxy) ganz normal aus.

    Ich hatte auch am Anfang einen Proxy, aber dann hab ich heimlich ein Verhältnis mit Linux begonnen. Und hab nicht aufgepaßt - und schwups - hatte ich einen kleinen Router (ei-du-du-du!).

    Mit einem Router können auch ganz viele (oder einer) ins Internet (tonline/DSL/ISDN/analog). Wozu brauch ich die tonline Software? Keine Ahnung, ich vermiss sie auch nicht!

    Ports sind plötzlich egal (naja fast), automatische Einwahl, Firewall. Und es ist einfacher, als einen Proxy zum Laufen zu kriegen.

    Nein, ich bin beileibe kein Linux-Freak. Aber begeisterter Anfänger. Wenn du Interesse hast, schick mir doch eine Mail (wenns funktioniert ;-) )

    Es geht einfach alles ohne irgendwelche Verrenkungen (drei email-accounts, auch tonnline, keine Ahnung welche ports *g*) usw.

    mfg
    Raphael
     
  3. Carsten R.

    Carsten R. Kbyte

    Registriert seit:
    26. Mai 2002
    Beiträge:
    183
    Hi Raphael,

    vielen Dank für die Antwort.
    Also das ganze funktioniert ja auch... ich habe ein Konto für "baby@storch.com" angelegt um die Mails via Proxy (1027/1012) abzuholen
    und dann noch mal das "baby@storch.com"-Konto um die Mails mittels der T-Online-Software abzuholen (110/25).

    Wenn der Proxy aus ist, dann bekomme ich eine Fehlermeldung, weil eine Verbindung zu (1027/1012) nicht möglich ist.

    Wenn der Proxy an ist, dann bekomme ich eine Fehlermeldung, weil eine Verbindung zu (110/25) nicht möglich ist...

    Außerdem muß man für jede neue Nachricht einstellen ob sie via (1027/1012) oder (110/25) gesendet werden soll.

    Bis die Fehlermeldungen erscheinen vergeht eine gewisse Zeit (Zeit bis zum Timeout) und das "blockiert" den Rechner dann auch noch :-(

    Das ist das Problem.... irgendeine Idee???

    Wünsche ein schönes Wochenende!!!

    Gruß
    Carsten
     
  4. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Hallo Carsten!

    Ich weiß zwar nicht so ganz genau was du eigentlich möchtest, aber ungefähr - ich erklär es einfach mal allgemein:

    Der Port: Es kann nur einen geben (wie Highländer) Einen Port darf man nur einmal öffnen. Auch der Proxy.

    Du brauchst in Outlook o.ä. über Proxy einen freien "Hilfsport". Sagen wir mal 1025 und 1010. Diese Anfrage übersetzt der Proxy in den richtigen Port und emailadresse und Benutzer.

    willy@mail.org, ports proxy in: 1025/1010
    anna@mail.de, ports proxy in: 1026/1011
    baby@storch.com, ports proxy in: 1027/1012

    Den Proxy mußt du natürlich entsprechend einrichten.

    Tipp: Sehr schön im Forum vom janaserver erklärt.

    mfg
    Raphael

    PS: Portnummer darf sein zwischen 1 und 65535
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen