NTFS-Partition wird versteckt

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von uwehl, 22. November 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. uwehl

    uwehl ROM

    Registriert seit:
    22. November 2004
    Beiträge:
    7
    Hallo zusammen,

    Nachdem LILO im MBR installiert wurde, wird die XP-Partition beim Booten immer versteckt. Natürlich kann dann XP nicht gestartet werden - hat jemand eine Lösung?

    Gruß Uwe
     
  2. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Muss an der Bootloader-Konfiguration liegen. Poste doch mal das entsprechend Grub/Lilo-File.
     
  3. uwehl

    uwehl ROM

    Registriert seit:
    22. November 2004
    Beiträge:
    7
    Das ging ja schnell!

    Also mit LILO-File meinst Du ja wohl die .conf, aber was erwartest Du zu GRUB?

    Muß noch dazu sagen: LINUX startet, ebenso '98, nur XP versagt, weil immer wieder versteckt.

    Danke erstmal, Uwe
     
  4. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Es kann ja nur eins von beiden relevant sein. Mit welchem Bootloader arbeitest du denn ?
     
  5. uwehl

    uwehl ROM

    Registriert seit:
    22. November 2004
    Beiträge:
    7
    Gut,

    ursprünglich habe ich sowohl '98 als auch XP installiert, der Bootloader von XP hat das problemlos für mich geregelt.

    Danach kam dann KNOPPIX (auf HD), Option: LILO in MBR.

    Jetzt kann ich - über LILO - Linux starten, wenn ich mich für Windows entscheide meldet sich der Bootloader von XP, aus der '98 (FAT32) Partition. '98 startet ebenfalls, natürlich nicht gleichzeitig (dummer Witz, entschuldige bitte).

    Nur wenn ich XP auswähle - vom XP-Bootloader - schlägt's fehl, weil, nach meiner Beobachtung, LILO die XP(NTFS)-Partition immer wieder versteckt, auch wenn ich sie mit PartitionMagic vorher sichtbar gemacht habe.

    Habe auch versucht, von LILO aus direkt auf XP zu schalten, das scheitert wegen fehlendem ntldr.

    Gruß Uwe
     
  6. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Wenn du von Lilo aus nicht den NT-Bootloader aus aufrufen kannst, dann solltest du folgende Variante ins Kalkül ziehen : Installiere Lilo in den Bootsektor der Linux-Partition. Dann kannst du den Bootloader als Datei extrahieren, auf die XP-Bootpartition bringen und mit dem NT-Bootloader laden. Der MBR würde dann mit fixmbr wieder durch einen Windows-MBR überschrieben werden. Als Bootmanager fungiert dann also allein der NT-Loader. In der boot.ini stehen XP; Win 98 und Linux zur Auswahl.Wenn dich diese Variante interessiert, kann man ins Detail gehen.
     
  7. uwehl

    uwehl ROM

    Registriert seit:
    22. November 2004
    Beiträge:
    7
    Okay, das werde ich mal versuchen, halte ich für die 2.beste Lösung.

    Interessieren würde mich aber schon, warum das oben beschriebene Verhalten auftritt.

    Melde mich heute Abend wieder, zunächst vielen Dank.

    Gruß Uwe
     
  8. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Hallo uwehl,

    poste doch mal den Inhalt Deiner lilo.conf, vielleicht verrät uns diese, wo das Problem liegt.;)

    Ansonsten habe die Lösungsvorschläge von franzkat meist die Eigenschaft, ziemlich clever und ausgefuchst zu sein.:D

    MfG
    Rattiberta
     
  9. uwehl

    uwehl ROM

    Registriert seit:
    22. November 2004
    Beiträge:
    7
    Ist ja schon gut,

    habe LILO Unrecht getan, es ist so, dass sich XP selber versteckt, da ist irgendwas kaputt.

    Unmittelbar vor KNOPPIX lief es noch - ich schwöre - das ist schon ein blöder Zufall.

    Die lilo.conf hat inzwischen bei "boot=" den Verweis auf eine bootfähige Partition, diese wurde aktiviert und sowohl LINUX als auch '98 funktionieren. XP werde ich einfach mal neu installieren und gucken was passiert.

    Wenn es überraschende Erkenntnisse geben sollte - kann aber dauern - melde ich mich in diesem Thread nochmal, ansonsten betrachtet ihn als von mir aus beendet.

    Ich habe nie an Kompetenz gezweifelt und bedanke mich

    Uwe
     
  10. uwehl

    uwehl ROM

    Registriert seit:
    22. November 2004
    Beiträge:
    7
    und es liegt doch an LILO...

    beim Aufruf einer Windows-Partition wird die jeweils andere versteckt, LILO selber ist das aber egal, nur ein nachgeschalteter XP-Bootloader, der dann nochmal die Partition wechselt, sieht plötzlich nichts mehr.

    Das ist durchaus sinnvoll wenn man z. B. Win98 und OS/2 gleichzeitig auf seiner Platte haben möchte.

    Vielen Dank für Eure Aufmerksamkeit, und vielleicht hilft es ja noch jemandem.

    Gruß Uwe
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen