NTFS Partitionen

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von ReneW, 16. Februar 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Ist es normal das man sich den Inhalt von NTFS Partitionen nur als ROOT anschauen kann?
     
  2. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Weiß zwar nicht was der Befehl umask=000 bewirkt und ob es wirklich an diesem lag, aber jetzt funktioniert es. Also Danke für deine Hilfe.
     
  3. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Ich hab hier einen interresanten Eintrag aus der Manpage von Mount:
    uid=value, gid=value and umask=value
    Set the file permission on the filesystem. By default, the files are owned by root and not read­able by somebody else.

    Dabei könnte dir Punkt 5 dieser Seite weiterhelfen: http://www.pl-berichte.de/work/newbie/mount.html

    Ich denke der Tipp mit dem umask=000, den ich ich oben erwähnt habe, hätte dir geholfen.
     
  4. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Er hat keine Schreibberechtigung (die hat nur der Root), aber eine Leseberechtigung. Im Prizip sind es die selben Einstellungen wie bei den FAT32 Partitionen und die kann ich ja auch als normaler User mounten.
     
  5. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Bist du dir auch wirklich 100%ig sicher, dass der User von den Dateien /dev/hda1 und /windows/C lesen kann?
    [Diese Nachricht wurde von Marsch am 16.02.2002 | 19:00 geändert.]
     
  6. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Also gelöscht habe ich nichts, jedenfalls nicht bewusst und die Partition wurde auch von fdisk (linux) gefunden.

    Der Befehl war genau das was ich brauchte, allerdings bin ich jetzt wieder da wo ich heute schon einmal war. Theoretisch habe ich (als normaler User) das Recht C zu mounten und Daten zu lesen , praktisch funktioniert es nur als ROOT.
    [Diese Nachricht wurde von ReneW am 16.02.2002 | 18:53 geändert.]
     
  7. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Ja, weil das Kontrolzentrum scheisse ist. Benutze lieber einen Befehl wie "df" um nach deinen Partitionen zu sehen.
    Wenn du das Verzeichnis gelöscht hast, dann mach doch einfach nen neuen Mountpunkt. "mkdir /windows/C" (Großschreibung beachten)
     
  8. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Bei mir kommt der Ferhlermldung
    mount: Mountpunkt /windows/c existiert nicht

    hda1 ist aber im Kontrollzentrum gelistet und als mounpunkt steht dort /windows/c
     
  9. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Seit wann gibt mount Fehlermeldungen in der Art "C nicht gefunden" aus?

    Das ist eine echte mount Fehlermeldung:
    mount: wrong fs type, bad option, bad superblock on /dev/hda1, or too many mounted file systems

    Kann es sein, dass das eine Fehlermeldung von KDE ist oder irgendeiner GUI ist?
     
  10. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Das war erst eine FAT32 Partition.
    Habe nur ein paar Befehle aus den I-net ausprobiert (einbinden von NTFS Partitionen) und bekomme jetzt (egal ob als ROOT oder normaler User) nur die Meldung "C nicht gefunden".
     
  11. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Wechsel des Dateisystems? Hast du versucht das Ganze als vfat zu mounten? Dabei sollte eigentlich nichts passieren. Was für Meldungen bekommst du, wenn du mount /dev/hda1 eingibst?
     
  12. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Ich glaub das war ein Fehler mit dem Wechsel des Dateisystem, jetzt wird so unter Linux nicht mal mehr angezeigt bzw. gefunden.
     
  13. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Die Mountflags scheinen in Ordnung zu sein. Ich selbst habe keine NTFS-Partitionen, aber bei meinen FAT-Partitionen gebe ich zusätzlich noch umask=000 an, um als User darauf zu schreiben. Vielleicht wird das NTFS auch für das Lesen benötigt. Du solltest auf jeden Fall noch "chmod 777 /windows/C" und "chmod 666 /dev/hda1" eingeben, um sicher zu gehen, dass der User auch die Berechtigung hat von dem Device und aus dem Mountpunkt zu lesen.
     
  14. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Der "fstab" Eintrag heißt

    /dev/hda1 /windows/C ntfs noauto,user 0 2

    Laut INFO (Eigenschaften) haben alle Benutzer das Recht C zu mounten und ihnen sollte auch der Inhalt angezeigt werden. Im Verzeichnis /Windows/ wird mir C aber als gesperrt angezeigt.
     
  15. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Eigentlich nicht. Post mal die Linie aus der /etc/fstab, in der die Partition aufgeführt ist und die Rechtevergabe des Mountpointes (ls -l "verzeichnis wo du das ding reinmountest"), dann wissen wir warum.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen