Öffnen mit

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von ledi, 25. August 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. ledi

    ledi Byte

    Registriert seit:
    21. März 2004
    Beiträge:
    46
    Hallo,
    bei dem Versuch eine Datei im Explorer (rechte Maustaste) zu Öffnen (Öffnen mit). steht warum auch immer die Option (Datei immer mit dem ausgewählten Programmtyp öffnen) nicht mehr zur Verfügung. War wohl ein kleines Spielchen mit der Registry !?
    Kann man das reparieren?

    Wer weiss Rat?

    ledi
     
  2. IVIisterX

    IVIisterX Byte

    Registriert seit:
    23. August 2004
    Beiträge:
    30
    Hallo!

    Etwas ähnliches herumprobiert?!



    HKEY_CLASSES_ROOT\ *



    erstellen Sie einen neuen Schlüssel mit dem Namen "shell", unter diesem Schlüssel einen weiteren mit dem Namen "openas" und darunter einen weiteren Schlüssel mit dem Namen "command" (der Registryzweig sollte nun folgendermaßen aussehen:



    "HKEY_CLASSES_ROOT\ *\ shell\ openas\ command".



    Hier tragen Sie nun bei "(Standard)" folgenden Aufruf ein:



    "RunDLL32 shell32.dll,OpenAs_RunDLL %1"



    bzw.



    "RunDLL32 shell32.dll,OpenAs_RunDLL %2" (Dadurch wird der Eintrag "Diesen Dateityp immer mit diesem Programm öffnen" automatisch deaktiviert).



    Ab jetzt wird für alle Dateitypen im Kontextmenü ein weiterer Eintrag "Öffnen mit..." angezeigt.



    Sie können auch den Text vorgeben mit dem der Eintrag im Kontextmenü angezeigt werden soll. Dafür geben Sie einfach bei:



    HKEY_CLASSES_ROOT\ *\ shell\ openas



    unter "(Standard)" den Text an der Angezeigt werden soll, wenn Sie vor einenm Buchstaben noch ein & (Shift +6) setzen können Sie auch noch einen Kurzbuchstaben mitgeben.



    Wenn Sie hinter %1 noch ein Leerzeichen angeben, wird im "Öffnen mit..." Dialog automatisch der Eintrag "Diesen Dateityp immer mit diesem Programm öffnen" deaktiviert und Sie können so nicht aus Versehen die Standardverknüpfung zu einem anderen Programm verändern. Es ist aber einfacher dafür dann gleich %2 zu benutzen.

    Gruß
    IVIisterX
     
  3. ledi

    ledi Byte

    Registriert seit:
    21. März 2004
    Beiträge:
    46
    Hey, IVlisterX,

    das war ein Spitzen - Profitip mit dem Eintrag in der Registry. Jetzt funktioniert wieder alles normal.
    Vielen Dank !
    Gruß
    ledi
     
  4. ledi

    ledi Byte

    Registriert seit:
    21. März 2004
    Beiträge:
    46
    Hey, IVlisterX,

    1.) es funktioniert zwar nach einigen Test's alles normal, im Kotextmenü habe ich aber nun nach Aufruf zwei ÖFFNEN Optionen (der eine Fett dargestellt der andere Eintrag normal dargestellt) nicht wie vorher ÖFFNEN und ÖFFNEN MIT.

    Wenn mir schon ein freundlicher Profi antwortet, na dann hätte ich gleich noch ein zweites Problem wo sich sogar Microsoft die Zähne ausbeisst !
    2.) Durch irgendeine, wahrscheinlich, zusätzliche Installation oder Ordnererstellung (Windows XP Home Edition) hat sich am Ende des Windows Explorers bei Aufruf von ARBEITSPLATZ unter dem dubiosen Abschnitt - ANDERE ein leerer SYSTEMORDNER eingetragen den ich anklicken und öffnen (zeigt nichts an) aber nicht mehr entfernen oder verändern kann.
    Auch die Hotline von Microsoft und andere Hotlines sind komplett hilflos und frustriert (traurig, traurig) ! Es ist im System garantiert kein Dialer, Spyware, Wurm, oder sonst ein Schädling vorhanden. Das wurde alles bis ins Detail mehrfach geprüft !!!

    mfG
    ledi aus Wien

     
  5. IVIisterX

    IVIisterX Byte

    Registriert seit:
    23. August 2004
    Beiträge:
    30

    Hallo ledi!

    Habe etwas mit der Registry rumprobiert:

    Die "fette" Öffnen-Option ist das alte Öffnen; die normale "Öffnen"-Option ersetzt die alte Öffnen Mit-Option. Dadurch wird Dir aber wieder die Möglichkeit eröffnet, den ausgeblendeten Punkt "Diesen Dateityp immer mit diesem Programm öffnen"anwählen zu können.
    Löscht man den angelegten Schlüssel in der Registry wieder, ist alles wieder wie vorher.
    Notlösung sieht daher wie folgt aus:
    Brauchst Du die Option "Diesen Dateityp immer mit diesem Programm öffnen" wieder, legst Du den Schlüssel an; danach löschst Du Ihn halt wieder.

    In der Hoffnung Dir geholfen zu haben

    viele Grüße
    IVIisterX
     
  6. IVIisterX

    IVIisterX Byte

    Registriert seit:
    23. August 2004
    Beiträge:
    30
    Hallo ledi!

    Ist im Arbeitsplatz unter Menüpunkt Ansicht > Ordneroptionen > Ansicht > erweiterte Einstellungen das Häkchen vor "Systemsteuerung unter Arbeitsplatz einblenden" ? Wenn ja machs mal weg und kontrolliere mal, ob der Ordner verschwindet.

    Gruß
    IVIisterX
     
  7. ledi

    ledi Byte

    Registriert seit:
    21. März 2004
    Beiträge:
    46
    Hallo IVIisterX,

    ja,beide - na ja, da kann ich anklicken was ich will der verdammte, dubiose Ordner ist immer da !!!

    Der Bildschirm sieht im Arbeitsplatz folgendermassen aus:

    FESTPLATTEN
    Lokaler Datenträger (C:)
    Lokaler Datenträger (E:)
    Lokaler Datrenträger (F:)

    GERÄTE MIT WECHSELMEDIEN
    CD Laufwerk (D:)

    ANDERE
    _ (das ist der rechteckige, dubiose, gelbe Systemordner)
     
  8. ledi

    ledi Byte

    Registriert seit:
    21. März 2004
    Beiträge:
    46
    ....... Sorry,vor lauter Frust und Hektik habe ich vergessen zu unterschreiben !

    mfG
    ledi
     
  9. IVIisterX

    IVIisterX Byte

    Registriert seit:
    23. August 2004
    Beiträge:
    30
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen