Openoffice setzt verdeckte Links

Dieses Thema im Forum "Office-Programme" wurde erstellt von waldgeis, 9. November 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. waldgeis

    waldgeis Byte

    Registriert seit:
    10. September 2000
    Beiträge:
    37
    In der letzten Version von Open Office werden beim konvertieren von Dokumenten zu HTML- Seiten, verdeckte Links direkt zu Google.com gesetzt. Festgestellt hat dies ein Bekannter von mir.
    Ich konnte den Vorgang selbst noch einmal nachvollziehen.

    Dies geschieht folgendermassen.
    1. Text mit Open Office erstellen.
    2.Persönlichen Link für HTML- Seiten zum dazugehörigen Ordner
    setzen,wenn dieses Dokument als HTML-Seite fungieren soll.
    3.Hier setzt Open Office an und schreibt unbemerkt vom Anwender " Http:\\ " vor den Link.
    In dem "Http:\\" steckt der versteckte Link zu Google.com.

    Das Ergebnis war, das mein Bekannter erst einmal seine eigenen Dokumente nicht mehr bearbeiten konnte, und er auch keinen Zugriff auf diese hatte. Da er zur gleichen Zeit nicht im Internet war, kam beim anklicken seines Html Links eine Fehlermeldung, mit dem Hinweis " Keine Seite bei Google.com verfügbar".

    Das lässt darauf schliessen, das wenn er im Internet gewesen wäre,seine Dokumente unter Google.com frei einsehbar gewesen wären. Dies ist aber dann wohl doch des guten zuviel, Oder? Weiteres will ich zu dem Sachverhalt nicht veräussern
    -ausser, dass das wohl nicht`s mit Datenschutz zu tun haben kann.

    Mit dem Programm AceHtml kam er diesem Sachverhalt auf die Spur. Und in diesem Programm konnter er dann auch diesen unseligen Link wieder entfernen. Nun hatte er sofort wieder Zugriff auf seine eigen Dokumente.

    Zu guter letzt ein Beispiel:
    Ich will einen Link von meinem erstellten Html-Dokument zu dem dazu gehörigenOrdner setzen, also "< a href=Pfad>"

    Dieser Link wird durch Open Office wie folgt geändert "<ahref=http:\\Pfad>".
    (Dieser link verhindert den Zugriff au die eigenen Dokumente.)

    Wenn ich das "http:\\" aus dem Link entferne, ist alles wieder Ok.

    Probiert es selbst aus!!!!!

    PS. Für mich ist dieses Beispiel ein wesentlicher Grund dafür, das ich die Hände von Open Office weglasse.
    Wer weiss was da noch so alles versteckt wird um den Anwender zu "entblössen.:bse:
     
  2. waldgeis

    waldgeis Byte

    Registriert seit:
    10. September 2000
    Beiträge:
    37
    Hi alle mitteinander,
    ich bedanke mich ganz herzlich, für die sachlichen Hinweise und die ehrliche Kritik, die ich gern annehmen möchte. Vor allem die Form der Anfrage muss ich überdenken.

    Wichtig- Mir ging es nicht darum OOo nieder zu reden!!!!
    Ich wollte eigentlich wissen ob andere und wie ähnliche Erfahrungen gemacht haben und wie man solch ein Problem löst.
    Natürlich habe ich nicht soviel Ahnung von OOo,da ja mein Bekannter und nicht ich das Problem hatte.

    Was den Hinweis von Kuckuck betrifft "eine Pfadangabe fängt nun mal nicht mit "http:// an", so nochmals, genau darin lag das Problem. Mein Bekannter hatte den Pfad richtig eingegeben, aber irgendwie wurde beim konvertieren dieser Pfad davor gesetzt.

    Na ja, egal. Ich will nun wirklich nicht der Verursacher eines sinnlosen Streits unter uns werden.

    Meinen besonderen Dank an Autum und RaBerti1. Ihre Hinweise sind vieleicht zur Lösung des Problems sinnvoll. Danke noch mal für Eure Hilfe:D
     
  3. RaBerti1

    RaBerti1 Viertel Gigabyte

    Registriert seit:
    24. November 2000
    Beiträge:
    5.094
    Aus der Hilfe von OpenOffice1.0:

    Suchwort: "Link" Auswahl "Link erstellen"
    _____________
    URL erkennen
    Ist dieses Feld markiert, versucht OpenOffice.org, in Ihrem Dokument Zeichenfolgen, die ein URL sein könnten, zu erkennen. Jeder erkannte URL wird automatisch in einen Hyperlink auf diesen URL verwandelt.
    _____________

    Wat macht nu OO, wenn der Link nicht gefunden werden kann? Es wird die voreingestellte Suchfunktion bemüht. Daß OO da direkt eine Suchmaschine in Dokumente eingetragen hätte, halte ich allerdings bis zum Beweis des Gegenteils für ein Gerücht.

    Trag doch einfach mal was Unvollständiges in Deinem Browser ein und dann schau, wer oder was sich meldet.

    OO pauschal zu verteufeln halte ich für völlig unangebracht. Es ist gut und richtig, daß Konkurrenz vorhanden ist. Sie belebt bekanntermaßen das Geschäft. Noch mehr Monokultur können wir wirklich nicht gebrauchen.

    Und das automatische Erkennen von URLs soll übrigens bei gewerblichen Schreibprogrammen so ähnlich ablaufen. Ich laß mich da aber gern belehren.

    MfG Raberti
     
  4. autum

    autum Kbyte

    Registriert seit:
    17. Dezember 2002
    Beiträge:
    330
    Hallo waldgeis,
    trotz eifrigen Bemühens konnte ich das Problem nicht nachvollziehen. Bei mir (und offenbar auch bei vielen anderen) verhält sich OOo korrekt. :cool:
    Ich will nicht in Abrede stellen, dass das Ergebnis bei Euch so war, wie Du es darstellst, allerdings kann ich mir nicht vorstellen, dass OOo das ohne Euer Zutun gemacht hat (vermutlich habt Ihr irgendwelche Einstellungen verändert).:confused:
    Mit anderen Worten: Deine pauschale Kritik ist unangebracht.:rolleyes:
    Gruß autum
    P.S.
    Am etwas rüden Ton im Thread bist Du durch Deine Formulierung nicht ganz unschuldig.
    Abgesehen davon: Dein Ursprungsposting enthielt weder eine Frage, noch eine Bitte um Hilfe oder auch nur eine (für mich reproduzierbare) Fehlerbeschreibung.
    Oder war das Ganze ein Trollversuch?
     
  5. waldgeis

    waldgeis Byte

    Registriert seit:
    10. September 2000
    Beiträge:
    37
    Ich hab versprochen zu antworten,also tu ich es.
    Nach der Rücksprache mit meinem Bekannten, habe ich erfahren,
    dass er das Dokument mit Star Office 5.2 geschrieben und es dann in OpenOffice übernommen und konvertiert hat.
    Was den persönlichen Link betrifft so meinte ich eigentlich den direkten Link zum Ordner auf dem eigenen PC.
    In der Sache aber ist es so und nicht anders gelaufen.
    Ps. Mein Bekannter hat Open Office deinstalliert.


    Noch eine kurze Bemerkung zu kuckuck,h3adbang3r und Co.Kg.
    Ich beteilige mich nicht an Eurem geistigen Dünnschiss. Ich wollte Hilfe und keine Frotzeleien. Wenn Ihr so erfahrene Benutzer seit,müsstet Ihr eigentlich mehr zu sagen wissen als "Heisse Luft unterwegs" und "keine Ahnung" haben.
    Ich bedanke mich dennoch bei allen, die mir gute Hinweise gegeben haben oder wollten.
     
  6. waldgeis

    waldgeis Byte

    Registriert seit:
    10. September 2000
    Beiträge:
    37
    Hi autum,
    Bitte hab noch ein weilchen Geduld mit der Antwort, ich muss mich erst noch mal mit meinem Bekannten konsultieren. Ich antworte auf jedenfall.
     
  7. autum

    autum Kbyte

    Registriert seit:
    17. Dezember 2002
    Beiträge:
    330
    Hallo Waldgeis,
    Dein Posting hat mich neugierig gemacht, da ich dieses Verhalten bisher noch nicht kannte (abgesehen davon, dass ich HTML-Code in Phase5 schreibe). Deshalb habe ich es 'mal ausprobiert (OOo1.1).
    Ich habe einen Text geschrieben und verschiedenen Links eingefügt (sowohl von Hand, als auch mit Einfügen/Hyperlink). Anschließend habe ich das Dokument als HTML-Seite abgespeichert.
    Was soll ich sagen, bei mir macht die Seite genau das, was sie soll. Sowohl die Links auf Webseiten (http://) als auch auf (interne) Verzeichnisse (file://) werden korrekt gesetzt.
    Was mache ich falsch? :verzweifelt:
    Außerdem weiß ich nicht, was ein "Persönlicher Link" ist - vielleicht liegt mein Fehler hier.
    Gruß autum
     
  8. waldgeis

    waldgeis Byte

    Registriert seit:
    10. September 2000
    Beiträge:
    37
    Hy Piggi,
    ob Du das was ich schreibe für grossen Unsinn hällst oder nicht, sei mal dahin gestellt.
    Was Dein Hinweis auf die slahes betrifft, habe ich auch keinen Widerspruch. Fakt ist, das Open Office ein zum Html konvertiertes Dokument so wie beschrieben ändert.
    Ob in der Html Zeile der Link versteckt ist, kannst Du ja selbst mal prüfen.
    Ich wollte nur einen Hinweis geben, über einen Sachverhalt den mein Bekannter gemacht hat. Im übrigen haben wir das überprüft, eben mit AceHtml. Sorry für " meinen Unsinn".
     
  9. piggy

    piggy Freigeist

    Registriert seit:
    18. April 2000
    Beiträge:
    719
    pardon, aber das was dur da schreibst halte ich für einen großen unsinn.
    Warum ein http:// (sorum gehören die slahes übrigens) auf einem rechner zu Google führt, weiß ich nicht. Aber versteckte links legt OpenOffice garantiert nicht an. Bevor du solche behauptungen aufstellst, solltest du vielleicht versuchen erst einmal die ursache herauszufinden.
    In HTML können außerdem gar keine links versteckt sein. Du kannst den quelletext ja jederzeit lesen und dann siehst du wo er hinführt.
    Und wenn du wissen willst, was OpenOffice genau macht, dann lese dir den quelltext durch. Den gibt es zum herunterladen.
    Hier liegt ja gerade der unterschied zu kommerziellen produkten: der anwender kann sich jederzeit im quelltext über die funktion der software informieren. Da gibt es keine geheimnisse.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen