Ordner lassen sich nicht sperren

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von Rafi, 20. Oktober 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Rafi

    Rafi Byte

    Registriert seit:
    20. Oktober 2003
    Beiträge:
    9
    Hi!

    Meine Ordner lassen sich nicht sperren. Ich haben alles wiehier gemacht.

    Allerdings habe ich keine NTFS sondern eine FAT32 Formation, da ich diese von meinem alten Betriebssystem übernommen habe (Win98SE).

    An was kann das liegen?

    Danke im Vorraus!

    Rafi
     
  2. Rafi

    Rafi Byte

    Registriert seit:
    20. Oktober 2003
    Beiträge:
    9
    Danke für eure Hilfe, aber ich habe gerade beschlossen bei FAT32 zu bleiben und mir ein Programm, dass meine Ordner mit Passwörtern schützt runterzuladen.
     
  3. Rafi

    Rafi Byte

    Registriert seit:
    20. Oktober 2003
    Beiträge:
    9
    So, jetzt hab ich auch noch defragmentiert und es sind 46 % freier Speicher am Laufwerk.
    Geht trotzdem nix.
    Ich hab alles gemacht was ihr aufgeschrieben habt!
     
  4. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo kukkuck !

    Ich habe mir die von Dir angegebenen Seiten mal angeschaut. Auf den MS-Seiten werden mögliche Gründe für Fehler bei der Konvertierung angegeben; auf die Rolle der MFT wird dabei aber nicht explizit eingegangen. Die Seite der TH Zürich äußert sich bei dem Thema MFT so :

    "Der Zugriff auf die MFT spielt eine entscheidende Rolle in der Zugriffszeit bei einem NTFS Laufwerk. Da die MFT selber eine Datei ist, kann sie wie alle anderen Dateien auch, fragmentiert werden. Um dies zu Verhindern, wird bei einem neuen NTFS Laufwerk eine gewisse Anzahl Clusters (Standard: 12,5 %) um die MFT herum freigehalten. Dies funktioniert aber nur solange die Disk nicht bis an die Grenzen voll ist, dann werden diese Clusters vom System quasi wieder eingezogen. Auch wenn extrem viele Dateien gespeichert werden und diese Zone nicht mehr für alle MFT-Einträge reicht, entsteht Fragmentierung, da diese Einträge in anderen Bereichen des Laufwerks gespeichert werden müssen

    Aber was besagt das über auftretende Schwierigkeiten bei der Konvertierung ? Das, was in dem Textausschnitt beschrieben wird, sind Probleme, die nach der Etablierung eines NTFS-Dateisystems auftreten können. Z.B. ist es ja auch erst bei einem schon vorhandenen NTFS-System möglich, über die Registry den Platz für die MFT-Einträge großzügiger zu organisieren :

    HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ FileSystem

    Eintrag : NtfsMftZoneReservation
    Wert : 1 -> 12,5%
    Wert : 2 -> 25%

    mfg franzkat
     
  5. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Die MFT wird ja ohnehin am Anfang des Volumes angelegt und belegt dort standardmäßig 12,5% des Speicherplatzes. Das heißt der am Anfang eines Volumes liegende Bereich muß bei einer Konvertierung nach NTFS in jedem Fall freigemacht werden.D.h., die MFT sucht sich hier nicht irgendwo eine ausreichende Lücke (bzw. findet dann keine ausreichend große), sondern beansprucht selbstbewußt die erste Reihe.Übrigens wird ja in der logischen Mitte des Volumes nochmals eine Kopie der ersten drei Records der MFT angelegt.
     
  6. Steve Balmer

    Steve Balmer Byte

    Registriert seit:
    5. Oktober 2003
    Beiträge:
    76
    möglicherweise hast du nicht genügend zusammenhängenden freien speicher für die MFT auf dem Laufwerk. Defragmentiere das Laufwerk und probiere es nochmal mit dem Konvertieren.

    MFG
    SteVe
     
  7. Prinz181

    Prinz181 Guest

    :) Sfc /SCANNOW gebe dies mal in die ,,Eingabetafel"ein.
     
  8. Rafi

    Rafi Byte

    Registriert seit:
    20. Oktober 2003
    Beiträge:
    9
    "CHKDSK kann nicht ausgeführt werden, weil dsa Volumen von einem anderen Prozess verwendet wird. Soll dieses Volumen überprüft werden, wenn dsa System dsa nächste Mal gestartet wird? (J/N)"

    Hab ich gemacht und dann alles nochmal.
    Funktioniert aber trotzdem nicht.
     
  9. XP Fan

    XP Fan Megabyte

    Registriert seit:
    6. August 2002
    Beiträge:
    1.258
    Hallo,

    lasse chkdsk mit der Option f laufen. Also chkdsk / f so wird nicht nur geprüft sondern auch Fehler behoben.

    Gruß

    Uwe
     
  10. Rafi

    Rafi Byte

    Registriert seit:
    20. Oktober 2003
    Beiträge:
    9
    Dann kommt folgende Meldung:
    "Auf dem Volumen sind möglicherweise Inkonsistenzen. Führen sie CHKDSK aus.
    Die Konvertierung ist fehlgeschlagen.
    E: wurde nicht in NTFS konvertiert."

    CHKDSK hab ich schon ausgeführt. Und dann alles nochmal.
    Bringt aber nix.
     
  11. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Bei einer solchen Konvertierung verlierst du keine Dateien.Es wird nur ein anderes Dateisystem für deine Daten aufgebaut.
    Gehe auf Start -> Ausführen -> cmd

    Dann gibst Du den Befehl ein :

    CONVERT Laufwerk: /FS:NTFS

    Für Laufwerk setzt Du den Laufwerkbuchstaben ein, der für das zu konvertierende Laufwerk steht; also wahrscheinlich c
     
  12. Rafi

    Rafi Byte

    Registriert seit:
    20. Oktober 2003
    Beiträge:
    9
    Ok. Und wie mach ich das ohne Daten zu verlieren?
     
  13. Gast

    Gast Guest


    Guten Morgen,

    Natürlich geht das so wie hier nur mit NTFS und nicht mit FAT32.

    Wo liegt also dein Problem??

    Convertiere zu NTFS und dann kannst du es so machen wie im Artikel beschrieben.

    :aua: :aua:
     
  14. Rafi

    Rafi Byte

    Registriert seit:
    20. Oktober 2003
    Beiträge:
    9
    In der Anleitung steht lediglich, dass man auf Ordneroptionen usw. gehn muss.

    Spielt das überhaupt eine Rolle, wenn ich nur einzelne Ordner sperren will?

    Kennt jemand eine Möglichkeit mit FAT32 einen Ordner zu sperren?
     
  15. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Ich frage mich, wie du das gemacht haben willst, denn die Anleitung basiert ja auf einem NTFS-System.Du schreibst aber, du hättest FAT32.Wie erklärt sich der Widerspruch ?
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen