Partitionen verschwinden !!!!!!!!!!!!!

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Der Eiserne II, 22. Juni 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    Ich habe gestern mir meinen daten Server mit SuSE 8.2 aufgesetzt. Meine Partition sieht so aus
    hde1 / 4 GB
    hde2/Swap 256 MB
    hde3/Home 2 GB
    hde4/ ServerPlatte1 31 GB
    hdg1/ServerPlatte2 21 GB

    Nur leider bin ich gestern dahahinter gekommen daß er mir am DestktopIcon ServerPlatte2 immer die falsche gräße angegeben hat ( von hde1 ) nach dem ich das Icon gelöscht habe ist es auch bei ServerPlatte1 aufgetreten. Und wieder habe ich das Icon gelöscht. Nun hatte ich das Problem auch im Konqueror unter / mit ServerPlatte1 und ServerPlatte2. Auch hier habe ich wieder beide Ordner gelöscht. Bin in YAST2 gegangen und habe die Partitionen neun eingehängt. Nur leider seit dem verschinden sie immer nach einem Neustart. Außerdem bekomme ich auch keine schreibrechte auf die Paltten mehr. Ich habe die /etc/fstab mit hilfe des Paretitionierer angebast. In der etc/fstab sehen die Zeilen so aus.
    /dev/hde4 /ServerPlatte1 user,auto,rw,exec,umask=000
    /dev/hdg1 /ServerPlatte2 user,auto,rw,exec,umask=000

    Bitte was kann ich jetzt noch machen. Ich habe das Problem schon mal gehabt und habe in meiner Verzweiflung Linux neu aufgesetzt. Ich wei das ist die Windows Art aber ich bin leider ein Anfänger und weiß mir nicht anders zu Helfen.

    Danke.
     
  2. emacs

    emacs Megabyte

    Registriert seit:
    10. Dezember 2002
    Beiträge:
    1.031
    Hallo,

    um Schreibrechte zu erlangen, kannst du dich als Root anmelden, wenn dann der KDE-Desktop erscheint, legst du Verknüpfungen der Laufwerke auf dem Desktop an und machst einen Rechtsklick darauf. In dem Kontextmenü kannst du die Rechte einstellen.

    emacs
     
  3. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Wie Du selbst geschrieben hast, kann man mit der Option umask bei fat32-Partitionen den Schreibzugriff auf alle Benutzer übertragen.
    Leider ist die Part. aber nicht mit fat32 formatiert. Wie für reiserfs die genaue Option lautet, müsste ich erst nachlesen.

    MfG
     
  4. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    Ich muß dich leider verbessern. Ich habe nicht nur bei den Eigenschaften von den Desktop Icon die Falschen angeben von größe usw. gehabt sondern auch die Daten waren bcw sind nicht zu sehen. Die fstab habe ich bearbeitet weil ich als Benutzer keine schreibrechte hatte ich wollte daher user,re,exec,umask=000 eingeben. Doch ich habe keine schreibrechte bekommen.
    Ich hatte das selbe schon bei meinem Leptop,gehabt nur da bin ich in meiner Verzweiflung in YAST2 gegangen zum Partitionieren und habe bemarkt daß man nach dem man eine Partiton ausgewählt hat und dann auf Bearbeiten geht rechts ein Button ist der fstab-Optionen heißt. Wenn man den drückt kann man unten in einer Zeile die Optionen Angeben wenn man auß den Fenstern mit OK geht und dann auf Anwenden geht kommt ein grünes Fenster und nach dem werden die Option in die fstab geschrieben und sofort angewendet. Das war die einzige Art wie es SuSE 8.2 auf meinem Leptop geschluckt hat daß ich als Benutzer auf eine FAT 32 Partition auch schreibrechte bekommen habe. Daher habe ich daß jetzt auch sofort gemacht wie das eintragen in der fstab direkt nichts gebracht hat. Nur wie ich jetzt wieder dei zeilen user,rw,exec,umask=000 Über jatzt in die fstab eingetragen habe hat mit auch der Konqueror die falschen Werte angezeigt und ich habe keine Daten auf den Laufwerken ( Ordnern ) gehabt. Habe umask=000 händisch aus der fstab gelöscht und siehe da die Werte haben nach einem booten wieder gestimmt, aber schreibrechte habe ich noch immer keine. Da ich den PC aber aks Daten Server verwenden will brauche ich schreibrechte auf den Beiden Partitionen. Hat einer eine Idee was ich noch machen kann.
     
  5. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    df gibt bei mir schon die richtige Größe aus (die entsprechende Part. habe ich natürlich vorher gemountet, sonst machts ja keinen Sinn).
    Aber die KDE-Icons auf dem Desktop zeigen IMMER, egal ob gemountet oder nicht, die falsche Größe an.
    Nicht, dass mich das stören würde, nur den Fragesteller hat es dazu veranlaßt, seine fstab umzustricken.
    MfG
     
  6. buherator

    buherator Byte

    Registriert seit:
    5. Juni 2003
    Beiträge:
    90
    Ich hab auch mal ein ähnliches Problem gehabt. ich hab 2 10gb partitionen. die eine ist / und die andere /mnt/space. Nun, df sagte, dass ich keinen freien platz mehr hatte, aber es waren nur 10gb belegt. Lösung: /mnt/space war nicht gemountet (nicht automatisch) und es wurde alles auf / geschrieben. Vielleicht gehts hier auch eher um ein mount problem...

    mfg
     
  7. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Der Dateisystemeintrag lautet dann reiserfs.
    MfG
     
  8. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    "Nur leider bin ich gestern dahahinter gekommen daß er mir am DestktopIcon ServerPlatte2 immer die falsche gräße angegeben hat ( von hde1 ) nach dem ich das Icon gelöscht habe ist es auch bei ServerPlatte1 aufgetreten."

    Da habe ich nun seit über einem Jahr mein jetztiges SuSE installiert und bin noch nie auf die Idee gekommen, bei den Desktop-Icons der Partitionen nachzuschauen, welche Plattengröße angegeben wird.

    Es werden auch bei mir falsche Größen angegeben. Ein KDE-Fehler?
    Konsolenabfrage mit df gibt die richtigen Werte aus.

    Das Löschen von Icons oder Ordnern ändert nicht wirklich etwas an der Systemstruktur, werden diese neu erstellt, hat man den Ausgangszustand wieder hergestellt.
    Unklar ist mir allerdings, was Du dabei mit yast gemacht hast?

    Änderungen in der fstab haben dagegen Einfluß auf Systemfunktionen.
    Wenn man sich bei Änderungen unsicher ist, sollte man die alte Einstellung erstmal stehen lassen und durch Voransetzen eines # lediglich deaktivieren. (# wirkt wie ein rem in dos-Konfigurationsdateien)

    MfG
     
  9. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    Entschuldige das habe ich in meiner Pamik vergessesn es ist Reiser FS.
     
  10. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Der Ausschnitt aus Deiner fstab irritiert mich etwas:
    Normalerweise ist die Form
    Gerät - Mountpoint - DATEISYSYSTEM - Benutzer - Art des Zugriffs
    Bei Dir wird das Dateisystem nicht genannt.
    MfG
    Nachtrag:
    z.B.
    /dev/hde4 /ServerPlatte1 vfat user,auto,rw,exec,umask=000
    (für fat32)
    [Diese Nachricht wurde von Rattiberta am 22.06.2003 | 20:18 geändert.]
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen