Partitionstabelle ungültig ?

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von thomsen99, 19. Juli 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. thomsen99

    thomsen99 Byte

    Registriert seit:
    27. April 2004
    Beiträge:
    8
    Hallo

    habe heute meine festplatte aus dem ersten rechner ausgebaut und in meinen
    zweitrechner eingebaut. Dort hatte ich Windows XP und suse 9.0 installiert.
    Gebootet habe ich mit lilo. Nach dem starten hatte suse nen kernel panic und windows xp hat immer wieder einen reboot gemacht, weil es ja ein ganz anderer rechner ist.
    Dann wollte ich erst xp installieren und anschliessend suse. Wenn ich dann beim formatieren bin und der rechner anschliessend die daten von cd auf festplatte spielt ist noch alles in ordnung , aber danach macht der rechner einen neustart und dann geht es mit der installation nicht mehr weiter weil dort dann "Partitionstabelle ungültig" steht. Habe es schon per r-konsole mit fixboot probiert immer noch der gleiche fehler.Mit der suse boot cd lässt es sich leider auch nich mehr starten :-(

    Danke im voraus!
     
  2. blablah

    blablah Kbyte

    Registriert seit:
    21. Juni 2004
    Beiträge:
    174
    was sagt denn das BIOS zu der Platte,
    wird die richtig erkannt?

    Prüfe nochmal, ob der IDE-Modus
    (LBA und anderer DOS/Windoze verschuldeter Blödsinn)
    bei dem neuen Rechner so eingestellt ist,
    wie beim alten.
     
  3. thomsen99

    thomsen99 Byte

    Registriert seit:
    27. April 2004
    Beiträge:
    8
    also im bios wird die festplatte erkannt aber warum muss ich denn die ide einstellungen vom alten rechner übernemen ?
     
  4. blablah

    blablah Kbyte

    Registriert seit:
    21. Juni 2004
    Beiträge:
    174
    die Abbildung der Plattengeometrie hat heute nichts
    mehr mit der physikalischen Geometrie zu tun.
    So lassen sich Platten manchmal wahlweise
    z.B. mit 15 oder 16 Köpfen ansprechen.
    Und LBA gibts auch noch.
    http://en.wikipedia.org/wiki/Logical_block_addressing

    Wenn die Geometrie der Platte geändert werden soll,
    muss die Platte komplett neu partitioniert
    und formatiert werden
     
  5. thomsen99

    thomsen99 Byte

    Registriert seit:
    27. April 2004
    Beiträge:
    8
    Ok dann muss ich wohl alles sichern und dann komplett neu partitionieren und formatieren.
    Nun habe ich die festplatte wieder in meinem ersten rechner eingebaut und mit partition magic die partitionen gelöscht. Leider habe ich am anfang der festplatte einen bereich 7,8MB gross der sich nicht mit den anderen partitionen zusammenfügen lässt. Dieser bereich war vorher auch schon da hat der irgendetwas mit dem bootloader lilo zutun , kann ich diesen bereich nur mit der start cd von suse wieder löschen ?
     
  6. thomsen99

    thomsen99 Byte

    Registriert seit:
    27. April 2004
    Beiträge:
    8
    so habe jetzt alles neu partitioniert und formatiert habe aber jetzt immer noch das gleiche problem. Ist jetzt Linux daran schuld oder is die festplatte schrott. Fixboot und Fixmbr bríngen auch nichts. Ich kann mit der xp start cd formatieren und die daten auf festplatte schreiben aber nach dem nächsten neustart steht immer ungültige Partitionstabelle oder invalid partition table.?:aua:
     
  7. blablah

    blablah Kbyte

    Registriert seit:
    21. Juni 2004
    Beiträge:
    174
    seltsam.
    Sind die Geometrien alt/neu wirklich verschieden gewesen?
    -> aufschreiben und vergleichen.

    Die Festplatte war nun im neuen Rechner eingebaut,
    neu Partitioniert und immer noch ist die Partitionierungstabelle kaputt ...
    ich erinnere mich an die fdisk-Manpage und Absurditäten.
    Unter bestimmten Umständen wird empfohlen, den MBR
    komplett zu löschen, hd. mit Nullen überschreiben,
    um danach eine neue Tabelle anzulegen.
    Geht folgendermassen:
    eine Live-Linux-CD starten (Knoppix oder SUSE im Rettungsmodus)
    dann
    dd if=/dev/zero of=/dev/hda bs=512 count=1
    erst dann neu partitionieren.

    Es gibt aber noch eine andere Möglichkeit:
    alte BIOS mit 32GB/64GB oder 128GB Beschränkungen.
    Gibt meist Probleme bei alten P1/P2-Boards und >32GB Platten.
     
  8. thomsen99

    thomsen99 Byte

    Registriert seit:
    27. April 2004
    Beiträge:
    8
    Danke für die Antworten !

    Habe es jetzt hinbekommen, habe einfach alles zu einer Partition gemacht und die gesamte festplatte formatiert.
    Anschliessend liess es sich dann wieder normal installieren ohne die Fehlermeldung "ungültige Partitionstabelle".
    Warum weiss ich nich, aber hauptsache es hat gefunzt :-)
     
  9. coralle

    coralle Byte

    Registriert seit:
    21. März 2003
    Beiträge:
    11
    :cool:

    Hi,

    Dualität der Ereignisse. Ich habe das ganze letzte Wochenende damit verbracht haargenau das gleiche Problem zu beseitigen. Da ich auch kein Fachmann bin habe ich einen ähnlichen Weg beschritten: ABER das Problem liegt wohl im Boatloader von Linux:Grub, der erkennt oder findet anscheinenend nicht den Anfang der Partitionen, wenn man, wie ich mit PArtiton Magic eine Größe einer PArtition ändert.
    Es geht aber, wenn man mit dem Klammeraffengriff nach dem Erscheinen der NAchricht: ungültige Partitionstabelle- über Setup die CD wählt und die LINUX Install-CD einlegt, dann bootet das System von der CD und man kann dann in Linux einfach mal im Boatloader nachsehen, einmal öffen und wieder schließen, fragt nach speichern-ja, und dann nochmal probieren, bei mir hat es geklappt.
    Ich wollte nicht die Festplatte kpl. formatieren, da ich eine Sicherungspartition hatte, auf der alle persönlichen Dokumente gespeichert waren.

    Gruß
     
  10. KiIIUAII

    KiIIUAII Byte

    Registriert seit:
    10. November 2003
    Beiträge:
    19
    Vielleicht ist mein Problem ja auch damit verbunden...

    Ich bin stolzer Besitzer einer 160GB Platte von WesternDigital, die hervorragend als primäre Bootpartion in meinem alten Rechner (Pentium mit 800MHz, Win2k SP4) lief.

    Nun schloß ich unlängst das Drecksding an meinen neuen PC an und zwar an einen EIDEController (UDMA 100) (P4 3.4 mit WinXP SP2 bootet von ner S-ATA Platte von Western Digital)

    Nach dem Anschliessen kams wie's kommen musste, trotz der Einstellungen im XP auf Übergröße bei EIDE und aktualisierung der Controllerkarte, erkennt der Controller nur eine 32GBPlatte, meine OntrackrettungsCD 8.4GB (aber nicht mal den ODD) und WindowsXP möchte gerne formatieren....

    Hat irgendjemand eine Idee, wie ich wieder an meine Daten komme???
    Ich wollte gar nichts an der Geometrie ändern, oder so...
    Viel schlimmer ich will auf GAR Keinen Fall Formatieren (wegen der noch (so Gott will) existierenden Daten...

    Bin mittlerweile echt verzweifelt....
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen