1. Liebe Forumsgemeinde,

    aufgrund der Bestimmungen, die sich aus der DSGVO ergeben, müssten umfangreiche Anpassungen am Forum vorgenommen werden, die sich für uns nicht wirtschaftlich abbilden lassen. Daher haben wir uns entschlossen, das Forum in seiner aktuellen Form zu archivieren und online bereit zu stellen, jedoch keine Neuanmeldungen oder neuen Kommentare mehr zuzulassen. So ist sichergestellt, dass das gesammelte Wissen nicht verloren geht, und wir die Seite dennoch DSGVO-konform zur Verfügung stellen können.
    Dies wird in den nächsten Tagen umgesetzt.

    Ich danke allen, die sich in den letzten Jahren für Hilfesuchende und auch für das Forum selbst engagiert haben. Ich bin weiterhin für euch erreichbar unter tti(bei)pcwelt.de.
    Information ausblenden

php..avatar upload funzt net

Dieses Thema im Forum "Programmieren" wurde erstellt von Tara_nr9, 11. Februar 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Tara_nr9

    Tara_nr9 Byte

    hallo!
    hab da mal ne frage...bei ne forum hab ich das problem das ich keinen avatar hochladen kann....er sagt mir das die funktion move_uploaded_file irgendwie keine berechtigung dazu hat. ich hab hier mal die entsprechenden zeilen kopiert, die fehlerzeile schreib ich einfach nochmal hier hin: $move_file($avatar_filename, './' . $board_config['avatar_path'] . "/$new_filename");
    damit ihr die leichter findet.....hoffe auf eure hilfe... danke!

    if ( $mode == 'editprofile' && $current_type == USER_AVATAR_UPLOAD && $current_avatar != ' )
    {
    if ( file_exists(@phpbb_realpath('./' . $board_config['avatar_path'] . '/' . $current_avatar)) )
    {
    @unlink('./' . $board_config['avatar_path'] . '/' . $current_avatar);
    }
    }

    if( $avatar_mode == 'remote' )
    {
    @copy($tmp_filename, './' . $board_config['avatar_path'] . "/$new_filename");
    @unlink($tmp_filename);
    }
    else
    {
    if ( @$ini_val('open_basedir') != ' )
    {
    if ( @phpversion() < '4.0.3' )
    {
    message_die(GENERAL_ERROR, 'open_basedir is set and your PHP version does not allow move_uploaded_file', ', __LINE__, __FILE__);
    }

    $move_file = 'move_uploaded_file';
    }
    else
    {
    $move_file = 'copy';
    }

    $move_file($avatar_filename, './' . $board_config['avatar_path'] . "/$new_filename");
    }

    @chmod('./' . $board_config['avatar_path'] . "/$new_filename", 0777);
     
  2. stefanniehaus

    stefanniehaus Halbes Megabyte

    versuche mal über dein FTP-Programm alle Bilddateien und den Ordner in dem die Bilder sind per chmod auf 777 zu stellen. Kann sein dass die Dateien schreibgeschützt sind.
    Soetwas sollte auch in der Anleitung zur Installation des Forums stehn, falls eine dabei ist
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen