Problem mit Excel-Formel "WENN/UND"

Dieses Thema im Forum "Office-Programme" wurde erstellt von murkelmel, 12. September 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. murkelmel

    murkelmel Byte

    Registriert seit:
    12. September 2002
    Beiträge:
    25
    Ich habe eine Excel-Formel mit Wenn-Und-Funktion. So weit alles klar. Nach Prüfung der Funktion soll ein "Dann-Wert", in meinem Fall eine Zahl, ausgegeben werden. Auch bis hier ist alles kein Problem. Nun habe ich mehrere Solcher Funktionen untereinander, bei denen jeweils ein "Dann-Wert" als Zahl ausgegeben wird. Ich möchte nun die "Dann-Werte" summieren.

    Das funktioniert nicht !!!

    Hat jemand eine Lösung?
     
  2. Kein Problem, gerne geschehen!!
    Mit "" ist die Ausgabe Text und nicht Zahl, das ist der Trick.
    Viel Vergnügen noch!

    Gruß MM
     
  3. murkelmel

    murkelmel Byte

    Registriert seit:
    12. September 2002
    Beiträge:
    25
    GIGANTISCH

    Vielen Dank, es funktioniert !!!

    Die Zeichen "" waren das Problem!
    Laut Excel-Buch muß man es so eingeben. Dem ist wohl nun nicht so!

    Vielen, vielen Dank an alle !!!
     
  4. Gäbe es den Smalltalk hier nicht, könnte ich gepflegt schlafen ;-)
     
  5. nightwing

    nightwing Kbyte

    Registriert seit:
    21. März 2001
    Beiträge:
    412
    Genau darauf bin ich auch gerade gekommen, naja, das nächste mal wieder.:)
    Wie isses so in der Anstalt beim nasepopeln?;):)

    Grütze nightwing
     
  6. nightwing

    nightwing Kbyte

    Registriert seit:
    21. März 2001
    Beiträge:
    412
    O.K., ich denke, wir kommen dem Verständnis näher. deine Formel hat als die Form: wenn(Bedingung;dann A1=1;"")
    Wo bei mir jetzt "" steht, stehen bei dir ja wohl weiter verschachtelte Bedingungen, die dann auch entsprechen andere Werte liefern. Habe das genauso wie Matthias in Excel 97 geprüft ohne Probleme.
    der Fehler muß in der Formel liegen, poste die mal, dann haben wirs gleich hoffe ich.

    Grütze nightwing
     
  7. NEIN!
    Die Formel sieht so aus:
    =WENN(C12=1;1;0)

    Wobei c12=1 irgendeine Bedingung ist. Die Ergebnisse 1 und 0 dürfen nicht in "" stehen, weil dann das Ergebnis keine Zahl!!
     
  8. murkelmel

    murkelmel Byte

    Registriert seit:
    12. September 2002
    Beiträge:
    25
    ja, der dann-wert steht in "". muß so sein, sonst funktioniert die formel ja nicht.
    wenn ich die ergebnis-zellen nun als text formatiere, kommt nach wie vor als ergebnis 0 raus!

    Danke für die schnelle Antwort!
     
  9. Kann es sein, dass Du die Zahlen in der wenn-dann Bedingung in "" gesetzt hast?? Dann ist es Text und keine Zahl!!

    Gruß MM
     
  10. murkelmel

    murkelmel Byte

    Registriert seit:
    12. September 2002
    Beiträge:
    25
    habe ich auch schon probiert.
    dann erschein "#WERT!"
     
  11. murkelmel

    murkelmel Byte

    Registriert seit:
    12. September 2002
    Beiträge:
    25
    Die Formel, denke ich, ist nicht das Problem. Die funktioniert einwandfei.
    Das Problem ist die Summierung der Ergebnisse.
    Es liegt wohl daran, das die Ergebnisszellen nicht "reine" Zahlen sind, sondern ein Ergebnis der Funktion, sogenante "Dann-Werte". Diese müssen ja in der Funktion mit " eingegeben werden.
    Hier vermute ich das Problem, daß die summierung das Ergebnis nicht als Zahl ansieht.

    Kommst Du mit oder soll ich die Formel mal abdrucken?
    Wie gesagt, die Formel funktioniert allerdings ohne Probleme.

    Auch Dir Danke für die schnelle Antwort!
     
  12. DasExperiment

    DasExperiment Kbyte

    Registriert seit:
    3. Juni 2002
    Beiträge:
    330
    Hi,

    Wenns nicht gerade eine Unmenge an Zahlen sind kannst Du ja mal probieren sie zu addieren, mal sehen was dann passiert.
    Hab das eben bei Excel 97 mal probiert, funktioniert einwandfrei. Stehe da ehrlichgesagt auch etwas auf dem Schlauch. Aber mal sehen vielleicht fällt mir ja nochwas ein.

    MfG

    Matthias
     
  13. nightwing

    nightwing Kbyte

    Registriert seit:
    21. März 2001
    Beiträge:
    412
    Laß mich sehen, ob ich das richtig verstanden habe.
    Du hast eine Formel von folgender Struktur:
    WENN Bedingung A und Bedingung B erfüllt sind DANN Ausgabe von Ergebnis A in zelle C1 SONST irgendetwas anderes.
    Die Summe der Ergebnisse von Spalte C oder D möchtest du danach summieren.
    Schreib mal was zur Struktur deiner Tabelle, in welcher Spalte stehen welche Werte. Eigentlich sollte alles funktionieren. Ich denke momentan an einen Fehler in der Formel.

    Grütze nightwing
     
  14. murkelmel

    murkelmel Byte

    Registriert seit:
    12. September 2002
    Beiträge:
    25
    Danke für die schnelle Antwort!

    Ja, die Formeln stehen in unterschiedlichen Zellen und die Ergebnisse (stets die Zahlen 1,2 oder 3 oder "leer", wenn keine "Wenn/Und-Funktion" zutrifft) möchte ich aufsummieren. Als Ergebnis, bei Eingabe "=SUMME(A1:A9)", erscheint "0".

    Kannst Du was damit anfangen?
     
  15. DasExperiment

    DasExperiment Kbyte

    Registriert seit:
    3. Juni 2002
    Beiträge:
    330
    Hi,

    damit ich das erstmal richtig schnalle. Die wenn Formeln stehen aber in unterschiedlichen Zellen oder? Und die Ergebnisse der verschiedenen Zellen möchtest Du aufsummieren. Oder versuchst Du das ganze in einer Zelle zu realisieren?
    Spuckt Excel irgendwas brauchbares aus sprich Fehlermeldung oder erscheint einfach kein Wert in der Zelle in der summiert werden soll?

    MfG

    Matthias
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen