[PROBLEM] Samba-2.2.4 / Windows XP

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Moses24, 31. Mai 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Moses24

    Moses24 ROM

    Registriert seit:
    31. Mai 2002
    Beiträge:
    2
    Hi!

    Ich habe auf meinem SuSE 7.3 Rechner Samba 2.2.4 installiert. Samba läuft zufriedenstellend, und ich kann auch problemlos von einem Win2k system auf die erstellten Freigaben zugreifen und Daten kopieren.

    Nun zu meinem Problem:

    Wenn ich versuche mit einem WinXP Client Daten auf den Samba-Rechner zu kopieren bekomme ich nach ca. 1 Minute die Meldung: Der Pfad ist zu lang (bei jeder Datei, funktioniert bei Win2k). Anschließend existiert eine Datei mit der richtigen Größe, allerdings ist diese defekt.
    Allerdings tritt dieses Problem erst bei Dateien auf, die größer als ca. 20kb sind

    Daten vom Samba-Server zu lesen funktioniert, allerdings bei XP sehr viel langsamer als unter Win2k.

    Jetzt noch was Eigenartiges (hab ich grad bemerkt):
    Wenn ich mich von dem XP-Rechner über eine VPN-Einwahl (Win2kAS) ins Netzwerk einwähle, kann ich Daten kopieren.
    Hab das momentan allerdings nur über eine Modem-Verbindung getestet.

    Hier noch meine Netzwerkkonfiguration:

    PDC (Win2kAS): 192.168.0.1
    Samba-Server: 192.168.0.2

    Client 1 (Win2k): 192.168.0.3
    Client 2(WinXP): 192.168.0.4
    Client 3(WinXP): 192.168.0.20
    Client 4(WinXP): 192.168.0.21
    Client 5(Win2k): 192.168.0.23

    VPN (WinXP): 192.168.0.102

    Hat irgendjemand eine Idee, woran das liegen könnte??
    Für Hilfe wäre ich echt dankbar!

    Moses

    PS: Hab auch schon neuinstalliert, hat nichts geholfen
     
  2. iCebird

    iCebird Kbyte

    Registriert seit:
    20. November 2001
    Beiträge:
    316
    Hi,

    also der NetBIOS Session Service liegt auf 139,
    auf 445 liegt der Microsoft-DS.
    Soweit ich weiß ist der 445 jetzt für die Dateiübertragung zuständig.
    Frag mich nicht ob udp oder tcp, hab das grad mal gescannt und mich dann an einen Artikel aus irgendeiner PC-Zeitschrift erinnert, aber halt nur dunkel.

    Gruß Ralf
     
  3. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    das ist typisch M$ ...

    Ist es jetzt nicht mehr 137, 138 und 139? (weiss nicht auswendig was davon udp oder tcp ist.)

    Danke für die Info

    MfG
     
  4. frubi

    frubi Byte

    Registriert seit:
    23. Mai 2002
    Beiträge:
    12
    hallo leute

    ich habe herausgefunden das ms in einem win2k sp die ports für die dateiübertragung geändert hat.

    ciao
     
  5. Moses24

    Moses24 ROM

    Registriert seit:
    31. Mai 2002
    Beiträge:
    2
    Hi!

    Hab mich wieder einen halben Tag mit meinem Problem beschäftigt und bin nun wieder ein Stückchen weiter.
    Irgendwie liegt das an der Netzwerkverbindung, wenn ich die auf 10Mbit runterdrehe funktioniert alles (deshalb auch das mit der VPN-Verbindung).
    Ich hab auch schon die 2 Rechner (Samba-WinXP) direkt (cross-over Kabel) miteinander verbunden, also glaub ich nicht dass es irgendwie an der Verkabelung liegt.
    Leider ist mir noch nicht ganz klar, warum die Win2k Rechner mit 100Mbit funktionieren, aber ich werds schon noch rausfinden (wozu denn auch schlafen, wenn man vorm Rechner sitzen kann *g*)

    @Jedi
    Ich hab Linux neu installiert, aber auch einer der WinXP Clienten ist praktisch jungfräulich (nur ein Office drauf)
    Und ich hab nicht mit irgendwelchen XP-Tuningtools herum gehandwerkt.

    @Bamm-Bamm
    Natürlich DER Moses, kennst einen anderen *g*
    Das mit dem XP-Problem hab ich auch gelesen, das ist aber glaub ich nur wenn ich vom Samba-Rechner auf den XP-Rechner zugreifen will.
    W2k deshalb als PDC, weil es den Linux-Rechner erst seit 2 Tagen gibt, und der muss ja erst mal vernünftig funktionieren.
    Aber dann werd ich\'s mir durch den Kopf gehen lassen.

    Euch allen jedenfalls mal ein großes THX!!

    Moses
     
  6. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Hallo Moses! (DER Moses? Sorry, musste sein)

    Erst vor kurzem habe ich gelesen, dass XP ein Problem mit Samba hat. Ob mit Absicht oder nicht sei dahingestellt. Wahrscheinlich gibt es wohl eine neuere Version von Samba, die diese Inkompatibilität behebt.

    Ich hab mich nicht weiter damit beschäftigt, weil mir das Verhalten von XP und Microsoft mißfällt. Bisher hab ich auch kein Gummibärchen-Windows.

    mfg
    Raphael

    P.S. Ich seh gerade w2k als PDC ?? Warum nicht den Samba-Server? Nur so als Anregung
    [Diese Nachricht wurde von Bamm-Bamm am 31.05.2002 | 18:01 geändert.]
     
  7. Jedi

    Jedi ROM

    Registriert seit:
    16. Juni 2000
    Beiträge:
    7
    Was hast du denn neu installiert XP od Linux?

    Ich hab mit der neuen Samba version keinerlei probleme, mit meinen XP clients.

    Drum tippe ich eher, dass du mit irgendwelchen XP - Tuningtools herum gehandwerkt hast.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen