Probleme bei Excel-Funktionen!

Dieses Thema im Forum "Office-Programme" wurde erstellt von Chiller856, 25. Mai 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Chiller856

    Chiller856 Byte

    Registriert seit:
    26. März 2002
    Beiträge:
    25
    Hi, ich habe da ein paar Probleme mit Excel-Funktionen und komme nicht weiter.

    1. Ich kann zwar bestimmte Werte aus einer Tabelle herausfiltern und daraus die Summe errechnen,
    z.B.: =SUMMEWENN(Tabelle1!B:B;"=A";Tabelle1!D:D)
    aber wie stelle ich es an, wenn ich die Summe herausfiltern möchte die aus zwei verschiedenen Spalten abhängig ist?
    Eine Lösung habe ich zwar gefunden, nämlich die zwei Spalten in einer neuen Spalte mit =B:B&C:C verbinden und dann aus dieser neuen Spalte das Ergebnis filtern.
    z.B.: =SUMMEWENN(Tabelle1!F:F;"=AX";Tabelle1!D:D)
    Ich möchte aber diese Berechnung lieber in einer einzigen Zelle durchführen und nicht extra einen zwischen Schritt machen.
    Gibt’s da etwas? Hab schon einiges Probiert (mit UND Verknüpfungen u.s.w.), aber leider kein erfolg.

    2. Dann habe ich noch ein Problem mit der Mittelwert Funktion, wenn einige Argumente noch 0 sind sollten sie bei der MW-Berechnung noch nicht berücksichtigt werden, wie könnte ich das anstellen?
    Wenn ich schon mit einer Tabelle Kalkulieren will, dann will ich nicht immer extra die Formeln dazu ändern müssen.

    3. Und dann noch eine winzige Kleinigkeit, wie kann ich einen positiven Wert in den gleichen negativen Wert umwandeln und umgekehrt? Ich finde einfach keine Funktion dafür?

    Hoffe jemand kann mir weiterhelfen!

    MfG Robbie
     
  2. Chiller856

    Chiller856 Byte

    Registriert seit:
    26. März 2002
    Beiträge:
    25
    OK, Danke für die Lösungen! Funktioniert alles prima :) nur schade, das diese Matrixformel nichts mit dem Bereich B:B anfangen kann!
    Aber Hauptsache es funktioniert. Ich hab’s auch schon öfter so ähnlich probiert, aber den Bereich immer mit B:B markiert
    und die Formel natürlich nicht mit STRG+UMSCHALT+EINGABE beendet!
    Danke nochmals für die Lösungen, hat mir jetzt sehr weiter geholfen.
     
  3. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Hallo,

    zu 1: Das kann man über eine sogenannte Matrixformel realisieren. In Deinem Fall wäre das:
    =SUMME(WENN(B1:B100&C1:C100="AX";D1:D100))
    Wichtig: Das geht nur mit Teilen der Spalte, nicht mit B:B, C:C etc.
    Und: Die Eingabe einer Matrixformel wird mit STRG+UMSCHALT+EINGABE beendet, nicht wie sonst üblich mit EINGABE.
    zu 2: Die Funktion ZÄHLENWENN kann man benutzen, um Zellen mit dem Wert 0 nicht mitzuzählen.
    Durch =ZÄHLENWENN(B1:B100;">0") erhält man die Anzahl der Zellen im Bereich B1:B100, die einen Wert >0 haben. Alternativ kann man auch schreiben: =ANZAHL2(B1:B100)-ZÄHLENWENN(B1:B100;"=0"). Dann werden auch leere Zellen nicht mitgezählt.
    zu 3: siehe oben: =-B1

    Hoffe, das hilft weiter, ansonsten ruhig nochmal nachfragen...

    Und tschüx
     
  4. 1995

    1995 Kbyte

    Registriert seit:
    20. November 2000
    Beiträge:
    128
    Zu 1. habe ich keine Lösung.

    Zu 2.:
    Wenn der Inhalt einer Zelle gleich Null ist, wird sie in jedem Fall in den Mittelwert einbezogen.
    Sie müssen dafür sorgen, dass die betreffenden Zellen "leer" sind. Wenn die Inhalte der Zellen berechnet werden, kann das mit
    "=WENN (Berechnung = 0; "" ; Berechnung)"
    geschehen.

    Zu 3.: "= - XY"

    mfg Fritz Weinel
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen