1. Bitte immer die Rechnerkonfiguration komplett posten!
    Vollständige Angaben zur Konfiguration erleichtern die Hilfestellung und machen eine zügige Problemlösung wahrscheinlicher. Wie es geht steht hier: Klick.
    Information ausblenden

Probleme mit XP im Netzwerk

Dieses Thema im Forum "Heimnetz und WLAN" wurde erstellt von Freese, 17. Oktober 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Hallo Leute !

    Habe mittlerweile alle Foren durch. Keiner kann mir so richtig weiterhelfen.

    Habe 4 XP Rechner und 2 x Win 2000 in einem Netzwerk.

    Netzwerkumgebung sehe ich alle Rechner. Klicke ich auf den Rechner sehe ich dort die freigegebenen Ordner. So ist es bei Win 2000 und bei einem XP Rechner. Bei den anderen erhalte ich diei Meldung "Zugriff verweigert"
    Woran kann das liegen. Habe 2 x XP Prof und 2 x XP Home im Netz.

    Die admintrativen Freigaben funktionieren alle ohne Probleme. Ich kann also manuell Netzlaufwerke freigeben wenn ich die Freigaben auf den Rechnern kenne.

    Habe auch schon identische Konten vergeben und Gast Konten aktiviert.

    Weiß nicht was ich noch einstellen soll. Welche Protokolle benötige ich ?

    Ist die Benutterverwaltung unter XP eine andere als unter Win 2000/NT ?

    Das Problem haben wohl ganz viele wie ich gelesen habe.

    Bin Admin von mehreren Netzwerken mit NT,98,Win2000. Da gibt es solche Probleme nicht.

    Für jeden Tipp dankbar.

    Gruß

    Freese
     
  2. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Daran könnte es in der Tat liegen :

    secpol.msc -> Sicherheitsoptionen -> Konten : Lokale Kontenverwendung von leeren Kennwörtern auf Konsolenanwendung beschränken :
    Deaktiviert
     
  3. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Danke für den Tipp !
    War alles richtig eingestellt. Auf XP Prof Rechnern klappt es jetzt denke ich.

    Aber warum muß das so kompliziert sein ? Denke Freigaben erteilen reicht und man muß drauf zugreifen können. Egal ob das nun XP/NT/2000/98 ist.

    Die administrativen Freigaben funktionieren ja. Aber wieso kommt denn sofort Zugriff verweigert ?

    Dann habe ich ja Zugriff.

    Ist ja nervig die Netzlaufwerke erst verbinden zu können wenn man die Freigabenamen kennt.

    Sehe ich irdendwo wie sich welcher Rechner wo anmeldet.

    Hab schon doppelte Konten, Gastkonto alles ausprobiert. Kein Erfolg.

    Was ist bei XP denn so anders ? Soviel habe ich da noch nie eingestellt !!

    Jetzt noch eine Sache. Habe ja noch 2 XP Home Rechner. Die kennen secpol.msc leider nicht.

    Noch jemand eine Ahnung wie man das da lösen kann ?

    Für jeden Tipp dankbar.
     
  4. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    XP ist halt ein echtes Multi-User-System mit anspruchsvollen Sicherheitsfeatures, die - und das ist wohl ein Grund für die Kompliziertheit - auch Linux in dieser Hinsicht übertrumpfen sollen.

    Es ist in der Tat wichtig, wenn die technischen Grundvoraussetzungen für Netzwerkverbindungen existieren und Freigaben erteilt worden sind, bei XP Pro-Rechnern mit NTFS zu überprüfen :

    a) sind die Berechtigungen für die Freigaben korrekt erteilt ?

    b) Sind die NTFS-Rechte ausreichend gesetzt ?

    c) Sind die besonderen Sicherheitsrichtlinien (secpol.msc) richtig gesetzt ?
     
  5. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Das ist wohl so.

    Habe gerade noch einen XP Home Rechner mal neu aufgesetzt. In's Netz gebracht usw.
    Da lautete die Meldung mit Fenster Verbinden als Gast. Hab ich dann auch gemacht. Danach kommt dieses Fenster nie wieder und ich habe Zugriff auf den PC ohne da was einstellen zu müssen. Schon merkwürdig.
    Krieg ich dieses Fenster nicht irgendwie wieder ? Das ich einmal als Gast auf den XP Home Rechner drauf komme und das der sich das dann merkt ?
    Wenn ich doppelte Konten anlege müße doch eigentlich alles klappen. Ist aber wohl nicht immer so. Wie gesagt von XP nach Win 2000 alles kein Problem.

    Wie gesagt bei zweien (XP Home) funktioniert es immer noch nicht.

    Bin da etwas ratlos muß ich zugeben.

    NTFS Rechte ? Wie setzt man die denn ?

    Gibt es im Netz oder sonst eine Anleitung dazu was man alles so beachten muß. Muß mich als Admin ja demnächst auch mit XP auskennen.
     
  6. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Unter XP muss man die erstmal nachrüsten, da sie eigentlich von MS für diese Distri nicht zur Verfügung stehen sollten, aber trotzdem in versteckter Form vorhanden sind. Installiere das Fajo-Tool :FaJo XP File Security Extension

    http://www.fajo.de/portal/index.php

    Gehe im Explorer auf :

    Extras -> Ordneroptionen -> Ansicht und nehme den Haken in der Checkbox : einfache Dateifreigabe verwenden weg.
    Anschließend klickst du mit der rechten Maustaste auf eine Datei/Verzeichnis und hast den Registerreiter 'Sicherheit' zur Verfügung. Hier kannst du dann NTFS-Zugriffsrechte setzen wie bei der Pro-Version auch. Die GUI ist identisch.
     
  7. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Das werde ich ja gleich morgen mal ausprobieren. Danke

    Bei dem einen Rechner XP Home der jetzt "Zugriff verweigert" sagt bin ich mir sehr sicher das das da schon mal funktioniert hat drauf zuzugreifen, denn ich habe auf anderen Netzwerkrechnern diverve Netzlaufwerke/Ordner und Drucker für diesen Rechner. Die habe ich bestimmt nicht manuell angelegt.

    Wo kann da der Haken liegen ? Habe nichts aber auch gar nichts am System geändert.

    Kommen der sache ja so langsam auf die Spur hoffe ich.

    Ach ja noch eine Frage:

    Was macht eigentlich der folgende Registry Eintrag ?

    hkey_local_machine
    => System
    => CurrentControlSet
    => Control
    => Lsa
    bei "restrictedanonymous" den wert von 1 auf 0 setzen

    Gruß

    Freese
     
  8. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Habe das mal ausprobiert. Jetzt klappt der Zugriff wieder ohne Probleme.

    Das war die Lösung:

    hkey_local_machine
    => System
    => CurrentControlSet
    => Control
    => Lsa
    bei "restrictedanonymous" den wert von 1 auf 0 setzen

    In Zusammenspiel mit dem Tipp von franzkat (http://www.fajo.de/portal/index.php)
    habe ich das Problem gelöst. Kann jetzt die Freigabe für Netzwerkzugriff konfigurieren.

    Habe noch eine Frage:

    Wenn ich jetzt von Windows 2000 auf XP zugreife habe ich kein Fenster "Verbinden als ...". Wo ich dann ein Paßwort eingeben kann. Ist sowas möglich das man das Fenster erzwingt ?

    Umgekehrt funktioniert das immer. Also von XP auf Windows 2000 kommt immer dieses Fenster und ich kann mich dann erst anmelden.

    Zumindestens bin erst mal einen Schritt weiter.

    Gruß

    Freese
     
  9. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Probier mal : net use \\rechnername /user:meinbenutzername
     
  10. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Was mach ich denn mit dem Befehl ? Irgendwie funktioniert der nicht oder ich habe noch nicht verstanden was ich da eingeben muß.
    rechnername: Rechner auf dem ich mich anmelden will ?
    user: welcher user ?
    meinbenutzername: Paßwort von welchem user ?

    Erklärst das bitte nochmal genauer ?

    Gruß

    Freese
     
  11. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Beispiel : Der Rechner heißt : Xanatos
    Der Account, unter dem du dich einloggen willst, heißt
    Zeus; dein Passwort für
    den Account, auf dem du dich einloggen wilst, heißt :
    Penelope

    Variante 1 : Du willst den Dialog mit der Kennworteingabe haben :

    net use \\Xanatos /user:Zeus -> Eingabemaske -> hier kannst du jetzt 'Penelope' eingeben.

    Variante 2 :All-in-One :

    net use x: \\Xanatos\namederfreigabe Penelope /user:Zeus

    Kommentar zu 2 :

    Die Freigabe namederfreigabe wird auf meinem Laufwerk mit dem Laufwerksbuchstaben X: eigehängt(gemountet); Passwort und Username werden mit dem Befehl selbst übergeben.
    (Funktioniert in der Form nur bei NT; bei Win 9x sieht der net use-Befehl etwas anders aus).
     
  12. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Danke für die Tipps !

    Habe das jetzt mal so eingegeben. Kriege aber keine Eingabeaufforderung nach
    Variante 1. Habe immer die Systemfehler 67 und 1219. Irdendwas stimmt da noch nicht. Außerdem besteht ein Konflikt zwischen den angegebenen und den schon bestehenden Anmeldeinformationen.
    Ich gebe dieses in der Eingabeaufforderung von Windows 2000 ein.

    Habe ich das richtig verstanden ?

    Kannst nochmal weiterhelfen.

    Habe mich übrigens mit den NTFS Sicherheitseinstellungen etwas vergallopiert.

    Habe mir jetzt eine Partition soweit gesichert das ich selber und alle Programme die darauf zugreifen weder lesen noch schreiben können. Toll !
    Damit muß ich mich nochmal beschäftigen. Ist eine gefährliche Sache hab ich festgestellt.

    Wie kann ich nun festlegen welcher User nun denn was darf ?

    ich gebe einen Ordner frei und muß dann über die NTFS Freigaben regeln welcher user was darf ? Oder geht das auch anders ? XP ist mir da etwas zu eigenmächtig finde ich.

    Für jeden Tipp dankbar.

    Gruß
    Freese
     
  13. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Dann mach mal folgendes :

    Gebe auf dem XP-Rechner den Befehl : control userpasswords2 ein,-> Registerkarte erweitert -> Kennwörter verwalten. Dort kannst du schon existierende Zuordnungen verändern/aufheben.
     
  14. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Ist ja interessant was man alles so über XP erfährt und wie versteckt dort einige Optionen sind.

    Hab grad noch einen Rechner in's Netz gebracht (XP Professional)

    Wenn ich per Netzwerk auf den Rechner zugreife kriege ich auf allen anderen Rechnern ein Login Fenster (Verbinden als Gast (XP) und Verbinden als ... (Win2000)).

    Soweit so gut. Jetzt habe ich den Eintrag in der Registry:

    hkey_local_machine
    => System
    => CurrentControlSet
    => Control
    => Lsa
    bei "restrictedanonymous" den wert von 1 auf 0 setzen


    überprüft. War aber richtig

    Gastkonto aktiviert.

    Immer noch kein Zugang auf den Rechner möglich.

    Dann habe ich folgendes gemacht:

    Mit Administratorrechten anmelden.
    Start, Ausführen und den Befehl "secpol.msc“ eingeben.
    Unter "Lokale Richtlinien, Zuweisen von Benutzerrechten“ Doppelklick auf "Zugriff vom Netzwerk auf diesen Computer verweigern“.
    "Gast“ aus der Liste der verbotenen Benutzerkonten löschen.

    Jetzt ist ein Zugriff möglich. Von allen Rechnern aus. Man braucht das Verbinden als Fenster nur einmal zu bestätigen und schon ist man auf dem Rechner.

    Jetzt kann man das Gastkonto getrost wieder deaktivieren. Der Zugang bleibt.

    Jetzt gelangt man von allen Rechnern aus ohne Verbinden als Fenster auf den Rechner.

    Wo wird das gespeichert ? Unter control userpasswords2 ein,-> Registerkarte erweitert -> Kennwörter verwalten ist nichts eingetragen. Bei Win2000 gibt es diese Einstellung glaube ich gar nicht ?

    Das war der Livebericht zur Installtion.

    So wie jetzt ist kann ich aber damit leben aber mein Interesse ist geweckt.


    Nach deaktivieren der einfachen Dateifreigabe kann ich ja alles einstellen was ich will. Werde wohl komplett zu XP Professional umschwenken.

    Hast du da einen Buchtipp der mir als Admin nützen könnte ? Schwerpunkt Netzwerke usw.

    Alles was du mir jetzt erzählt hast war mir neu.

    Aber dafür ist ja ein Forum da.

    Gruß

    Freese
     
  15. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Was die Eingabe-Maske anbetrifft : Versuche mal folgendes :

    Start -> Ausführen : \\rechnername
     
  16. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Das hat auch irdendwie nicht geklappt. Mein Netzwerk wird jetzt doch größer wie ich dachte. War noch am verkabeln usw.

    Überlege ob ich nicht eine Dömänenverwaltung aufbauen sollte. Mal sehen.

    Wenn ich jetzt die erweiterte Dateifreigabe bei XP Professional wegnehme kann ich ja einstellen wer auf einen bestimmen Ordner zugreigfen darf. Lokal auf dem Rechner klappt es ja. Aber ich weiß immer noch nicht als was sich eine anderer Rechner bei mir einloggt (Als Gast ?, als Admin). Das ist noch alles etwas undurchsichtig.
    Mir fehlt mein "Verbinden als Fenster"

    Hast du noch eine Idee dazu ?

    MfG

    Freese
     
  17. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Was ist eigentlich mit der oben von mir empfohlenen Variante 2. Hat die funktioniert ?
     
  18. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Soweit ich das probiert habe funktioniert das nicht. Aber habe jetzt schon soviel ausprobiert. Vielleicht mache ich da noch was falsch.

    Vielleicht hast du ja noch eine andere Lösung.
     
  19. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Naja, wenn man nun aber die Dinge offen und ehrlich betrachtet, dann bedeutet das, dass von den Kommandozeilen-Befehlen nichts funktioniert. Dann sollte man doch noch mal die Fehlersuche intensivieren.
     
  20. Freese

    Freese Byte

    Registriert seit:
    17. Oktober 2004
    Beiträge:
    24
    Ich will mich ja eigentlich nur als ein bestimmter Benutzter auf dem PC per Netzwerk anmelden. Dazu brauche ich dieses Verbinden als Fenster. Irgendwie merkt XP/Win2000 sich das ja wohl. Einmal als Gast angemeldet nie wieder ein Verbinden als Fenster.

    Obwohl schaut man unter XP nach ist man als Benutzter des Netzwerk PC's angemeldet.

    Wie das mit dem Gast so funktioniert ist mir nicht ganz klar.

    Fehler sind eigentlich nicht im Netzwerk nur habe ich wahrscheinlich noch nicht so den Durchblick den ich für diese Realisierung brauche.

    Wird schon werden.
    Forum sei dank.

    Gruß

    Freese
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen