Probleme mit Zugriffsrechten auf eingebundene Fat-Partition.

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Adana, 29. November 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Adana

    Adana Byte

    Registriert seit:
    17. November 2004
    Beiträge:
    32
    Hallo!

    Ich möchte mit meinem Linux (Suse 9.1, KDE 3.2, von PC-Welt CD) auf eine, im Dateisystem eingebundene Fat-Partition zugreifen.
    Leider kann ich selbst als Root die Zugriffsrechte für den (einzigen) Benutzer auf eben diese Partition nicht umstellen.

    In Yast gibt es unter 'Partitonieren' unter anderem die Optionen, Zugriffsrechte zuzuordnen, doch jedesmal wenn man die Einstellungen vornimmt und mit OK bestätigt, dann sind sie nach einem zweiten aufrufen der Option wieder verschwunden.
    Offenbar übernimmt Linux die Änderungen gar nicht.
    :heul:


    Ich habe auch die aktuellen Updates und Patches heruntergeladen und installiert.

    Kennt vielleicht jemand das Phänomen und weiß eine Lösung?
     
  2. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
  3. MissAntroph

    MissAntroph Halbes Megabyte

    Registriert seit:
    17. Februar 2004
    Beiträge:
    633
    mount /dev/hda1 /mnt/win_c -o umask=000

    -o umask=000 =alle(!) user haben schreibrecht auf alle(!) dateien der partition

    Eintrag unter /etc/fstab:
    /dev/hda1 /mnt/win_c vfat rw,user,umask=000

    der Eintrag user bedeutet, das auch user die platte mounten dürfen
     
  4. MissAntroph

    MissAntroph Halbes Megabyte

    Registriert seit:
    17. Februar 2004
    Beiträge:
    633
    sorry...das FAT habsch überlesen... :o
     
  5. Mylin

    Mylin Viertel Gigabyte

    Registriert seit:
    20. Juni 2003
    Beiträge:
    2.757
    Äh, wenn man das mounten über die UID beschränkt?
     
  6. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Was mich stutzig macht:
    Wenn bei der Installation von SuSE 9.1 eine FAT16/FAT32 Partition im System existiert und diese in Ordnung ist, dann wird sie automatisch mit rw-Rechten im System eingebunden und standardmässig beim Booten gemountet, nicht so NTFS - und das mit gutem Grund!

    Was ist hier also los? :confused:

    Gib an der Konsole mal mount ein, und schau, ob die Part. aufgeführt ist.
    Wenn ja, poste bitte die Ausgabe für diese Part., wenn nein, schau mal in der Datei /ect/fstab nach, ob sie dort erscheint.

    MfG
    Rattiberta
     
  7. Adana

    Adana Byte

    Registriert seit:
    17. November 2004
    Beiträge:
    32
    Also, die FAT-Partition wurde nicht beim Installieren mit eingebunden, sondern wurde später über Yast> Partitionieren eingebunden.

    Es handelt sich definitiv um eine FAT- und keine NTFS-Partition, denn parallel ist Win ME installiert (allerdings auf einer anderen Partition, die nicht eingebunden ist.)

    Die eingebundene Partition tacht auch in der etc/fstab auf, den Eintrag müßte ich noch einmal nachschauen, doch derzeit läuft der PC mit Windows.

    Ich werde mich später nocheinmal dazu melden, soweit aber erst einmal, herzlichen Dank Euch allen,

    Gruß,

    Adana
     
  8. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    NTFS Partitionen werden seit Suse8.0 eingebunden und gemountet
     
  9. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    kann zwar logischweise nicht drauf schreiben, hatte aber bis keine Probleme mit NTFS Partitionen




    Wenn ich micht recht erinnere sah der Eintrag damals bei mir etwa so aus.

    /dev/hda5 /windows/D vfat auto,users,gid=users,umask=0002,iocharset=iso8859-1
     
  10. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Sorry, da habe ich mich wohl mißverständlich ausgedrückt!:)
    Zumindest werden sie nicht rw gemountet sondern lediglich ro (readonly).

    MfG
    Rattiberta
     
  11. blauerklaus2

    blauerklaus2 Kbyte

    Registriert seit:
    27. Februar 2004
    Beiträge:
    482
    Er gibt viele wege hier einer davon wie ich es mache
    Wenn ich von Win auf Linux zugreifen will lege ich im
    Wurzelverzeichnis / einen sogenannten Montpoint an
    z.B. für C:\ nenne ich dosc ,also mit mkdir
    ein Verzeichnis dosc anlegen und Rechte setzen
    mit chmod -R 777 nun können alle drauf zugreifen !
    jetzt noch in der /etc/fstab dosc eintragen.
    /dev/hda1 /dosc vfat rw,noauto,user 0 0
    oder
    /dev/hda5 /dosd vfat rw,noauto,user 0 0 (für D:\)
    oder
    /dev/fd0 /dosa vfat rw,noauto,user 0 0 (für Diskette)

    die Eintragungen von einer root shell mit dem
    vi machen und abspeichern.
    Nicht vergessen für die Partitionen immer die Mountpoints
    anlegen. (klammerwerte nicht eintragen)
    Und die Namen wie dosc sind beliebig.
    Nun kann man die HDs grafisch eintragen und durch
    anklicken einbinden oder in einer shell wie ich
    es mache !
    mount /dev/dosc
    cd /dosc (ansehen)
    cd
    umount /dev/dosc (lösen)
    Zur Zeit würde ich nur auf vfat lesen und schreiben,
    auf NTFS nur lesen ist besser noch so !

    Alles eintragen und glücklich sein.

    bk2
     
  12. Adana

    Adana Byte

    Registriert seit:
    17. November 2004
    Beiträge:
    32
    Hi Leute!

    Ich habe jemanden gefunden, der mir jeden einzelnen Schritt erklärt hat und damit habe ich die FAT-Partition eingebunden bekommen.

    So muß der Eintrag in der fstab lauten:

    /dev/hda8 /Pfad/Pfad/Pfad vfat rw,uid=1000,gid=100,umask=000 0 0

    Wobei die Parameter keine Leerschritte enthalten dürfen, die Parametergruppen aber durch Leerschritt oder Tab getrennt werden müssen.

    Ich danke Euch allen trotzdem für Eure Hilfe,

    Gruß, Adana
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen