Read error in ... bei Navigon

Dieses Thema im Forum "Navigationssysteme" wurde erstellt von martin.stigler, 17. Juli 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. martin.stigler

    martin.stigler ROM

    Registriert seit:
    17. Juli 2005
    Beiträge:
    1
    Hi ,
    hat jemand schon mal das Problem gahabt das sich ständig das System aufhängt mit dem hinweis "Read error in line ......" !? Es sind immer wieder andere Linien (Zahlen) ! Ich habe zwei PDAs einen Yakumo Delta 200 und eine Delta 400 auf dem 200er hatte ich Navigon die 2.0 Software installiert und auf dem 400er hatte ich schon mal die 4.0 und jetzt aktuell die 5.0 Software ! Der Fehler ist immer wieder der selbe :aua: :aua: egal mit welchen Gerät oder Software !?? :confused: :confused: :heul:
    Bitte um Hilfe !
    Gruß
    Martin
     
  2. kar1507

    kar1507 ROM

    Registriert seit:
    14. November 2005
    Beiträge:
    1
    Hallo
    Du kannst mal Hier gucken vielleicht hilft es Dir weiter:
    http://www.pocketnavigation.de/board/thread.php?threadid=32963
    :)
    Ich habe es mal rauskopiert:

    ACHTUNG: Die hier diskutierte Lösung gilt nur für das Betriebssystem WM2003! Bei älteren Systemen mit PPC2002 etc. ist der relevante Registry-Eintrag nicht vorhanden, und es ist leider keine andere Lösung bekannt.
    **************************

    Viele haben ja ein Problem mit dem Fehler "Memory Allocation Failed", insbesondere wohl nach aus- und einschalten bei laufendem MN4.

    Möglicherweise lässt sich dies durch eine Änderung in der Registry beheben. Ein ähnliches Problem gab`s ja schon beim Medion 40600 ("Read Error"), dort wurde es von Medion mit einem Patch behoben. Allerdings wusste keiner so genau, was dieser bewirkt. Das habe ich jetzt mal untersucht. Der Patch ändert in der Registry den Wert
    HKEY_LOCAL_MACHINE\System\StorageManager\PnPUnloadDelay von 0 (Originalzustand nach Hard-Reset) auf 1500 (=1,5 Sekunden).

    ==================================
    ERGÄNZUNG:
    ACHTUNG: Bei Destinator PN wird ein ähnliches Problem diskutiert. Dort kann es anscheinend auch schaden, wenn der Wert zu hoch angesetzt ist.
    AWSW berichtet von einem Erfolg nach runtersetzen von 3000 auf 1500:
    www.pocketnavigation.de/board/thread.php...63&threadview=0
    Abhängig von PPC und Speicherkarte könnte der optimale Wert unterschiedlich sein, also wenn's nicht gleich klappt, andere Werte testen, und Soft-Reset nicht vergessen!
    ==================================

    Über die Bedeutung dieses Eintrags schreibt Microsoft:
    http://msdn.microsoft.com/library/defaul...rchitecture.asp
    "The PNPUnloadDelay subkey of the HKEY_LOCAL_MACHINE\System\StorageManager registry key specifies the time delay in milliseconds after the Storage Manager receives a Plug and Play (PnP) identifier unload notification of a block driver before it is actually unmounted. This notification forces unmounts of the partition driver and any file systems. During this period, the mount points move into a suspended state and requested I/O access to the mount points fail with ERROR_DEVICE_NOT_AVAILABLE. The primary use for this is during suspend/resume cycles where a block driver might unload and reload on resume. When the Storage Manager receives a load notification, it examines the block device to see if it is identical to the previously unmounted device. If it is identical, the block device remounts under the previous mount points. "

    Nach einer MN4-Installation nach Hard Reset ohne Patch hatte ich ebenfalls den "Memory Allocation Failed" Fehler. Nach dem Patch ist er wieder weg. Ich bin nicht ganz sicher, ob der Medion-Patch noch weitere Änderungen bewirkt, glaube es aber nicht.

    Ob und welche Wirkungen diese Änderung auf anderen Systemen hat, kann ich natürlich nicht sagen, aber offenbar gibt es den Eintrag ja nicht nur bei Medion/Yakumo/Mitac. Möglicherweise ist für andere Konfigurationen (anderer PPC, Installation auf Speicherkarte etc.) ein noch höherer Wert sinnvoll.

    Also, wer experimentierfreudig ist und weiß, was er tut, kann z.B. mit dem PHM Registry Editor
    www.phm.lu/Products/PocketPC/RegEdit
    den Wert ändern und schaun, ob es hilft.
    Vorher Backup nicht vergessen!

    ERGÄNZUNG: Erst nach Soft-Reset wird die Änderung wirksam!
    Viel Glück!
    944S2 hat dieses Bild angehängt:
     

    Anhänge:

Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen