Richtig Mounten. Aber wie?

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Probleme_Haber, 3. April 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Probleme_Haber

    Probleme_Haber Byte

    Registriert seit:
    9. Januar 2003
    Beiträge:
    53
    Hallo!

    Unter Suse 7.3 habe ich 3 Festplatten (hde, hdf, hdg) im Fat32 als windows/d , windows/e und windows/f gemountet (mit Yast)und für SMB diese drei Verzeichnisse (lesend und schreibend) freigegeben.
    Nun beim schreiben in diese Verzeichnisse werden aber die Dateien physikalisch auf die hda5, die als / gemountet ist, geschrieben.
    Was mache ich beim Mounten falsch? :confused:
    Kann man nicht mit einem Befehl den freien Platz von Partitionen (oder besser noch von physikalischen Platten) anzeigen lassen. YAST zeigt den freien Platz nicht.

    Danke im Voraus. :bet:

    Gruß der Linuxanfänger :)
     
  2. cirad

    cirad Kbyte

    Registriert seit:
    24. Februar 2001
    Beiträge:
    509
    *g* Zu genial. Mounten mußt du sie natürlich (lassen). (:
     
  3. Probleme_Haber

    Probleme_Haber Byte

    Registriert seit:
    9. Januar 2003
    Beiträge:
    53
    Es funktioniert! Nun sind die Festplatten gemountet!
    Habs rausgefunden wies geht! Hab in der fstat die noautos entfernt! :cool:
     
  4. rapmaster

    rapmaster Halbes Gigabyte

    Registriert seit:
    21. Juli 2002
    Beiträge:
    5.181

    wer kann darauf nicht schreiben :-S
     
  5. rapmaster

    rapmaster Halbes Gigabyte

    Registriert seit:
    21. Juli 2002
    Beiträge:
    5.181
    es ist bei vfat partitionen so, dass nur der jenige, der die partitionen mountet, auf der partition schreiben darf.

    ein bsp wäre:

    /dev/hdXzahl /mountpoint/ vfat ro,user,noauto 0 0
     
  6. Probleme_Haber

    Probleme_Haber Byte

    Registriert seit:
    9. Januar 2003
    Beiträge:
    53
    Hier noch ein paar weitere Informationen, die ich herausgefunden habe:

    Kommando: mount

    /dev/hda4 on / type reiserfs (rw)
    proc on /proc type proc (rw)
    devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
    /dev/hda3 on /boot type ext2 (rw)
    shmfs on /dev/shm type shm (rw)


    Kommando: cat /proc/partitions

    major minor #blocks name

    34 0 39082680 hdg
    34 1 1 hdg1
    34 5 39070048 hdg5
    33 0 39082680 hde
    33 1 1 hde1
    33 5 39070048 hde5
    33 64 39082680 hdf
    33 65 1 hdf1
    33 69 39070048 hdf5
    3 0 2062368 hda
    3 1 88704 hda1
    3 2 1 hda2
    3 3 14080 hda3
    3 4 921312 hda4
    3 5 1038208 hda5



    Datei: smb.conf

    [global]
    map to guest = Bad User
    security = user
    encrypt passwords = Yes
    workgroup = familie
    client code page = 850
    character set = ISO8859-15
    socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
    kernel oplocks = No
    guest account = Nobody
    os level = 2
    [daten_klein]
    path = /windows/C
    writeable = yes
    [privat]
    path = /windows/D
    writeable = yes
    [prog]
    path = /windows/E
    writeable = yes
    [media]
    path = /windows/F
    writeable = yes


    Datei: stab

    /dev/hda4 / reiserfs defaults 1 1
    /dev/hda3 /boot ext2 defaults 1 2
    /dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
    devpts /dev/pts devpts defaults 0 0
    /dev/fd0 /media/floppy auto noauto,user,sync 0 0
    proc /proc proc defaults 0 0
    /dev/hda5 /windows/C vfat noauto,user 0 0
    /dev/hde5 /windows/D vfat noauto,user 0 0
    /dev/hdf5 /windows/E vfat noauto,user 0 0
    /dev/hdg5 /windows/F vfat noauto,user 0 0
    /dev/hda1 swap swap pri=42 0 0
     
  7. Probleme_Haber

    Probleme_Haber Byte

    Registriert seit:
    9. Januar 2003
    Beiträge:
    53
    Also irgendwie sind die gemountet aber mit dem Befehl "df" kann ich die Platten nicht sehen.

    Schaut euch mal bitte das beiliegende Bild an.

    [​IMG]
     
  8. Acki D.

    Acki D. Byte

    Registriert seit:
    21. September 2003
    Beiträge:
    86
    Versuch es mal mit den Befehlen
    mount
    df
    fdisk -l

    und schau Dir mal die Datei /etc/fstab an.
    Falls Du Fragen hast, lies Dir die Manpages zu den einzelnen
    Programmen/Befehlen durch, und zwar mit
    man <Programmname>.

    Viel Erfolg!
    Gruß,
    Acki
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen