samba samba

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von mroszewski, 8. Juli 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. mroszewski

    mroszewski Viertel Gigabyte

    Registriert seit:
    18. Juni 2002
    Beiträge:
    4.208
    habe ein Problem mit heterogenem Netzwerk, habe auf mein PC Suse Linux 7.1 druffgemacht und Samba server installiert zum Datenaustausch mit Windowsrechnern, dann habe ich die notwendigen Freigaben laut der Beschreibung im Handbuch eingerichtet, auf die Verzeichnisse public=yes gesetzt und den write mode eingestellt (smb.conf mit texteditor bearbeitet kein konfigprogramm) und muß über ein seltsames Problem berichten, der PC ist über Hub mit 2 anderen verbunden, der eine mit windows 95b, der andere mit win98se, unter windows 95 kann ich problemlos, zwar nur lesend zugreifen aber sonst kein problem, unter windows98 aber kann ich in der Netzwerkumgebung den Baum nicht öffnen, beim klick auf das + werde ich nach passwort gefragt,obwohl ich keins gesetzt habe für die freigaben und public=yes in smb.conf steht beim betreffenden verzeichnis, auf beiden windows rechnern sind die gleichen Protokolle installiert
     
  2. MikeVX

    MikeVX Byte

    Registriert seit:
    4. Juli 2001
    Beiträge:
    119
    Ich hab Windows eXPerimrntal (wie es bei uns im Studium immer genannt wird) auch nur Weils halt bei einem Rechner mit dabei war. Es gibt bereits eine parallelele Mandrake 82-Installation die auch häufiger benutzt wird. Nichtsdestotrotz sollte halt auch XP zugriff auf Server-Shares bekommen.
    Das MS mit XP mal wieder eine Aktion ala "Wir bauen was ein damit LINUX nicht mehr geht" gestartet hat weiß ich. Die machen aber sowas andauernd mit Konkurentzproduckten.
    Ich werd mal die neuste Samba aufspielen. An sich sind die ja schon bei der 2.2.5. Mein Problem ist. Das die Installation eigentlich ein eSuSE 7.1 ist., bei der nur einige Komponenten (z.B. Samba) upgedatet wurden. Mal sehen ob sie das Update auch noch verträgt. Das Problem ist wirklich nur bei XP. Alle anderen Windows-Varianten laufen Problemlos (im Moment 95,98, 98SE, NT4 und 2000; ME hatte ich nie und will es nie)
    Zusatz: Die Rechner Melden sich nicht am Server an (-> kein Domainlogin). Es ist eine ganz normale Windows-Anmaldung, die auch ohne Server funktioniert. Nur wenn er dann auf den Server zugreift wird das Paßwort gecheckt. Es gibt mehrere User die auch spezielle Home-verzeichnisse bekommen. Es läuft alle perfeckt mit Windowsvarianten vor XP, als muß XP ihrgendwas schicken oder erwarten was Samba nicht verkraftet.

    Also Danke für die Tipps. Ich werd de Mal versuchen, und mich dann wieder melden

    Mike
    [Diese Nachricht wurde von MikeVX am 21.07.2002 | 13:19 geändert.]
     
  3. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    @mike
    Nachtrag:
    siehe unter
    http://www.sambahq.de/smbconf.php3/os_level.html
    Dort steht: Mit xp HOME gibt es keine Domain-Anmeldung.
    (Da hab ichs doch tatsächlich mit meinem gameligen SE noch besser *gg*)

    mfg
    Raphael
     
  4. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Hallo Mike!

    Um es vorweg zu sagen: Ich hab kein Gummibärchen-Windoof. Und deshalb auch keine Erfahrung mit eXtremly Pain. Ich hab noch die Shit Edition.

    Getreu dem Motto: "Mit dem Feind redet man nicht", hat M$ die Netzwerkdienste (SMB) bei XP so verändert, dass keine Komunikation mit dem bösen Linux möglich ist. Soweit, so schlecht.

    Die Leute von Samba haben das Problem in Arbeit. Inzwischen sollte eine Lösung "auf dem Markt" sein. Die neueste (?) Version habe ich bei suse gefunden:
    ftp://ftp.suse.com/pub/suse/i386/8.0/suse/n2/samba-2.2.3a-117.i386.rpm
    Ist zwar für die Achter-Version sollte dennoch bei 7.3 laufen.

    Ist das Problem nur bei xp oder auch win ce,me,nt (ich liebe wortspielereien :)) )? Weil sonst liegt der Hund in der smb.conf

    mfg
    Raphael
     
  5. MikeVX

    MikeVX Byte

    Registriert seit:
    4. Juli 2001
    Beiträge:
    119
    Hi,

    Frage: Kannst du mir sagen was ich alles anstellen muß, daß ich mich mit meiner XP-Home edition an einen Sambe 2.2 - Server (SuSE 7.3) anmelden kann? Ich hab schon diverse Registryeinträge geändert aber nix funktioniert. Der Rechnername ist dem Server und Samba bekannt. Gibt irgendwo im Netz eine genaue Anleitung was ich alles Ändern muß? Oder sollt ich mal bei Micrsoft nachfragen? *g*

    Wäre um jede Hilfe dankbar

    Mike
     
  6. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Nachtrag zum OS-level

    Level 2 bedeutet, dass Browser-Dienste für 95 und wfw (win3.11) angeboten werden.

    Level 255 gab bei mir einen Haufen Probs (Ping geht, Netzwerklaufwerk geht auch, Netzwerkumgebung meistens leer/kann nicht durchsucht werden). Viel hilft doch nicht viel.

    Level 40 und 50 geht wunderbar (zusammen mit 98se)

    mfg
    Raphael
     
  7. hypermania

    hypermania ROM

    Registriert seit:
    20. Juli 2002
    Beiträge:
    3
    Du musst einfach unter Windows 98 die Anmeldeart von Netzwerk auf irgendwas anderes stellen!

    Oder beim Start von Windows 98 bei der Abfrage von Name und Passwort auf Abbrechen klicken.

    Bei Win95 gabs das glaube ich noch nicht. Oder es ist Standardmäßig nicht eingestellt.
     
  8. H.J.

    H.J. Byte

    Registriert seit:
    19. März 2002
    Beiträge:
    19
    Bist du unter Windows98 mit einem anderen Benutzernamen (Netzwerkanmeldescreen am Anfang) drin?
    Dann erkennt Samba dich nicht und fragt nach Benutzer und Passowort...

    so war das zumindest bei mir
    [Diese Nachricht wurde von H.J. am 17.07.2002 | 08:26 geändert.]
     
  9. mroszewski

    mroszewski Viertel Gigabyte

    Registriert seit:
    18. Juni 2002
    Beiträge:
    4.208
    das seltsame ist, daß die Passwortabfrage nur unter windows98 kommt unter windows 95 klappt das Browsing problemlos.
     
  10. iCebird

    iCebird Kbyte

    Registriert seit:
    20. November 2001
    Beiträge:
    316
    Hi,

    zweierlei Dinge.

    Zu Deiner ersten Frage:

    Hast Du encrypt passwords auf yes gestellt und die Benutzernamen / Passwörter der W9x User (die auch auf dem Linux System existent sein müssen)
    per <B>smbpasswd -a username</B>
    in die Passwortdatei von Samba eingefügt?

    Zu Deiner 2. Frage:

    Der OS-Level, wurde ja schon beschrieben, geht (soweit ich weiß) nur bis 65 (kann mich aber auch irren).
    Du solltest diesen, wenn die Linux Maschine der einzige Server ist, auch auf diesen Wert stellen, damit die Aushandlungen (wie schon beschrieben) des Masterbrowsers unterbleiben.
    Ist die Linux Maschine nicht immer eingeschaltet so sollte man den Level auf einem niedrigeren Niveau halten als der Rechner der am meißten läuft um Unstimmigkeiten bzgl. des Masterbrowsers auszuschließen.

    Ergänzend noch ein Hinweis.

    Wenn Du SWAT benutzt, Webbrowser gestützte Administration des Samba Servers, (siehe usr/share/doc/packages/samba (swat) oder man swat) so kannst Du zu jedem Konfigurationspunkt bequem eine Hilfe aufrufen, die den entspr. Punkt genauestens erklärt.

    Gruß Ralf
     
  11. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Jeder Windoze-Rechner (Samba tut ja auch so) hat einen OS level (1-255). Je höher, je moderner (besser?)

    1 wfw
    1 9x
    16 NT 3.51
    17 NT 4
    32 NT 3.51 Server
    33 NT 4 Server
    666 xp *scherz* (Die Zahl ist der böse Scherz, oder?)

    aprospos xp: xp mag kein samba. Erst die neueste Samba-Version ist wieder genehm.

    In jedem Netzwerk ist einer der Boss. Der sog. Master-Browser. Dies ist der Rechner mit der höchsten Kennziffer. Falls mehrere Rechner den gleichen Level haben wird ausgehandelt (alles über das Netzwerk). Es kann nur einen geben.
    Dies wird "bei Bedarf" (?) immer wieder (!) ausgehandelt.
    Da ich nur 9x kisten in meinem Netzwerk hab, reicht OS=2 völlig aus (in memorandum: OS/2)
    Zusätzlich kann man noch

    local master = yes
    preferred master = yes

    setzen.

    Das ganze Prozedere wird in einem Atemzug mit WINS genannt (ein schlechterer DNS Server) Der WINS-Server sollte gleichzeitig der Master-Browser sein.

    wins support = yes
    wins proxy = yes

    Die WINS-Sache habe ich mit meinen paar Rechnern bisher ignoriert und leb immernoch. Schließlich müss(t)en die Windosen auch konfiguriert und neu gestartet werden. *igitt*

    mfg
    Raphael
     
  12. mroszewski

    mroszewski Viertel Gigabyte

    Registriert seit:
    18. Juni 2002
    Beiträge:
    4.208
    was bedeutet eigentlich der Eintrag "os level=2" im Handbuch stand darunter auch nichts näheres drin, wenn was anderes als =2 steht.
     
  13. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Bei mir funktionierende Einstellungen (ordinäres peer to peer):

    Datei etc/smb.conf (auszug)

    [global]
    workgroup = arbeitsgruppe
    guest account = nobody
    keep alive = 30
    os level = 2
    kernel oplocks = false
    security = SHARE
    public = yes
    create mode = 0777

    [treiber]
    comment = Treiber
    path = /data/treiber
    read only = no

    ----------
    Manches vielleicht unnötig, aber es läuft

    vielleicht wichtig:
    Wort (leer) = (leer) Wort

    Mit Garantie wichtig:
    Den Ordner "von Hand" erstellen und mit chmod im Linux Dateisystem auch die Rechte (777) an den entsprechenden Ordner geben.
    Strenges Rechtesystem, ähnlich wie unter NTFS

    mfg
    Raphael
     
  14. wickey

    wickey Megabyte

    Registriert seit:
    8. Januar 2002
    Beiträge:
    1.126
    Vielleicht findest du da Hilfe --&gt; http://samba.sernet.de/info.html ich kann Dir leider nicht helfen.

    grüße wickey
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen