SAMBA-Server nicht sichtbar

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von iCebird, 26. Februar 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. iCebird

    iCebird Kbyte

    Registriert seit:
    20. November 2001
    Beiträge:
    316
    Hi,

    ich habe einen eigentlich voll funktionstüchtigen Samba Server aufgesetzt.
    Es gibt nur 2 kleine Probleme.

    1. In der Netzwerkumgebung ist er nicht Sichtbar.
    Hier ein Auszug aus meiner smb.conf ...

    [global]
    workgroup = LINGROUP
    netbios name = EDV-1
    interfaces = eth0
    encrypt passwords = Yes
    os level = 65
    preferred master = Yes
    domain master = Yes
    wins support = Yes

    [Public]
    comment = Public
    path = /public
    writeable = Yes

    Wie man sieht fungiert dieser auch als WINS-Server.
    Durch die Optionen domain master und preferred master = yes
    sollte er eigentlich der Rechner sein der die Browsing-list verwaltet.
    Wie dem auch sei, egal ob Win 9x / 2000 / XP, er tauch einfach nicht in der Netzwerkumgebung auf.
    Man bekommt ihn nur über "Computer suchen" angezeigt.

    2. Neben dem Share "Public" existiert noch das share "home".
    Dieses wird korrekt auf den User umgesetzt und angezeigt.
    Leider ist es nicht möglich die Freigabe zu öffnen :-(
    Hier kommt immer die Meldung daß das Verzeichnis nicht erreichbar wäre.
    Die Freigabe "Public" jedoch läßt sich ohne Probleme öffnen.

    Die Samba Hilfe war hier nicht sehr Ergiebig. Da von Seiten des Samba-Servers ja eigentlich auch alles klar ist könnte es an den Clients hängen.

    Ich weiß auf jeden Fall nicht weiter und bin für jede Hilfe dankbar.

    Gruß Ralf
     
  2. iCebird

    iCebird Kbyte

    Registriert seit:
    20. November 2001
    Beiträge:
    316
    Kleine Info für Interessierte.

    Freigegebene Dateien oder Ordner (in SAMBA) versteckt man vollständig in dem man sie als "veto files" angibt.

    Hier lag mein Problem Nr. 2!
    Ich wollte in den home Verzeichnissen der User die versteckten Dateien, die mit einem Punkt beginnen vollständig ausblenden.
    Also setzte ich bei veto files = /.*/ ein und das Resultat war ich konnte nicht mehr auf das Verzeichnis zugreifen.
    Setzt man allerdings veto files = /.a*/.b*/.c*/ etc. so tritt dieses Problem nicht mehr auf.
    Es ist zwar etwas mühsam alle .files anzugeben aber unter XP hat man ansonsten keinen Zugriff.
    Mit anderen Win Versionen hab ich das noch nicht ausprobiert.
    Früher, mit Win98SE hat die Variante /.*/ funktioniert, allerdings kann es auch ein Problem der Samba-Version 2.0.7 sein, die ich im Moment verwende.

    Na ja, vielleicht hilft das dem einen oder anderen weiter.

    Gruß Ralf
    [Diese Nachricht wurde von iCebird am 27.02.2002 | 11:35 geändert.]
     
  3. iCebird

    iCebird Kbyte

    Registriert seit:
    20. November 2001
    Beiträge:
    316
    Hi,

    erst mal schönen Dank.
    die Rechner befinden sich alle in der selben Arbeitsgruppe.
    Das witzige ist, nach der Installation war alles in Ordnung.
    Dann hab ich den smbd und den nmbd beendet, da das Projekt Samba als File- und Printserver bei uns ein zu setzen gestorben war.
    Nun lebt es wieder auf, ich also die beiden wieder gestartet aber Sie tauchen nicht mehr auf.
    Na ja, ich werd mal schauen ob mir die smb.conf von Martin weiterhilft.

    Vielleicht kommen ja noch ein paar Ideen zusammen und wenn nicht muß ich halt damit leben und weiterprobieren.

    Gruß Ralf

    Ach ja, Problem 2 hab ich gelöst.
    Das Share einfach noch mal neu angelegt und es ging wieder.
    [Diese Nachricht wurde von iCebird am 27.02.2002 | 09:11 geändert.]
     
  4. HLange

    HLange Kbyte

    Registriert seit:
    22. September 2000
    Beiträge:
    183
    1. Wenn sich Deine Win-Clients in einer anderen Arbeitsgruppe (workgroup) als der Samba-Server befinden, kann es sein, daß keine Namensauflösung stattfindet. Pro Arbeitsgruppe muß mindestens ein Win-Rechner mit Datei- und Druckerfreigabe oder ein Samba-Server vorhanden sein, der die Namensverwaltung übernimmt.
    Der Samba-Server wird nicht die Namensverwaltung für andere Arebitsgruppen übernehmen.
    Für das manuelle Suchen ist kein Namensserver erforderlich.
    Deswegen klappt bei Dir zwar das eine, das andere aber nicht.

    2. Hier weiß ich leider nicht, wodran das liegen könnte.

    mfg Henning Lange
     
  5. Marsch

    Marsch Kbyte

    Registriert seit:
    7. Dezember 2000
    Beiträge:
    205
    Hier ist meine smb.conf. Vielleicht hilft dir das weiter. Mein Rechner wird auf jeden Fall gefunden:

    [global]
    workgroup = SCHERER
    server string = %h server (Samba %v)
    security = SHARE
    encrypt passwords = Yes
    obey pam restrictions = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
    syslog = 0
    max log size = 1000
    socket options = IPTOS_LOWDELAY TCP_NODELAY SO_SNDBUF=4096 SO_RCVBUF=4096
    dns proxy = No
    invalid users = root
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen