Sambaserver mit Win Freigabe

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von MatthiasH, 31. Januar 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. MatthiasH

    MatthiasH Kbyte

    Registriert seit:
    8. August 2000
    Beiträge:
    332
    Hallo
    Auf meinen Linux Rechner hab ich einen Sambaserver eingerichtet. Der schreibzugriff auf eine Freigabe auf der Linuxplatte funktioniert.
    Ich habe aber auch ein Verzeichnis auf der FAT Partition der Win 98 Festplatte freigegeben. Hier kann ich über Samba keine Dateien erstellen. Wenn ich über Linux auf die Win 98 Festplatte zugreife, kann ich Dateien erstellen. Wieso funktioniert dies nicht über Samba?
     
  2. bitumen

    bitumen Megabyte

    Registriert seit:
    4. Juni 2002
    Beiträge:
    1.952
    Tut mir leid, dich enttäuschen zu müssten, aber smbadduser ist standardmäßig dabei! (vielleicht bei v2.0 nicht mehr...)

    :tröst:
     
  3. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    Wer weiß was da mdk gebastelt hat, da smbadduser offensichtlich bei den Samba-Paketen nicht mehr dabei ist - jedenfalls bei mir nicht. Es wird sicher ein Script sein.
     
  4. MatthiasH

    MatthiasH Kbyte

    Registriert seit:
    8. August 2000
    Beiträge:
    332
    Bei mir ist es egal, ob jeder schreibrechte auf der Linuxmachine haben.
    1. ist es ein alter Rechner, der nur noch zum Testen da ist (Vor allem wegen Apache)
    2. werden keine wichtigen Daten ausgelagert
    3. pfuscht niemand am Netz.
    4. da ich nur ein Verzeichnis auf der FAT Partition freigegeben habe, macht es nix aus, dass jeder Schreibzugriff hat.

    Das mit den Gruppen und Paßwörtern wäre interessant, wenn der Linuxrechner als PDC läuft. Aber ich habe keine Domäne
     
  5. bitumen

    bitumen Megabyte

    Registriert seit:
    4. Juni 2002
    Beiträge:
    1.952
    [root@neptun /etc]# cat /etc/smbpasswd
    testuser:501:D80B6BFCF3B7A64DAAD3B435B51404EE:FB8CF34B80B786BDBD39851491351865:[U ]:LCT-401C29B0:
    [root@neptun /etc]#

    nööö, das ist schon verschlüsselt.
     
  6. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    smbadduser gibt es aber nicht auf jedem System :rolleyes:

    Erst User ganz normal ohne Shell anlegen, wenn er noch nicht existiert und dann smbpasswd -a User
    geht immer.

    PS
    Wenn ich mich nicht täusche, ist smbadduser schon etwas angestaubt und legt das Passwort im Klartext in der /etc/smbpasswd ab. Ein Anmelden ist dann auf einem Shadow-System nicht möglich.
     
  7. bitumen

    bitumen Megabyte

    Registriert seit:
    4. Juni 2002
    Beiträge:
    1.952
    Stimmt, ich habe an aber an die user gedacht. die müssten mit smbadduser angelegt werden, weiters muss das samba-share mit der option "writeable = yes" versehen werden, sonst geht garnix.

    mfg
     
  8. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    Habe es mal ausgetestet. Samba hält sich sehr wohl an die Rechteverwaltung im System und hebelt diese nicht aus.

    Ein Verzeichnis welt-beschreibbar zu machen ist ja nicht gerade das gelbe vom Ei. Solange man allein im Netz ist (was eigentlich keinen Sinn macht), ist es ja egal. Andernfalls wäre es günstiger eine eigene Gruppe dafür anzulegen und dort alle User aufzunehmen, die da reinschreiben dürfen. Das Mounten der Part muß dann mit der entsprechenden Gruppe gid=xxxx und umask=000x erfolgen.
     
  9. MatthiasH

    MatthiasH Kbyte

    Registriert seit:
    8. August 2000
    Beiträge:
    332
    Jetzt funktioniert der Schreibzugriff über Samba auf die Windoofs Partition. Ich hab in der fstab einfach bei unmask 0000 statt 0002 hingeschrieben.
     
  10. MatthiasH

    MatthiasH Kbyte

    Registriert seit:
    8. August 2000
    Beiträge:
    332
    Ich gebe zu, ich hab mich zuerst ein wenig unverständlich ausgedrückt.

    Wenn ich als "normaler" User in Linux eingeloggt bin, dann kann ich auch auf die FAT Platte schreiben.
    Ich muss mal schauen, wie die Rechtevergabe unter Linux eingestellt ist.
     
  11. bitumen

    bitumen Megabyte

    Registriert seit:
    4. Juni 2002
    Beiträge:
    1.952
    :bet: bitte das nächste mal etwas verständlicher, ich hab erst jetzt gejeckt, was du meinst....

    Wie gnagfloh schon erwähnt hat, sollte die pladde für die user mountbar sein. das erreichst du, indem du in der /etc/fstab in der entsprechenden zeile bei den optionen "user" hinzufügst. Der ordner, in dem die pladde gemountet ist, sollte auch das schreiben als normaluser, sprich 666 eingestellt sein.
    Ich glaube jedoch, dass samba ein eigenes rechtevergabe-system hat. da kannst du alles mögliche einstellen, wer was darf. In diesem Fall sind die og einstellungen ziemlich egal, da samba von init, und nicht von einem benutzer ausgeführt wird. Falls du dich nicht in die untiefen des smb.conf begeben möchtest, kannst du das ganze auch per swat konfigurieren.

    gruß, buhi
     
  12. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    :confused: Verständigungsprobleme :confused:

    Du willst von einem Windows-PC aus auf eine Samba-Freigabe von Linux über das NW zugreifen, die auf eine gemountete FAT-Partition zeigt?

    Wie ist denn die FAT-Part gemountet? Ein Mountpoint gehört immer Root und nur Root hat darauf Schreibzugriffe. Da man auf FAT keine Zugriffsrechte vergeben kann, hast du wahrscheinlich Pech. :aua: Versuch mal die FAT-Part. als User-Mount freizugeben und als User, der darauf zugreifen soll zu mounten. Vielleicht klappt das.

    Ich werde es mal testen.
     
  13. MatthiasH

    MatthiasH Kbyte

    Registriert seit:
    8. August 2000
    Beiträge:
    332
    Genau, ich will auf der Windowsplatte, die im Linuxrechner ist Schreibrechte.
     
  14. bitumen

    bitumen Megabyte

    Registriert seit:
    4. Juni 2002
    Beiträge:
    1.952
    Ich vermute, dass du auf der win98 maschine lese/schreib-zugriff haben möchtest. (fragestellung nicht wirklich eindeutig)
    GIb am besten in den konqueror smb://ip-des-rechners ein. da sollte es funktionieren...

    gruß, buhi
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen