1. Bitte immer die Rechnerkonfiguration komplett posten!
    Vollständige Angaben zur Konfiguration erleichtern die Hilfestellung und machen eine zügige Problemlösung wahrscheinlicher. Wie es geht steht hier: Klick.
    Information ausblenden

SCSI-Problem

Dieses Thema im Forum "Festplatten, SSD, USB-Sticks, CD/DVD/Blu-ray" wurde erstellt von Marco Saenger, 28. Dezember 2001.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Marco Saenger

    Marco Saenger Kbyte

    Registriert seit:
    22. März 2001
    Beiträge:
    241
    Folgendes:

    Ich habe in einen Rechner einen neuen SCSI-Controler eingebaut. Dieser erkannt den externen Scanner, den CD-Brenner, das DVD-Laufwerk unddie drei Festplatten korrekt. Das Bootlaufwerk ist richtig eingetragen, die Primärpartition auf ihm ist aktiv. Das booten von CD läuft auch.

    Jetzt hab ich aber das Problem das sich XP oder auch Win 2000 nicht installieren lassen, sondern mit Fehlern abbrechen. XP gibt einfach nur ne Fehlermeldung 7 aus, 2000 bricht das Setup mit dem Hinweis auf ein unzureichen ACPI-fähiges BIOS ab....

    Wer kennt sich denn mit SCSI aus hier??
     
  2. Marco Saenger

    Marco Saenger Kbyte

    Registriert seit:
    22. März 2001
    Beiträge:
    241
    So, ersteinmal herzlichen Dank dafür das Du Dir die Zeit genommen hast, mir derartig ausführlich zu antworten - es hat mein Wissen uber SCSi hardwaremäßig dann doch erweitert. Danke :-))

    Was nun aber den Fehler angeht - ich trau mich kaum es zu sagen - die ganze Problematik hang an einem blöden RAM-Chip, der auf dem alten Mainboard einwandfrei lief, auf dem jetzigen neuen aber die ganzen Probleme verursacht hat. Was meinst Du wie ich geflucht habe - aber darauf soll man auch kommen. Erst als uns auffiel das Win2K immer wieder mit unterschiedlichen Fehlern die Installation verweigerte sind wir auf den Trichter gekommen.

    Nochmals danke :-)
     
  3. Alegria

    Alegria Kbyte

    Registriert seit:
    3. August 2000
    Beiträge:
    423
    Suche die Fehler erstmal bei der Verkabelung und der Gerätekonfiguration, dann bist Du schon entscheidend vorangekommen.
     
  4. Marco Saenger

    Marco Saenger Kbyte

    Registriert seit:
    22. März 2001
    Beiträge:
    241
    hm...das Board ist ein Asus A7V 133 mit nem 800er Athlon drauf. Die IDE und ATA Schnittstellen des Boards sind deaktiviert, das BIOS ist aktuell

    Davon das der Adaptec dazu inkompatibel sein könnte habe ich nix gefunden - aber das will nix heißen - bei Adaptec nen Treiber zu finden ist auch schon ein Abenteuer für sich *gg*
    [Diese Nachricht wurde von Marco Sänger am 29.12.2001 | 01:00 geändert.]
     
  5. Alegria

    Alegria Kbyte

    Registriert seit:
    3. August 2000
    Beiträge:
    423
    Denke daran, daß sich die Kabellängen Intern wie Extern am NICHT-LVD-Strang addieren, d.h. die Länge des Wide-SCSI-Kabels und die Länge des internen wie auch externen Narrow-SCSI-Kabels bis zum Scanner ergeben die Gesamtlänge Deines Busses.
    Den LVD-Strang benutzt Du nicht, sagst Du. Die Terminierung ist bei der Verwendung von UltraSCSI-Geräten für einen reibungslosen Betrieb zwingend aktiv auszuführen, d.h. der externe Terminator muß aktiv sein, ein einfacher passiver Widerstandsarray-Terminator tut es nicht. Du hast drei mindestens UltraSCSI-fähige Platten, mindestens ein UltraSCSI-fähiges CDROM-Laufwerk, die Gesamtbuslänge bis zu der alles störungsfrei funktioniert ist ca 1,5m. Das wird leicht durch die internen und externen Kabel erreicht. Bei dieser Konfiguration ist es durchaus möglich, daß mehrere Bus-Resets während der Controllerinitialisierung durch die Installation ereignen, sobald der Treiber für den Controller geladen wird. Das wäre eine Erklärung für den Stop-Fehler. Wenn 2000 an der ACPI-fähigkeit Deines Rechners herummeckert, kann das an Deinem Motherboard-BIOS liegen, muß aber nicht unbedingt sein. Normalerweise läuft die Installation trotzdem durch.
    Mein Vorschlag zur Fehlerdiagnose wäre erstmal:
    Den Scanner komplett abhängen, den Narrow-SCSI-Strang intern enden lassen und korrekt terminieren.
    Den WideSCSI-Strang so kurz wie möglich halten, Terminierung auch hier nochmal überprüfen, die LVD-Platte falls korrektes Kabel zur Hand getrennt an den LVD-Anschluß hängen und natürlich muß ein aktiver Kabelterminator am Ende des LVD-Kabels stecken. Die LVD-Platte hat wahrscheinlich keine eigene aktive Terminierung, nur einen Jumper für TermPower. Der kann und darf gesteckt sein, hat aber nichts mit der eigentlichen Terminierung zu tun, ist nur eine Spannungsversorgung für aktive Terminatoren.
    Aktuelle Treiber zur Hand, das aktuellste Mainboard-BIOS geflasht kann es dann mit der Installation erneut losgehen.
    Booten von CD, wenn der salbungsvolle Spruch "Setup untersucht die Konfiguration, bla,bla,bla" kommt F5 drücken und warten, bis Du manuell einen Treiber für Deinen Controller installieren kannst, den Du nun auf Diskette bereit haben solltest. Außerdem kannst Du an dieser Stelle auch die ACPI-Erkennung umgehen, indem Du den Rechner als StandardPC installierst. Je nach Board gibt es dann auch noch die berüchtigte Inkompatibilität mancher SCSI-Controller mit dem PCI-Bus-Controller von manchen VIA-Chipsets.
    Dein Board hast Du leider nicht näher bezeichnet.
    Viel Erfolg!
     
  6. Marco Saenger

    Marco Saenger Kbyte

    Registriert seit:
    22. März 2001
    Beiträge:
    241
    Jo, habe ich echt vergessen, sorry.

    Ist ein Adaptec 29160, der hat nen 50 poligen, an welchem bei besagtem Rechner Brenner, DVD-ROM und Scanner hängen.

    Dazu hat er nen 68poligen Ultra / Fast Wide SCSI, an welchem die drei HDDS hängen. Eine davon ist zwar ne aktuelle LVD 160, das darf aber eigentlich kein Problem darstellen.

    Datu hat er noch intern nen neuen LVD 68 polig und gleiches durchgeschliffen für externe Geräte. An denen hängt jeweils nix

    Terminierungen sitzen wie vorher auch schon an der richtigen HDD und am Scanner - die neue LVD 160er Platte hat eine alte Platte nur ersetzt, kam also in einen an sich funktionierenden "Kreislauf". Es wird ja auch alles erkannt. Im Controler-BIOS ist dem bisherigen Boot-Device die korrekte ID zugewiesen, booten von CD geht auch.

    Nur dann hakt es halt mit den beschriebenen Probs unter XP und W2K.
    [Diese Nachricht wurde von Marco Sänger am 28.12.2001 | 20:13 geändert.]
     
  7. Alegria

    Alegria Kbyte

    Registriert seit:
    3. August 2000
    Beiträge:
    423
    Welcher Controllertyp (Hersteller, Bezeichnung,Ultra, UltraWide, LVD 80, LVD 160), wie ist verkabelt und wie ist terminiert (aktiv, passiv)?
    Welche Anschlüsse mit welchen Interface-Eigenschaften (50 oder 68-polig, Ultra, UltraWide usw. extern wie intern)
    Ferner welche Kabellängen kommen zum Einsatz?
    Bei einem Adaptec 2940UW beispielsweise dürfen nur zwei der vorhandenen Anschlüsse am Controller verwendet werden, bei Benutzung von allen drei Anschlüssen baust Du eine sternförmige Verkabelung, es muss jedoch ein Bus mit lediglich zwei Enden sein.
    Nur an den Enden darf terminiert sein, Abzweige, doppelte Terminierung sind nicht erlaubt. Ein extrener Scanner arbeitet nur 8Bit breit, das würde aber an einem externen 16 Bit Wide-Anschluß bedeuten, daß die oberen 8 Datenleitungen unterminiert bleiben, bei Verwendung eines normalen Terminators (aktive Terminierung sollte es sowieso sein).
    Ein 2940U2W hingegen besitzt getrennte Busse für Ultra/Ultrawide-Geräte und LVD-Wide-Geräte. Hier können sowohl alle internen als auch der externe Anschluß (korrekte Verkabelung und Terminierung vorausgesetzt) benutzt werden. Ebenso verhält es sich mit neueren Controllern mit Ultra-160-Interface, wobei das von Controllermodell zu Controllermodell bei Adaptec von den externen Anschlüssen unterschiedlich ist, was zur Verfügung steht.
    Gib mal ein paar mehr Informationen dazu...
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen