SMB startet nicht!?

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Lysy, 4. April 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Lysy

    Lysy Byte

    Registriert seit:
    19. April 2002
    Beiträge:
    20
    SMB startet nicht ;-)

    Beim booten startet der SambaServer (Ver.2.21) nicht mit.
    Den muss ich immer per Webmin starten.
    Hat jemand Ahnung was ich da falsch mache? Gibt es unter meinem Suse7.3 eine Option in der man analog zu Windows-autoexec b.z.w. Autostartordner den SMB beim Rechnerstart mitstarten kann?

    Im Voraus schon jetzt DANKE!!! für event. Antworten.

    Gruß Lysy


    Beim Webminzugriff ist unter "Systemstart- und Herunterfahren-Dienste" (http://192.168.2.1:10000/init/edit_action.cgi?0+smb) folgender "initscript for the SAMBA services" (die Option "Starte beim Systemstart" ist auf "JA" gesetzt!):


    #! /bin/sh
    # Copyright (c) 2001 SuSE Gmbh Nueremberg, Germany. All rights reserved.
    #
    # <fedback@suse.de>
    #
    ### BEGIN INIT INFO
    # Provides: smb
    # Required-Start: $network $remote_fs syslog
    # Required-Stop:
    # Default-Start: 3 5
    # Default-Stop:
    # Description: initscript for the SAMBA services
    ### END INIT INFO
    #
    # init.d/smb

    . /etc/rc.config

    SMB_BIN=/usr/sbin/smbd
    NMB_BIN=/usr/sbin/nmbd
    SMB_CONF=/etc/samba/smb.conf
    SMB_PID=/var/run/samba/smbd.pid
    NMB_PID=/var/run/samba/nmbd.pid


    # Determine the base and follow a runlevel link name.
    base=${0##*/}
    link=${base#*[SK][0-9][0-9]}

    # Force execution if not called by a runlevel directory.
    test $link = $base && START_SMB=yes
    test "$START_SMB" = "yes" || exit 0

    if [ ! -x $SMB_BIN ] ; then
    echo -n "SMB demon not installed ! "
    exit 5
    fi

    if [ ! -x $NMB_BIN ] ; then
    echo -n "NMB demon not installed ! "
    exit 5
    fi


    # The echo return value for success (defined in /etc/rc.config).
    #return=$rc_done

    . /etc/rc.status
    rc_reset


    case "$1" in
    start)
    echo -n "Starting SAMBA nmbd :"
    checkproc $NMB_BIN
    if [ $? -eq 0 ] ; then
    echo -n " Warning: nmbd already running ! "
    else
    [ -e $NMB_PID ] && echo -n " Warning: $NMB_PID exists ! "
    fi
    startproc $NMB_BIN -D
    rc_status -v
    echo -n "Starting SAMBA smbd :"
    checkproc $SMB_BIN
    if [ $? -eq 0 ] ; then
    echo -n " Warning: smbd already running ! "
    else
    [ -e $SMB_PID ] && echo -n " Warning: $SMB_PID exists ! "
    fi
    startproc $SMB_BIN -D
    rc_status -v
    ;;
    stop)
    echo -n "Shutting down SAMBA nmbd :"
    checkproc $NMB_BIN || echo -n " Warning: nmbd not running ! "
    killproc -TERM $NMB_BIN
    rc_status -v
    rm -f $NMB_PID
    echo -n "Shutting down SAMBA smbd :"
    checkproc $SMB_BIN || echo -n " Warning: smbd not running ! "
    killproc -TERM $SMB_BIN
    rc_status -v
    rm -f $SMB_PID
    ;;
    try-restart)
    $0 stop && $0 start
    rc_status
    ;;
    restart)
    $0 stop
    $0 start
    rc_status
    ;;
    force-reload)
    $0 reload
    rc_status
    ;;
    reload)
    echo -n "Reloading SAMBA nmbd :"
    checkproc $NMB_BIN || echo -n " Warning: nmbd not running ! "
    killproc -HUP $NMB_BIN
    # [ -e $NMB_PID ] && touch -c -m $NMB_PID
    rc_status -v
    echo -n "Reloading SAMBA smbd :"
    checkproc $SMB_BIN || echo -n " Warning: smbd not running ! "
    killproc -HUP $SMB_BIN
    # [ -e $SMB_PID ] && touch -c -m $SMB_PID
    rc_status -v
    ;;
    status)
    echo -n "Checking for SAMBA nmbd :"
    checkproc $NMB_BIN
    rc_status -v
    echo -n "Checking for SAMBA smbd :"
    checkproc $SMB_BIN
    rc_status -v
    ;;
    probe)
    test $SMB_CONF -nt $SMB_PID && echo reload
    test $SMB_CONF -nt $NMB_PID && echo reload
    ;;
    *)
    echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload|probe}"
    exit 1
    ;;
    esac
    rc_exit
     
  2. Lysy

    Lysy Byte

    Registriert seit:
    19. April 2002
    Beiträge:
    20
    Hi!

    Habe durch Zufall entdeckt, dass beim Webmin unter "Systemstart- und Herunterfahren-Dienste" noch ein Eintrag sich befindet, der in der Beschreibung das Wort Samba enthält, und zwar der "nmb" (Samba NetBIOS naming service over IP). Das Ding war nicht zum Starten aktiviert. Nach der Aktivierung und reboot läuft der SMB!

    Nochmals Herzlichen Dank für alle Tips!

    Gruß Lysy
     
  3. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    Da kenne ich mich auch nicht so gut aus, da die letzte SuSE die ich noch gelegentlich zwischen die Finger bekomme die 7.3 ist.

    Wenn sich auf deiner Kiste eine /sbin/init.d/boot.local befindet, schreibe dort als letzte Zeile folgendes rein:

    /sbin/init.d/smb start

    Das ist zwar nicht ganz sauber, da beim herunterfahren der Samba-Server nicht richtig heruntergefahren wird, aber es sollte funzen und auch keinen Schaden anrichten.
     
  4. Lysy

    Lysy Byte

    Registriert seit:
    19. April 2002
    Beiträge:
    20
    Hallo!

    Danke für die Tips, diese konnte ich leider nicht ausprobieren, da ich den Linux gekillt habe ;-(
    Habe momentan den Suse9.0, zweks ausprobieren - da besteht aber das Problem mit dem "SMB-Starten" weiter, nur dass die Datei rc.config leider nicht mehr existiert, und mit dem Yast unter "Editor für Config-Dateien" ist die Option für SMB auch nicht mehr.
    Wo wird die Samba zum Starten eingetragen?

    Gruß Lysy
     
  5. gnagfloh

    gnagfloh Kbyte

    Registriert seit:
    7. August 2003
    Beiträge:
    325
    in der /etc/rc.config die Variable

    START_SMB="no"

    auf yes setzen und schon geht es.
     
  6. rapmaster

    rapmaster Halbes Gigabyte

    Registriert seit:
    21. Juli 2002
    Beiträge:
    5.181
    tu mal ein shell script mit folgendem inhalt

    /etc/init.d/samba start

    in
    /etc/rdS.d

    rein

    mfg
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen