Suse 8.2 (Heftvers.) C-Compiler fehlt !

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von DeMaephis, 20. September 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. DeMaephis

    DeMaephis Byte

    Registriert seit:
    12. September 2003
    Beiträge:
    9
    Seid gegrüßt,

    ich brauch für die Heft-Version Suse 8.2 einen C-Compiler ... wißt
    ihr welche Dateien ich dafür downloaden müßte ?

    Danke für eure Hilfe ... !
     
  2. tux71

    tux71 Byte

    Registriert seit:
    21. November 2000
    Beiträge:
    81
    Hallo,

    evtl. bestehne noch andere Abhängigkeiten für gcc. Du kannst Dir die Abhängikeiten aber alle anzeigen lassen, ohne das Du mit Yast arbeitest, am besten mit KPackage, da kannst Du auch die Installation als Test durchführen und es werden alle ungereimtheiten angezeigt.
    Auf der Heftcd vpn PC-Welt ist gcc aufjeden fall nicht dabei. Soll ja schliessich auch eine Version zum schnuppern sein.

    Als allgemeine Entwicklungsumgebung kann ich das Gesamt packet K-Deverlop empfehlen.

    Am besten rechner so schnell wie möglich ins Netz bringen updaten und loslegen.

    CU:D
     
  3. DeMaephis

    DeMaephis Byte

    Registriert seit:
    12. September 2003
    Beiträge:
    9
    Das geht aber nur wenn der Internetzugang unter Linux funktioniert - was bei mir z.Zt. nicht der Fall ist. Deshalb hab ich mir jetzt schon einige Dateien runtergeladen aber wenn ich gcc installieren will bekomm ich nur noch einen Abhängigkeitskonflikt.

    Da steht dann in großen roten Buchstaben:

    'cpp nich verfügbar

    gcc benötigt cpp = 3.3.1-16'

    ich hab schon Folgende Dateien runtergeladen
    'cpp-3.3-23.i586.rpm'
    'gcc-c++-3.3-23.i586.rpm'

    bringt aber nichts... und mit rpmseek.de bin ich auch nicht fündig geworden... kann jemand weiterhelfen... ich hab keine ahnung was ich da noch installieren muß um den Abhängigkeitskonflikt zu beseitigen.

    Vielen Dank für eure Hilfe !!!!
     
  4. julian14

    julian14 Kbyte

    Registriert seit:
    20. Januar 2003
    Beiträge:
    379
    Ich weiß jetzt, wie es geht.
    Meine Lösung:
    Yast öffnen,
    Software,
    Installationsquelle wechseln.

    Da gibt man dann einen Server in der Nähe ein (Übersicht unter www.suse.de)
    Dann werden glaube ich die Beschreibung zu den einzelnen Paketen geladen.

    Als nächstes öffnet man "Software installieren oder löschen". Dann kann man die ganze Software installieren, die auf dem Server ist, also auch gcc.
     
  5. julian14

    julian14 Kbyte

    Registriert seit:
    20. Januar 2003
    Beiträge:
    379
    Echt? Das habe ich schon am Anfang gemacht und YaST hat glaube ich nichts gefunden.

    Bin grad dabei, die Installationsquelle zu ändern, also dass er vom SuSE Server Programme installiert.
    Da kommt jetzt "Installationsquelle wird hinzugefügt..."
    Das dürfte länger dauern, da ja die Beschreibung etc. geladen wird.

    Wenn es vorbei ist, und es nicht geklappt hat, suche ich nochmal auf der CD.

    Gruß, Julian
     
  6. Bio-logisch

    Bio-logisch Halbes Megabyte

    Registriert seit:
    18. Februar 2002
    Beiträge:
    708
    Der Kompiler ist auf der CD drauf, einfach mal nach gcc in yast suchen.

    MfG, Bio-logisch
     
  7. julian14

    julian14 Kbyte

    Registriert seit:
    20. Januar 2003
    Beiträge:
    379
    Das müssten dann die Dateien sein:

    gcc-3.3-23.i586.rpm 578 KB 13.03.2003 00:00:00
    gcc-c++-3.3-23.i586.rpm 1687 KB 13.03.2003 00:00:00
    gcc-g77-3.3-23.i586.rpm 2050 KB 13.03.2003 00:00:00
    gcc-info-3.3-23.i586.rpm 764 KB 13.03.2003 00:00:00
    gcc-java-3.3-23.i586.rpm 1612 KB 13.03.2003 00:00:00
    gcc-objc-3.3-23.i586.rpm 1497 KB 13.03.2003 00:00:00


    Habe ich schon heruntergeladen, aber dann hat er wieder andere gewollt.

    Das einfachst müsste doch sein, die Installationsquelle zu wechseln. Da gibt es ja auch einen Punkt in YaST.
    Das hat aber bei mir nicht richtig geklappt.

    Kann mir jemand sagen, was für eine Adresse ich da genau eingeben muss?

    Gruß, Julian
     
  8. AS_X

    AS_X Halbes Megabyte

    Registriert seit:
    17. Oktober 2002
    Beiträge:
    585
  9. bitumen

    bitumen Megabyte

    Registriert seit:
    4. Juni 2002
    Beiträge:
    1.952
    wie wärs mit ggc? :D :D :D
     
  10. julian14

    julian14 Kbyte

    Registriert seit:
    20. Januar 2003
    Beiträge:
    379
    Brauche ich auch.
    Habe schon versucht, die Installations Quelle zu wechseln, also vom SuSE Server zu installieren, aber das hat net richtig geklappt. Wollte morgen weiterversuchen, weil da des Internet (ISDN-XXL) umsonst ist.
    Wenn ich es geschafft habe, werde ich es hier poste, glaube aber, dass das Problem dann schon gelöst ist, weil es hier bestimmt ein paar Leute gibt, die sich besser auskennen!
    Gruß, Julian
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen