Suse 8.2 PCW, xine u. mplayer laufen nicht

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von belladonna, 17. September 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Hallo, habe mir von der Uni Bayreuth xine 0.9.18 und den mplayer heruntergeladen u. installiert. Beim Start von xine erscheint zwar das Programm auf dem Desktop, aber dann tut sich nichts mehr, ich muss es sogar killen. Der mplayer startet noch nicht einmal. den habe ich übrigens bei allen Suse ab 7.0 und auch bei Knoppix noch nie zum Laufen gebracht. Oder kennt einer von euch noch andere Video.Abspielprogramme ???
     
  2. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Dann bescheide ich mich zunächst mit der Version als root. Vielen Dank, Acki, Du hast mir sehr geholfen.
     
  3. Acki D.

    Acki D. Byte

    Registriert seit:
    21. September 2003
    Beiträge:
    86
    Hmm...sorry,belladonna..hier bin ich leider mit meinem Latein am Ende.Die Fehlermeldungen sind jetzt etwas anders,ich kann da mittlerweile nicht mehr helfen.Was mich wundert ist diese Meldung fast am Ende:

    MPlayer interrupted by signal 11 in module: ao2_init
    - MPlayer crashed by bad usage of CPU/FPU/RAM.

    Ein Hardware-Problem kann es ja eigentlich nicht sein,weil als eingeloggter Root geht es ja,wie Du gesagt hast.Es muß irgendein Rechte-Problem sein.Nur diese Fehlermeldung irritiert mich halt total.Es gibt jetzt mehrere Möglichkeiten für Dich:
    a) Video immer als eingeloggter Root schauen
    (nicht so schön)
    b) MPlayer selber kompilieren (nicht einfach!)
    c)eine vorgefertigte,bessere MPlayer-Version von http://packman.links2linux.de saugen und installieren
    d)andere Video-Player benutzen,z.B. Ogle oder xine
    e)andere Linux-User fragen,eventuell auf der MPlayer-Mailingliste oder in einem MPlayer-Forum,da wird Dir vielleicht besser geholfen

    Hoffe,etwas geholfen zu haben
    Gruß
    Acki
     
  4. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Hier hat ein Missverständnis vorgelegen: gmplayer mit allen Funktionen läuft nur, wenn ich mich über den Anmeldebildschirm als root eingelogt habe.
    Bei Einloggen als user und danach Anmelden als root kann gmplayer X11 nicht öffnen. Siehe Verlauf:
    juel1@linux:~> su
    Password:
    linux:/home/juel1 # gmplayer

    Reading config file /etc/mplayer/mplayer.conf
    Reading config file /root/.mplayer/config
    [cfg] read config file: /root/.mplayer/gui.conf
    Reading config file /root/.mplayer/gui.conf
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    vo: couldn't open the X11 display (:0)!
    MPlayer GUI requires X11.
    Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
    Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
    Usage: mplayer [options] [url|path/]filename

    Basic options: (complete list in the man page)
    -vo <drv[:dev]> select video output driver & device ('-vo help' for a list)
    -ao <drv[:dev]> select audio output driver & device ('-ao help' for a list)
    -vcd <trackno> play VCD (Video CD) track from device instead of plain file
    -dvd <titleno> play DVD title from device instead of plain file
    -alang/-slang select DVD audio/subtitle language (by 2-char country code)
    -ss <timepos> seek to given (seconds or hh:mm:ss) position
    -nosound do not play sound
    -fs fullscreen playback (or -vm, -zoom, details in the man page)
    -x <x> -y <y> set display resolution (for use with -vm or -zoom)
    -sub <file> specify subtitle file to use (also see -subfps, -subdelay)
    -playlist <file> specify playlist file
    -vid x -aid y select video (x) and audio (y) stream to play
    -fps x -srate y change video (x fps) and audio (y Hz) rate
    -pp <quality> enable postprocessing filter (details in the man page)
    -framedrop enable frame dropping (for slow machines)

    Basic keys: (complete list in the man page, also check input.conf)
    <- or -> seek backward/forward 10 seconds
    up or down seek backward/forward 1 minute
    pgup or pgdown seek backward/forward 10 minutes
    < or > step backward/forward in playlist
    p or SPACE pause movie (press any key to continue)
    q or ESC stop playing and quit program
    + or - adjust audio delay by +/- 0.1 second
    o cycle OSD mode: none / seekbar / seekbar + timer
    * or / increase or decrease PCM volume
    z or x adjust subtitle delay by +/- 0.1 second
    r or t adjust subtitle position up/down, also see -vop expand



    linux:/home/juel1 #

    Nach Eingabe der echo-Zeile als root, danach Aufrufen von gmplayer als user erscheint grafische Darstellung auf Desktop: Bei Open DVD erscheint die gleiche Fehlermeldung wie gehabt, aber anderer Verlauf:
    juel1@linux:~> su
    Password:
    linux:/home/juel1 # gmplayer

    Reading config file /etc/mplayer/mplayer.conf
    Reading config file /root/.mplayer/config
    [cfg] read config file: /root/.mplayer/gui.conf
    Reading config file /root/.mplayer/gui.conf
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    vo: couldn't open the X11 display (:0)!
    MPlayer GUI requires X11.
    Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
    Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
    Usage: mplayer [options] [url|path/]filename



    linux:/home/juel1 # echo 1024 > /proc/sys/dev/rtc/max-user-freq
    linux:/home/juel1 # exit
    exit
    juel1@linux:~> gmplayer
    MPlayer 0.91-RPM-3.1 (C) 2000-2003 MPlayer Team
    CPU: Intel (Family: 8, Stepping: 7)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with Runtime CPU Detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with --disable-runtime-cpudetection
    Reading config file /etc/mplayer/mplayer.conf
    Reading config file /home/juel1/.mplayer/config
    [cfg] read config file: /home/juel1/.mplayer/gui.conf
    Reading config file /home/juel1/.mplayer/gui.conf
    vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0" => local display)
    Disabling DPMS
    Reading /home/juel1/.mplayer/codecs.conf: can't open '/home/juel1/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
    Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
    font: can't open file: /home/juel1/.mplayer/font/font.desc
    font: can't open file: /usr/share/mplayer/font/font.desc
    Using Linux hardware RTC timing (1024Hz).
    Can't open input config file /home/juel1/.mplayer/input.conf: Datei oder Verzeichnis nicht gefunden
    Input config file /etc/mplayer/input.conf parsed: 52 binds
    SKIN dir 1: '/home/juel1/.mplayer/Skin'
    SKIN dir 2: '/usr/share/mplayer/Skin'

    Playing /dev/dvd
    Reading disc structure, please wait...
    *** Zero check failed in ifo_read.c:1637
    for vts_attributes->vtstt_audio_attr = 0xc4c5656400000000
    *** Zero check failed in ifo_read.c:1637
    for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
    *** Zero check failed in ifo_read.c:1637
    for vts_attributes->vtstt_audio_attr = 0x04c16e6500030000
    *** Zero check failed in ifo_read.c:1649
    for vts_attributes->vtstt_subp_attr = 0x01006e650000
    *** Zero check failed in ifo_read.c:1649
    for vts_attributes->vtstt_subp_attr = 0x010065640000
    *** Zero check failed in ifo_read.c:1649
    for vts_attributes->vtstt_subp_attr = 0x01006564000d
    *** Zero check failed in ifo_read.c:1649
    for vts_attributes->vtstt_subp_attr = 0x010072740000
    *** Zero check failed in ifo_read.c:1649
    for vts_attributes->vtstt_subp_attr = 0x010065640009
    There are 1 titles on this DVD.
    There are 21 chapters in this DVD title.
    There are 1 angles in this DVD title.
    *** Zero check failed in ifo_read.c:443
    for vtsi_mat->vts_audio_attr = 0xc4c5656400000000
    *** Zero check failed in ifo_read.c:443
    for vtsi_mat->vts_audio_attr = 0x04c56e6500000000
    *** Zero check failed in ifo_read.c:443
    for vtsi_mat->vts_audio_attr = 0x04c16e6500030000
    *** Zero check failed in ifo_read.c:447
    for vtsi_mat->vts_subp_attr = 0x01006e650000
    *** Zero check failed in ifo_read.c:447
    for vtsi_mat->vts_subp_attr = 0x010065640000
    *** Zero check failed in ifo_read.c:447
    for vtsi_mat->vts_subp_attr = 0x01006564000d
    *** Zero check failed in ifo_read.c:447
    for vtsi_mat->vts_subp_attr = 0x010072740000
    *** Zero check failed in ifo_read.c:447
    for vtsi_mat->vts_subp_attr = 0x010065640009
    DVD successfully opened.
    Cache fill: 11,52% (966656 bytes) MPEG-PS file format detected.
    VIDEO: MPEG2 720x576 (aspect 3) 25,00 fps 9800,0 kbps (1225,0 kbyte/s)
    ==========================================================================
    Opening audio decoder: [liba52] AC3 decoding with liba52
    Using SSE optimized IMDCT transform
    AC3: 5.1 (3f+2r+lfe) 48000 Hz 384,0 kbit/s
    Using MMX optimized resampler
    AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 48000->192000 (384,0 kbit)
    Selected audio codec: [a52] afm:liba52 (AC3-liba52)
    ==========================================================================
    ==========================================================================
    Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
    VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
    Could not find matching colorspace - retrying with -vop scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    VDecoder init failed :(
    Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder v2.0
    libmpeg2: Using MMXEXT for IDCT transform
    libmpeg2: Using MMXEXT for motion compensation
    VDec: vo config request - 720 x 576 (preferred csp: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1,78:1 - prescaling to correct movie aspect.
    VO: [xv] 720x576 => 1024x576 Planar YV12
    Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
    ==========================================================================
    Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
    AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
    AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
    audio_setup: Can't open audio device /dev/dsp: Das Gerät oder die Ressource ist belegt
    SDL: Samplerate: 48000Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
    mcop warning: user defined signal handler found for SIG_PIPE, overriding


    MPlayer interrupted by signal 11 in module: ao2_init
    - MPlayer crashed by bad usage of CPU/FPU/RAM.
    Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
    disassembly. For details, see DOCS/bugreports.html#crash.b.
    - MPlayer crashed. This shouldn't happen.
    It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc
    version. If you think it's MPlayer's fault, please read DOCS/bugreports.html
    and follow the instructions there. We can't and won't help unless you provide
    this information when reporting a possible bug.
    Successfully enabled DPMS
    juel1@linux:~>
     
  5. Acki D.

    Acki D. Byte

    Registriert seit:
    21. September 2003
    Beiträge:
    86
    Hier wird wohl immer noch der Fehler liegen..
    mach mal als root ein
    echo 1024 > /proc/sys/dev/rtc/max-user-freq (alles in eine Zeile!)
    ,gehe aus dem root-modus wieder raus und versuch es nochmal.Eine Frage: Du hast versucht,den Mplayer als root zu starten,allerdings aus der Kommandozeile eines Users.Hast Du Dich schon mal "richtig" als root eingeloggt,also schon beim Anmeldebildschirm?Wenn nicht,mach das mal (einfach root bei username eintippen und das passwort natürlich) und starte danach mal gmplayer aus der Kommandozeile.Sag mir dann bitte,ob es funktioniert.Wenn ja,haben wir nur ein reines Rechteproblem.
    Gruß,
    Acki (wir sind fast am Ziel!)
     
  6. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Als user gebe ich ls -la /dev/rtc ein. Ergebnis:
    crwxrwxrwx 1 root root 10,135 2003-03-14 14:07 /dev/rtc
    Nach Eingang als root u. Eingabe chmod u. Rückkehr als user kommt gleiche Fehlermeldung wie zuvor u. folgender Verlauf:
    juel1@linux:~> ls -la /dev/rtc
    crwxrwxrwx 1 root root 10, 135 2003-03-14 14:07 /dev/rtc
    juel1@linux:~> su
    Password:
    linux:/home/juel1 # gmplayer
    MPlayer 0.91-RPM-3.1 (C) 2000-2003 MPlayer Team
    CPU: Intel (Family: 8, Stepping: 7)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with Runtime CPU Detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with --disable-runtime-cpudetection
    Reading config file /etc/mplayer/mplayer.conf
    Reading config file /root/.mplayer/config
    [cfg] read config file: /root/.mplayer/gui.conf
    Reading config file /root/.mplayer/gui.conf
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    vo: couldn't open the X11 display (:0.0)!
    MPlayer GUI requires X11.
    Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
    Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
    Usage: mplayer [options] [url|path/]filename

    Basic options: (complete list in the man page)
    -vo <drv[:dev]> select video output driver & device ('-vo help' for a list)
    -ao <drv[:dev]> select audio output driver & device ('-ao help' for a list)
    -vcd <trackno> play VCD (Video CD) track from device instead of plain file
    -dvd <titleno> play DVD title from device instead of plain file
    -alang/-slang select DVD audio/subtitle language (by 2-char country code)
    -ss <timepos> seek to given (seconds or hh:mm:ss) position
    -nosound do not play sound
    -fs fullscreen playback (or -vm, -zoom, details in the man page)
    -x <x> -y <y> set display resolution (for use with -vm or -zoom)
    -sub <file> specify subtitle file to use (also see -subfps, -subdelay)
    -playlist <file> specify playlist file
    -vid x -aid y select video (x) and audio (y) stream to play
    -fps x -srate y change video (x fps) and audio (y Hz) rate
    -pp <quality> enable postprocessing filter (details in the man page)
    -framedrop enable frame dropping (for slow machines)

    Basic keys: (complete list in the man page, also check input.conf)
    <- or -> seek backward/forward 10 seconds
    up or down seek backward/forward 1 minute
    pgup or pgdown seek backward/forward 10 minutes
    < or > step backward/forward in playlist
    p or SPACE pause movie (press any key to continue)
    q or ESC stop playing and quit program
    + or - adjust audio delay by +/- 0.1 second
    o cycle OSD mode: none / seekbar / seekbar + timer
    * or / increase or decrease PCM volume
    z or x adjust subtitle delay by +/- 0.1 second
    r or t adjust subtitle position up/down, also see -vop expand

    * * * SEE THE MAN PAGE FOR DETAILS, FURTHER (ADVANCED) OPTIONS AND KEYS * * *

    linux:/home/juel1 # gmplayer -vo xv
    MPlayer 0.91-RPM-3.1 (C) 2000-2003 MPlayer Team
    CPU: Intel (Family: 8, Stepping: 7)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with Runtime CPU Detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with --disable-runtime-cpudetection
    Reading config file /etc/mplayer/mplayer.conf
    Reading config file /root/.mplayer/config
    [cfg] read config file: /root/.mplayer/gui.conf
    Reading config file /root/.mplayer/gui.conf
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    vo: couldn't open the X11 display (:0.0)!
    MPlayer GUI requires X11.
    Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
    Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
    Usage: mplayer [options] [url|path/]filename

    Basic options: (complete list in the man page)
    -vo <drv[:dev]> select video output driver & device ('-vo help' for a list)
    -ao <drv[:dev]> select audio output driver & device ('-ao help' for a list)
    -vcd <trackno> play VCD (Video CD) track from device instead of plain file
    -dvd <titleno> play DVD title from device instead of plain file
    -alang/-slang select DVD audio/subtitle language (by 2-char country code)
    -ss <timepos> seek to given (seconds or hh:mm:ss) position
    -nosound do not play sound
    -fs fullscreen playback (or -vm, -zoom, details in the man page)
    -x <x> -y <y> set display resolution (for use with -vm or -zoom)
    -sub <file> specify subtitle file to use (also see -subfps, -subdelay)
    -playlist <file> specify playlist file
    -vid x -aid y select video (x) and audio (y) stream to play
    -fps x -srate y change video (x fps) and audio (y Hz) rate
    -pp <quality> enable postprocessing filter (details in the man page)
    -framedrop enable frame dropping (for slow machines)

    Basic keys: (complete list in the man page, also check input.conf)
    <- or -> seek backward/forward 10 seconds
    up or down seek backward/forward 1 minute
    pgup or pgdown seek backward/forward 10 minutes
    < or > step backward/forward in playlist
    p or SPACE pause movie (press any key to continue)
    q or ESC stop playing and quit program
    + or - adjust audio delay by +/- 0.1 second
    o cycle OSD mode: none / seekbar / seekbar + timer
    * or / increase or decrease PCM volume
    z or x adjust subtitle delay by +/- 0.1 second
    r or t adjust subtitle position up/down, also see -vop expand

    * * * SEE THE MAN PAGE FOR DETAILS, FURTHER (ADVANCED) OPTIONS AND KEYS * * *

    linux:/home/juel1 # chmod 777 /dev/rtc
    linux:/home/juel1 # ls -la /dev/rtc
    crwxrwxrwx 1 root root 10, 135 2003-03-14 14:07 /dev/rtc
    linux:/home/juel1 # exit
    exit
    juel1@linux:~> gmplayer
    MPlayer 0.91-RPM-3.1 (C) 2000-2003 MPlayer Team
    CPU: Intel (Family: 8, Stepping: 7)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with Runtime CPU Detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with --disable-runtime-cpudetection
    Reading config file /etc/mplayer/mplayer.conf
    Reading config file /home/juel1/.mplayer/config
    [cfg] read config file: /home/juel1/.mplayer/gui.conf
    Reading config file /home/juel1/.mplayer/gui.conf
    vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
    Disabling DPMS
    Reading /home/juel1/.mplayer/codecs.conf: can't open '/home/juel1/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
    Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
    font: can't open file: /home/juel1/.mplayer/font/font.desc
    font: can't open file: /usr/share/mplayer/font/font.desc
    Linux RTC init error in ioctl (rtc_irqp_set 1024): Keine Berechtigung
    Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
    Using usleep() timing
    Can't open input config file /home/juel1/.mplayer/input.conf: Datei oder Verzeichnis nicht gefunden
    Input config file /etc/mplayer/input.conf parsed: 52 binds
    SKIN dir 1: '/home/juel1/.mplayer/Skin'
    SKIN dir 2: '/usr/share/mplayer/Skin'

    Playing /windows/E/Encoding/xXx_DivX[1].avi
    Cache fill: 0,00% (0 bytes) AVI file format detected.
    VIDEO: [DIVX] 512x256 16bpp 23,98 fps 793,5 kbps (96,9 kbyte/s)
    ==========================================================================
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    MP3lib: init layer2&3 finished, tables done
    AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 14000->176400 (112,0 kbit)
    Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
    ==========================================================================
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
    ==========================================================================
    Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
    AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
    AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
    audio_setup: Can't open audio device /dev/dsp: Das Gerät oder die Ressource ist belegt
    SDL: Samplerate: 44100Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
    mcop warning: user defined signal handler found for SIG_PIPE, overriding


    MPlayer interrupted by signal 11 in module: ao2_init
    - MPlayer crashed by bad usage of CPU/FPU/RAM.
    Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
    disassembly. For details, see DOCS/bugreports.html#crash.b.
    - MPlayer crashed. This shouldn't happen.
    It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc
    version. If you think it's MPlayer's fault, please read DOCS/bugreports.html
    and follow the instructions there. We can't and won't help unless you provide
    this information when reporting a possible bug.
    juel1@linux:~>
     
  7. Acki D.

    Acki D. Byte

    Registriert seit:
    21. September 2003
    Beiträge:
    86
    Na super,fast haben wir es geschafft.Wenn Du Dir mal den Output mal anschaust,wirst Du eine Fehlermeldung sehen

    Failed to open /dev/rtc: Keine Berechtigung (mplayer should be setuid root or /dev/rtc should be readable by the user.)

    Ich denke mal,darin liegt der Fehler.Mach bitte mal ein
    ls -la /dev/rtc und poste den Output.Wechsle mal in der Konsole
    mittels su zu root und mach dann mal ein
    chmod 777 /dev/rtc und logg Dich mittels exit wieder aus dem Root-Modus aus.Dann tippe als normaler User wieder gmplayer ein und sag mir,was passiert.
    Gruß
    Acki
     
  8. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Nach dem Saugen von einigen Skins in /usr/share/mplayer/Skin und Eingabe von gmplayer als root erscheint die grafische Oberfläche und ich kann einen Videofile oder eine DVD laufen lassen. Ich habe das Icon auch auf den Desktop gezogen u. kann das Programm von dort starten. Bild u. Ton sind teilweise etwas abgehackt, da muß ich noch an den Einstellungen rumprobieren. Hast du vielleicht einige Tipps: ich habe eine Grafikkarte ATI Radeon 9600 TX AGP und eine Soundkarte Realtek AC97 Audio.
    Beim Starten von gmplayer als normaler user kommt folgende Meldung: MPlayer interrupted by signal 11 in modul ao2_init und folgendem Verlauf:
    juel1@linux:~> gmplayer
    MPlayer 0.91-RPM-3.1 (C) 2000-2003 MPlayer Team
    CPU: Intel (Family: 8, Stepping: 7)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with Runtime CPU Detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with --disable-runtime-cpudetection
    Reading config file /etc/mplayer/mplayer.conf
    Reading config file /home/juel1/.mplayer/config
    [cfg] read config file: /home/juel1/.mplayer/gui.conf
    Reading config file /home/juel1/.mplayer/gui.conf
    vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
    Reading /home/juel1/.mplayer/codecs.conf: can't open '/home/juel1/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
    Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
    font: can't open file: /home/juel1/.mplayer/font/font.desc
    font: can't open file: /usr/share/mplayer/font/font.desc
    Failed to open /dev/rtc: Keine Berechtigung (mplayer should be setuid root or /dev/rtc should be readable by the user.)
    Using usleep() timing
    Can't open input config file /home/juel1/.mplayer/input.conf: Datei oder Verzeichnis nicht gefunden
    Input config file /etc/mplayer/input.conf parsed: 52 binds
    SKIN dir 1: '/home/juel1/.mplayer/Skin'
    SKIN dir 2: '/usr/share/mplayer/Skin'

    Playing /windows/E/Encoding/xXx_DivX[1].avi
    AVI file format detected.
    VIDEO: [DIVX] 512x256 16bpp 23,98 fps 793,5 kbps (96,9 kbyte/s)
    ==========================================================================
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    MP3lib: init layer2&3 finished, tables done
    AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 14000->176400 (112,0 kbit)
    Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
    ==========================================================================
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
    ==========================================================================
    Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
    AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
    AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
    audio_setup: Can't open audio device /dev/dsp: Das Gerät oder die Ressource ist belegt
    SDL: Samplerate: 44100Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
    mcop warning: user defined signal handler found for SIG_PIPE, overriding


    MPlayer interrupted by signal 11 in module: ao2_init
    - MPlayer crashed by bad usage of CPU/FPU/RAM.
    Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
    disassembly. For details, see DOCS/bugreports.html#crash.b.
    - MPlayer crashed. This shouldn't happen.
    It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc
    version. If you think it's MPlayer's fault, please read DOCS/bugreports.html
    and follow the instructions there. We can't and won't help unless you provide
    this information when reporting a possible bug.
    juel1@linux:~>
     
  9. Acki D.

    Acki D. Byte

    Registriert seit:
    21. September 2003
    Beiträge:
    86
    Ok,das sieht doch schon mal nicht ganz so schlecht aus. Wenn Du den Mplayer mit
    gmplayer startest,kommt dann eine grafische Oberfläche?Die letzten 3 Zeilen lassen ja erahnen,dass da nix kommt,weil er keinen Skin findet.Sind in dem Verzeichnis
    /usr/share/mplayer/Skin irgendwelche Skins,also Verzeichniss drin?Mach mal ein
    ls -la /usr/share/mplayer/Skin und poste mal den Output.Falls da nix drin ist,lad Dir mal von der Mplayer-HomePage einige Skins runter und pack die mal in dieses Verzeichnis rein.
    Ich glaub www.mplayerhq.hu oder so ähnlich.Schau mal bei Google vorbei.
    Achso: tippst Du gmplayer als root ein oder als normaler Benutzer?
    Gruß
    Acki
     
  10. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Beim Starten von der Kommandozeile mit mplayer --gui filename wird der Videofilm von Platte abgespielt, aber ohne jegliche Eingreifmöglichkeit (wie Vorspulen, Lautstärke u.ä.).
    Bei Eigabe von gmplayer erscheint folgender Verlauf:
    linux:~ # gmplayer
    MPlayer 0.91-RPM-3.1 (C) 2000-2003 MPlayer Team
    CPU: Intel (Family: 8, Stepping: 7)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with Runtime CPU Detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with --disable-runtime-cpudetection
    Reading config file /etc/mplayer/mplayer.conf
    Reading config file /root/.mplayer/config
    [cfg] read config file: /root/.mplayer/gui.conf
    Reading config file /root/.mplayer/gui.conf: No such file or directory
    vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
    Disabling DPMS
    Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': No such file or directory
    Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
    font: can't open file: /root/.mplayer/font/font.desc
    font: can't open file: /usr/share/mplayer/font/font.desc
    Using Linux hardware RTC timing (1024Hz).
    Can't open input config file /root/.mplayer/input.conf: No such file or directory
    Input config file /etc/mplayer/input.conf parsed: 52 binds
    SKIN dir 1: '/root/.mplayer/Skin'
    SKIN dir 2: '/usr/share/mplayer/Skin'
    [skin] file ( /usr/share/mplayer/Skin/default/skin ) not found.
    Skin not found ( default ).
    linux:~ #
    Gruß belladonna
     
  11. Acki D.

    Acki D. Byte

    Registriert seit:
    21. September 2003
    Beiträge:
    86
    Ok. Dann starte es doch mal aus der Kommandozeile,entweder über mplayer, oder mplayer --gui oder gmplayer.
    Dann tauchen meistens ein paar Meldungen auf der Kommandozeile auf,wenn er versucht zu starten.Diese Meldungen kannst Du mal hier posten,vielleicht sehen wir dann woran es liegt.In die Glaskugel schauen kann ich leider auch nicht.
    :rolleyes:
     
  12. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Das Starten des Programmes von einem Icon auf dem Desktop geht nicht. Es reagiert überhaupt nicht, keine Fehlermeldung, nichts.
     
  13. Acki D.

    Acki D. Byte

    Registriert seit:
    21. September 2003
    Beiträge:
    86

    Hmm...eventuell ein Problem mit den Benutzerrechten?Was genau geht denn nicht?
    Eventuell ne Fehlermeldung,wenn Du es von der grafischen Oberfläche versuchst?
    Ich benutze immer in der Kommandozeile
    gmplayer &
    das andere geht bei mir komischerweise auch nicht,das Fenster öffnet sich zwar,bleibt aber schwarz.Keine Ahnung warum...
    Gruß
    Acki
     
  14. pausenclown

    pausenclown Halbes Megabyte

    Registriert seit:
    29. Mai 2002
    Beiträge:
    564
  15. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Danke, Comants und Acki D. Jetzt bin ich soweit, daß ich mplayer -vo xv videofile von der Kommandozeile als root starten und ein Video abspielen kann. Aber warum kann ich das Programm nicht direkt aus /usr/bin/mplayer starten bzw. dieses icon auf den Dektop ziehen u. von dort Einstellungen vornehmen, ein Video öffnen u. dann starten. So ist das ja sehr unkomfortabel.
    Grüsse belladonna
     
  16. Acki D.

    Acki D. Byte

    Registriert seit:
    21. September 2003
    Beiträge:
    86
    Hmm..laß mal das kpackage weg und geh mal auf die Kommandozeile,oftmals sieht man dann die Fehler besser.

    rpm -e mplayer deinstalliert mplayer.
    rpm -q mplayer prüft,ob mplayer installiert ist.
    rpm -ivh <paketname> installiert ein Paket.

    Gruß,
    Acki
     
  17. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Ich habe jetzt aus dem Verzeichnis, aus dem ich installiere, alle mplayer-Dateien (auch rpm's) entfernt ausser den 7, die ich ja brauche, um erneut zu installieren.
    Mit Kpackage habe ich erneut versucht, die beiden angeblich installierten, zu deinstallieren. Aber das gelingt nicht. Es kommt dann die message: mplayer-2: 0.91-2 Pakete konnten nicht installiert werden.
     
  18. Comants

    Comants Byte

    Registriert seit:
    14. September 2003
    Beiträge:
    14
    Hi belladonna

    Eine Übersicht aller installierten rpm-Pakete kannst du mit KPackage erhalten (im K-Menü unter System/Konfiguration)
    Mit KPackage kann man auch Pakete installieren/deinstallieren.
    Sei dir aber sicher, was du machst...

    Mit meinem vorigen Tipp meinte ich, dass du die 2 Pakete aus dem Verzeichnis nehmen sollst aus dem du installierst, nicht die schon installierten Dateien. Du kannst die aber auch nochmal mit KPackage deinstallieren.

    Eine Registry wie unter Windows gibt es in Linux nicht.
    Es gibt aber Konfigurationsdateien, die man in /etc findet.

    Gruß Comants
     
  19. belladonna

    belladonna Kbyte

    Registriert seit:
    7. Juli 2002
    Beiträge:
    161
    Hi Comants,
    dafür müsste ich die beiden Programme erst einmal finden. Ich habe mit Kfind u. Krusader alles durchsuchen lassen. Die haben nur mplayer-files in Verzeichnissen in Windows-Partitions gefunden. Von dort will ich ja nach deinem Muster installieren. Aber es kommt nach wie vor die Meldung:
    mplayer-0.91-2 bereits installiert
    mplayer-common-0.91-2 bereits installiert.
    Gibt es denn bei linux auch so eine Art Rgistry wie unter Windows ???
    Gruß belladonna
     
  20. Comants

    Comants Byte

    Registriert seit:
    14. September 2003
    Beiträge:
    14
    Hi belladonna

    Verschieb doch die 2 installierten Pakete einfach in ein anderes Verzeichnis, dann sollte es funktionieren.

    Tja, die Heft Version ist halt ziemlich abgespeckt, und da muss man teilweise noch nachinstallieren...

    Gruß Comants

    PS:
    Viel Spaß noch beim "linuxen" ...
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen