SuSE 8.2 schreibrecht auf FAT 32 Part.

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Der Eiserne II, 10. Juni 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    Ich habe auf meinem Leptop Windows XP und SuSE Linux 8.2
    Habe XP auf einer NTFS Partition und Linux / auf einer Reiser FS als Prim. Part. Die Linux Swap, die Linux /home als Reiser FS und eine Daten Partition mit Programme benannt als FAT 32 Part als Logisches Laufwerk in einer Erweiterten Part. Ich kann aber nicht als User auf die Programme Partition schreiben, mit Root schon. Habe unter Root im KDE unter Eigenschaften die Datei zugehöriggkeit verstellt, Anzeige stimmt schreibzugriff geht nicht. Habe es un der Shell mit chmod, chown und chgrp probiert und habe keine Fehlermeldung erhalten aber die Recht mit ls -l waren immer noch die gleichen. Im Knoquerer kommen auch 2 Ordner Programme zum vorschein einmal ein Link und einmal ein normaler Ordner. Was hat es mit dem Link auf sich und kann es sein daß man bei einer Partition die Rechte nicht endern kann. Ach ja habe es im Konquerer versucht die Rechte zu ändern samt Unterordner habe die Meldung bekommen habe keine schreibrecht und ich war aber root.
    Hat wer eine Erklärung?
     
  2. Bio-logisch

    Bio-logisch Halbes Megabyte

    Registriert seit:
    18. Februar 2002
    Beiträge:
    708
    <I>Nur gibt er jetzt bei einer neuen Datei den Benutzer und die Gruppe root an und nicht die des Benutzter und der Gruppe user. Obwohl ich die Datei nicht mit Root erstellt habe.</I>

    Weil FAT 32 keine Eigentumsrechte kennt. Deswegen ist für Linux immer der der Eigentümer der Dateien, der die Partiton eingebunden hat.

    Da es der User root ist, der die Partiton einbindet, haben die Dateien dann den Status "Eigentum von Root".

    Auch andere Dateiatribute kennt es nicht.
    Deswegen werden diese mit umask überschrieben.
    Der Wert 000 heißt, das jeder Benutzer jede Datei lesen, schreiben und ausführen darf, egal in welcher Gruppe er ist.

    MfG, Bio-logisch
    [Diese Nachricht wurde von Bio-logisch am 12.06.2003 | 23:40 geändert.]
     
  3. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    Danke für deinen Link habe ihn mir ausgedruckt und befolgt, Nur leider hatt er nichts genützt ich habe die Atribute rw,user,umask=000 brav gesetzt in den verschiedensten Arten und immer neu gebootet und ich habe aber nie schreibrechte bekommen. Ich war schon so verzeifelt daß ich in YaST2 gegangen bin dort unter System / Partitionieren habe die Programme Partiotion angewählt und habe auf Bearbeiten geklickt. Und was sehe ich da plötzlich einen Button Fstab-Optionen. Neugirig wie ich bin habe ich den gleich ausprobiert. Im Beliebigen Optionswert habe ich versuchsweise wieder rw,user,auto,umask=000 eingegeben und mit OK beendet und übernommen. Dann habe noch mal eine Frage in einem grünen Fenster beantwortet und seit dem habe ich schreibrechte auf der Partiton ohne Linux neu zu booten.
    Nur gibt er jetzt bei einer neuen Datei den Benutzer und die Gruppe root an und nicht die des Benutzter und der Gruppe user. Obwohl ich die Datei nicht mit Root erstellt habe.
     
  4. buherator

    buherator Byte

    Registriert seit:
    5. Juni 2003
    Beiträge:
    90
    dh&gt; partition umounten und dann mit mount wieder mounten. Es gibt auch irgendsoeinen Befehl wie "mount -remount -rw /dev/hdaX", dieser remountet dann eine screibgeschützte partition im read/write modus. (kann sein, das ich was mit den parametern verwechselt habe, es ist schon lange her als ich die entsprechende howto las...) Ansonsten ist remount nicht weiter von Bedeutung.

    mfg
     
  5. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    Bin zwar ein linux daumeier, aber einer der was lernen will. Also wie ist das mit den remount. Was kann das was macht das.
     
  6. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Bei mir ist die Gruppe standardmässig (von SuSE angelegt) als "users" bezeichnet.
    Bei Mandrake ist es dann wohl die Gruppe "user".

    Wieder was dazugelernt!:)
    MfG
    P.S. Entscheidend ist, dass die Gruppenbezeichnung im System und in der fstab übereinstimmen.
    [Diese Nachricht wurde von Rattiberta am 12.06.2003 | 13:27 geändert.]
     
  7. Bio-logisch

    Bio-logisch Halbes Megabyte

    Registriert seit:
    18. Februar 2002
    Beiträge:
    708
    Wie schon einige gesagt haben, einfach die Datei /etc/fstab editieren.

    Wenn die Partiton beim booten automatisch eingebunden werden soll, dann sieht der Eintrag so aus:
    /dev/hdxy /windows/C vfat umask=0 0 0
    x steht für das IDE - Device, y für die Partitonsnummer. Falls Du scsi hast, ändert sich das ganze zu sdxy.
    Näheres hier:
    http://chipfaq.piranho.de/#mount

    MfG, Bio-logisch
     
  8. buherator

    buherator Byte

    Registriert seit:
    5. Juni 2003
    Beiträge:
    90
    Also ich hab bei mandrake 9.1 folgende Zeile:
    /dev/hda1 /mnt/space ext3 user,sync,suid,exec 1 2
    (ist zwar kein fat, aber eigentlich müsste user ja funktionieren...)
    Wies bei SuSE ist, weiß ich nicht.

    mfg
     
  9. buherator

    buherator Byte

    Registriert seit:
    5. Juni 2003
    Beiträge:
    90
    Hast ja recht! Er schrieb, dass er ein "linux daumeier" sei, deswegen wollte ich ihn nicht mit remount verwirren, da ist es einfacher, das system neu zu starten.

    mfg
     
  10. buherator

    buherator Byte

    Registriert seit:
    5. Juni 2003
    Beiträge:
    90
    Hast ja recht! Er schrieb, dass er ein "linux daumeier" sei, deswegen wollte ich ihn nicht mit remount verwirren, da ist es einfacher, das system neu zu startet.

    mfg
     
  11. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Manchmal liegts wirklich an Kleinigkeiten:
    Die Option heißt "users" nicht "user"
    Bei mir lautet die entsprechende Zeile
    /dev/hda5 /windows/D vfat users,gid=users,umask=0002,iocharset=iso8859-15,code=437 0 0
    (Festplattenbezeichnung -Einhängepunkt - Dateisystem - Zugriff für users mit entsprechnder Gruppenidentität,Lese-und Schreibberechtigung, Festlegung des iso-Standards damit ü,ä,ö usw. korrekt gelesen und geschrieben werden

    Ein Tipp:
    Gib die Begriffe "umask" und "gid" in die Suchmaske des SuSE-Hilfesystems ein, dann bekommst Du eine umfangreiche Erläuterung .

    MfG
     
  12. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    AAhhhhhhhhhhhhhhhhhhhh du auch.
    Drum will ich immer einer Erklärung haben damit ich weiß was ich mache. Sonst weiß ich es bein nächsten mal wieder nicht. Ich will ja schließlich aus was lernen.

    unmask hat glaube ich was mit den Dateiatributen lesen, schreiben und ausführen was zu tun. Nur als ich 000 gesetzt habe konnte nicht einmal Root mer lessen.
     
  13. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    Gute Frage, soviel Ahnung habe ich nämlich auch nicht: Aber der Parameter "umask=" dürfte wichtig sein, da ich ihn damals bei Suse7.3 eintragen musste damit ich als User auf die NTFS Partition zugreifen konnte.
     
  14. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    MMMMMMMMMMMMMMMMM
    Schaut gut aus aber ich habe leider keinen blassen Schimmer was die Zeile bewirkt kannst du mir das vielleicht erklären bevor ich daß bei mir rein schreibe?
     
  15. ReneW

    ReneW Megabyte

    Registriert seit:
    28. Mai 2000
    Beiträge:
    2.486
    bei mir sieht es so aus

    /dev/hda6 /windows/E vfat users,gid=users,umask=0002,iocharset=iso8859-15,code=437 0 0
     
  16. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    Nein, ich meinte den Link von Programme ich habe in / einen Ordner von Programme und einen Link von Programme daß meinte ich.

    Tut leid mit .... defaults,user 0 0 geht es noch immer nicht.
     
  17. buherator

    buherator Byte

    Registriert seit:
    5. Juni 2003
    Beiträge:
    90
    Dann versuchs mal mit "...defaults,user 0 0"
    Ich weiß nicht, was du mit dem Link meinst. In einer Textdatei kann kein Link stehen.
    :###

    mfg
     
  18. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    Ja das habe ich auch geglaubt von wegen oprtionen, die Zeile sieht so aus.
    /dev/hda7 /Programme vfat defaults 0 0

    So und wie geht es jetzt bitte weiter? Und weißt du auch für was der Link gehört?
    [Diese Nachricht wurde von Der Eiserne II am 10.06.2003 | 23:08 geändert.]
     
  19. buherator

    buherator Byte

    Registriert seit:
    5. Juni 2003
    Beiträge:
    90
    Öffne die /etc/stab mit einem beliebigen text editor als root. Such dir die Zeile, in der deine fat32 part ist. da sind eher am ende der zeile optionen, die mit beistrichen getrennt sind. da schreibst du noch "user" rein. (auch mit einem beistrich getrennt) Nach einem reboot kannst du dann Mit dem Konqueror neue Rechte für normale Benutzer vergeben.

    Gruß, buherator
     
  20. Der Eiserne II

    Der Eiserne II Kbyte

    Registriert seit:
    25. Februar 2003
    Beiträge:
    263
    Entschuldige ich bin Linux Daumeier. Kannst du mir ein Beispiel schreiben. Eine kurze erklärung fände ich ganz Toll damit ich auch weiß was ich da mache. Danke. Ich habe in der /etc/fstab schon herum gedoktert mit unmask 000 und dan habe ich gar keine rechte mer gehabt. Den Befehl habe ich von einer Zip Laufwerkseinbindung für eine Live Version irgentwo ausgegraben. ( Hab halt in meiner Verzweiflung was ausprobiert. Dumm der Aufforderung von Kofler nach gekommen, Anfänger sollen einfach ein bischen probieren).

    Danke
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen