Suse 9.1 SE pcw-Edition und Nvidia -Treiber

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von RaBerti1, 4. Oktober 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. RaBerti1

    RaBerti1 Viertel Gigabyte

    Registriert seit:
    24. November 2000
    Beiträge:
    5.094
    Hi!

    Das hatte ich mir -ich gebs wirklich nur ungern zu- etwas einfacher vorgestellt.

    OK, die Installation von Suse lief unspektakulär über die Bühne, unerkannt blieb -erwartungsgemäß- der Medion-Scanner. Einrichten von Netzwerk, Zugang zum Web, alles wie erwartet und ruckzuck zu erledigen.

    ABER 3D-Funktionalität und NVIDIA-Treiber installieren?
    Es fing damit an, daß natürlich schon während der Suse-Installation auch gleich das Update aufgedudelt wurde mit neuerem Kernel. Dessen Sourcen waren natürlich nicht auf CD und wurden auch beim Update nicht autom. auf die HD gedudelt. Also nachladen von ftp://ftp.suse.com/pub/suse/9.1/ (oder so ähnlich; Danke an Suse für die DL-Möglichkeit!). Das allein half nicht: GCC-Compiler fehlte ebenso wie Make, also erneut: Nachladen. Dazu noch von NVIDIA den Treiber runterladen.

    Jetzt hab ich nach Anmeldung als root mit
    init 3
    den X-Server gekillt, um dann mit
    sh NVIDIA-treiber.6111.run
    (oder so ähnlich, jedenfalls richtigem Dateinamen) sowie dem Parameter --kernel-source-path und Argument richtigem Speicherort der entpackten Kernelsourcen die Installation versucht. Script startete, fragte Zustimmung zu AGBs ab, fand auch die Sourcen. Installation klappte aber trotzdem nicht, da im Kernel immer noch die Treiber für "rivafb" implementiert seien, womit der Nvidia-Treiber nicht kompatibel sein soll.

    Also Kernel komplett neu compilieren? Wenn ja, wär es sinnvoll, dann gleich von www.kernel.org die Sourcen eines 2.6.7 runterzuladen und den dann zu installieren, oder kommt der wieder mit den Suse-Eigenheiten nicht klar?

    MfG Raberti
     
  2. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
  3. RaBerti1

    RaBerti1 Viertel Gigabyte

    Registriert seit:
    24. November 2000
    Beiträge:
    5.094
    Danke erstmal.
    Ich hatte mir auch die howto (dieselbe? weiß ich jetzt nicht, ich meine, die meinige war nur auf 9.0 ausgerichtet) gezogen, aber es spielte sich komischerweise nicht so ab.
    Version 5138 (oder so ähnlich) ließ sich aber auf dem "easy way" willig installieren. Mal schauen, ob das Update auf die aktuelle Version 6111 klappt. Nötig ists angesichts des implantierten Graka-Oldies wahrscheinlich nicht, aber um des Spaßes willen, der Internet-Provider will ja auch leben...

    MfG Raberti
     
  4. Bio-logisch

    Bio-logisch Halbes Megabyte

    Registriert seit:
    18. Februar 2002
    Beiträge:
    708
    Never change a running System!
    Das gilt vor allem bei Grafikkartentreibern unter Linux...
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen