Systemwiederherstellungsreiter weg

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von mike03, 15. März 2006.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. mike03

    mike03 Byte

    Registriert seit:
    25. Mai 2003
    Beiträge:
    85
    Hallo, nach Deaktivieren der Systemwiederherstellung für alle Laufwerke und bejahen der Sicherheitsabfrage ist der Reiter dafür unter Arbeitsplatz verschwunden. Der RPC-Dienst lässt sich starten, aber der Systemwiederherst.dienst nicht. ( Fehler 5, Zugriff verweigert)dito auch im abgesicherten Modus. Gibt es eine Möglichkeit, einen Punkt zu finden, wo man die Deaktivierung aufheben kann? Alle Vorschläge im Netz gehen von einem vorhandenem Reiter unter Arbeitsplatz aus. Auch RSW u.ä. half nicht weiter. Bin immer als Admin. angemeldet.
    Jemand einen Tip?
    Mfg Mike
     
  2. MichaelausP

    MichaelausP Viertel Gigabyte

    Registriert seit:
    20. Juni 2001
    Beiträge:
    2.985
  3. mike03

    mike03 Byte

    Registriert seit:
    25. Mai 2003
    Beiträge:
    85
    Hallo Michael, danke für die Antwort. Aber diese Lösungen sind mehr für administrative Eingriffe gedacht.Die genannten Einstellungen sind bei mir alle im Sinne einer sichtbaren Konfigurationsschnittstelle ( Reiter) eingestellt, trotzdem kein Reiter unter Arbeitsplatz/Eigenschaften.Auch nach Aufspielen eines Backups das gleiche, auch eine Rep.install. brachte nichts.
    Verdacht:Irgendwo auf den Partitionen ein Eintrag, der alles abblockt, zwar komisch, mir fällt nach den ganzen Versuchen nix mehr ein.
    MfG Mike
     
  4. MichaelausP

    MichaelausP Viertel Gigabyte

    Registriert seit:
    20. Juni 2001
    Beiträge:
    2.985
    Habe noch nichts anderes gefunden, aber wenn ein Reiter nicht angezeigt wird, steckt der dafür nötige Eintrag in der Registry ... Die im Link genannten Schlüssel scheinen aber den Reiter nicht wieder hervor zubringen, wenn sie aus der Registry entfernt wurden ...
     
  5. gert12349

    gert12349 Halbes Megabyte

    Registriert seit:
    21. Oktober 2001
    Beiträge:
    651
    @mike03
    Schau mal nach, ob in der Registrierung die beiden in den Screenshots markierten Schlüssel (Start und DisableSR) existieren und den richtigen Wert (jeweils REG_DWORD 0) haben.
     

    Anhänge:

  6. mike03

    mike03 Byte

    Registriert seit:
    25. Mai 2003
    Beiträge:
    85
    Hallo Gert, vielen Dank, aber die beiden Bilder sind deckungsgleich mit meinen Einträgen.Grübel, grübel...
    Find es blöd, deswegen eine Neuinstall zu machen, zum Glück ist es nicht der Hauptrechner.Leider ist ja die Meldung : Fehler 5, Zugriff verweigert,beim Versuch, den SR-Dienst zu starten, nicht sehr aussagekräftig.
    Also, trotzdem danke
    MfG Mike
     
  7. gert12349

    gert12349 Halbes Megabyte

    Registriert seit:
    21. Oktober 2001
    Beiträge:
    651
  8. Nevok

    Nevok Ganzes Gigabyte

    Registriert seit:
    3. Oktober 2002
    Beiträge:
    12.196
  9. mike03

    mike03 Byte

    Registriert seit:
    25. Mai 2003
    Beiträge:
    85
    Danke Gert, für die Mühe, aber auch hier Fehlanzeige.Hatte aber auch nach 15 Jahren PC noch nie eine zerstörte Systemdatei, dafür aber genug andere Probleme.
    Viel Spass weiterhin mit dem umfangreichen Infohintergrund.Man muss ja schon einen Kopf wie ein Pferd haben bei der Informationsflut.
    Bis bald, Mike
     
  10. mike03

    mike03 Byte

    Registriert seit:
    25. Mai 2003
    Beiträge:
    85
    Hallo Nevok, auch Dir danke für den Tip, es fehlte in der Registry ein anderer Eintrag: RestoreStatus, aber auch das brachte nichts.Es scheint also tiefer zu liegen. Wenn sowas durch Entfernen eines Haken passieren kann, was ja z.B. bei Virenbefall nützlich ist,dann spreche ich von einem Bug.Habe ja keine Modifikationen in der Registry vorgenommen.Jedenfalls ist der Vergleich mit einem PC, der nicht dieses Verhalten zeigt, ergebnislos geblieben.
    MfG Mike
     
  11. MichaelausP

    MichaelausP Viertel Gigabyte

    Registriert seit:
    20. Juni 2001
    Beiträge:
    2.985
    Vielleicht ist auch eine DLL zerschossen? Die Frage ist, welche - für den Explorer, der SR ...

    Edit:
    Im TaskManager erscheint die rundll32.exe, sobald die Systemeigenschaften aufgerufen werden (Win+Pause)!?! Nun nur noch herausfinden, was den Reiter ausblendet ...

    Edit2:
    In diesem Pfad findest du das Systemwiederherstellungsprogramm (rstrui.exe): C:\WINDOWS\system32\Restore
    führe es aus und klicke im Willkommen-Fenster unten auf den Link Systemwiederherstellungseinstellungen, es sollte sich das Systemeigenschaften-Dialog-Fenster öffnen. Taucht der Reiter jetzt auf? Ich vermute, er ist nicht erschienen :-(
     
  12. mike03

    mike03 Byte

    Registriert seit:
    25. Mai 2003
    Beiträge:
    85
    Hallo Michael, wir kommen der Sache näher.
    1. Die rundll.exe hat auf meinem Haupt-PC 7,780KB, auf dem ohne SR nur 7,448KB. Ich weiss aber nicht, ob diese rundll.exe auf jedem System gleich sein muss, wenn ja, wie austauschen? ( Konsole?)
    Wird diese Datei bei einer Rep.install nicht überschrieben? Wenn die rundll.exe zerschossen ist, wo liegt derGrund? Meist kündigt sich ein HDD-Fehler an, hoffentlich nicht.
    Vielleicht hast Du noch einen Rat.
    MfG Mike
    Edit: zu1.:Ist natürlich falsch, weil es sich um eine dynamische Grösse handelt, bei jedem Start andere Grösse.
    Wenn ich die rstrui.exe öffne, kommt sofort der Hinweis, dass die SR den Computer nicht sichern kann, Neustart wird verlangt, der aber nix bringt.Wenn ich die Systemwiederherstellungseinstellungen anklicke, erscheint, wie Du vermutest, kein SR-Reiter.Die Logs unter Restore werden aber täglich erstellt.
     
  13. MichaelausP

    MichaelausP Viertel Gigabyte

    Registriert seit:
    20. Juni 2001
    Beiträge:
    2.985
    Was hat denn die rundll32.exe für eine Größe (33,0 KB (33.792 Bytes))?
    Was steht denn in der Ereignisanzeige der Verwaltung/Anwendungen?
     
  14. mike03

    mike03 Byte

    Registriert seit:
    25. Mai 2003
    Beiträge:
    85
    Unter Anwendungen erscheint keine Fehlermeldung, dafür unter System:1.ServiceControlManager...Dienst mit Fehler beendet, Zugriff verweigert.
    2.srservice...Initialisierung der Systemwiederherstellung ist fehlgeschlagen...
    Der SCM protokolliert dann noch das Starten, Ausführen und Beenden des SR-Dienst.
     
  15. mike03

    mike03 Byte

    Registriert seit:
    25. Mai 2003
    Beiträge:
    85
    rundll32.exe : 33.792 B
     
  16. MichaelausP

    MichaelausP Viertel Gigabyte

    Registriert seit:
    20. Juni 2001
    Beiträge:
    2.985
    Schau mal in der Registry in diesem Pfad nach:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost ... im rechten Fenster gibt es einen Schlüssel netsvcs, klicke da mal doppelt drauf und suche in der Liste nach SRService, ob er dort steht ...
    Hintergrund: In den Eigenschaften des Systemwiederherstellungsdienstes steht als Pfad für die EXE-Datei: C:\WINDOWS\System32\svchost.exe -k netsvcs

    Wenn jemand den Eindruck hat, wir suchen die Nadel im Heuhaufen - ja, das machen wir!
     
  17. mike03

    mike03 Byte

    Registriert seit:
    25. Mai 2003
    Beiträge:
    85
    Ja Michael, so ist es auch bei mir, SRService vorhanden. Die Nadel im Heuhaufen finden wär ja nicht so schlimm, wenn nur der Windowsheuhaufen nicht so gross wär. So intensiv in die Tiefen des BS lange nicht getaucht. In der Zeit hätte man auch ein neues System aufgesetzt, wenn da nicht die Neugier wäre.
    Bis dann Mike
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen