Textmarken (Anker) und Netscape

Dieses Thema im Forum "Browser" wurde erstellt von HankXX, 26. Dezember 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. HankXX

    HankXX ROM

    Registriert seit:
    12. September 2001
    Beiträge:
    5
    Hi,

    ich habe eine Frameseite (Inhaltverzeichnis + Hauptframe) und
    möchte durch Links und Textmarken innerhalt des Hauptframes
    navigieren. Beim Internetexplorer funktioniert das. Beim
    Netscape dagegen nicht richtig, d.h. manche Textmarken
    funktionieren nicht.
    Quellcode im Inhaltverzeichtnis:<a target="Hauptframe" href="products.htm#Produkt1"><font color="#480800" size="4">Produkt1</font></a></b><br>
    im Hauptframe (Seite Products.htm):p><font face="Arial"><a name="Produkt1"></a></font></p>
    Kennt jemand das Problem?

    Hank
     
  2. kalweit

    kalweit Hüter der Glaskugel

    Registriert seit:
    18. April 2000
    Beiträge:
    31.469
    Beim 6er ist mir diesbezüglich nichts bekannt, allerdings ist der aus anderen Gründen wirklich nicht zu gebrauchen. Folge einfach mal den Vorschlag mit dem Netscape7. Sollte das immer noch nicht funktionieren, stell das Ganze mal ins Netz, damit man sich das ansehen kann.

    Gruss, Matthias
     
  3. kalweit

    kalweit Hüter der Glaskugel

    Registriert seit:
    18. April 2000
    Beiträge:
    31.469
    Was ist an dem dort stehenden Text unverständlich?

    <zitat>

    2.1.2 Fragment identifiers

    Some URIs refer to a location within a resource. This kind of URI ends with "#" followed by an anchor identifier (called the fragment identifier). For instance, here is a URI pointing to an anchor named section_2:

    http://somesite.com/html/top.html#section_2

    </zitat>

    Gruss, Matthias
     
  4. Tux_1984

    Tux_1984 Byte

    Registriert seit:
    18. Oktober 2002
    Beiträge:
    117
    hmm...sagt mir herzlich wenig, ist aber auch nicht so wesentlich, denn das ist nur einfach aus einer HTML-Datei gezogen, die nicht ich erstellt habe, aber bie der es funktioniert...
     
  5. Tux_1984

    Tux_1984 Byte

    Registriert seit:
    18. Oktober 2002
    Beiträge:
    117
    versuche es doch mal mit Netscape7, denn Netscape6 war im Prinzip zu jedem Zeitpunkt bezüglich der Engine eine Beta-Version.
     
  6. HankXX

    HankXX ROM

    Registriert seit:
    12. September 2001
    Beiträge:
    5
    Danke fuer Deine Anwort!

    Die Verson ist Netscape 6 ! Ausserdem stehen die
    Textmarken innerhalb eines Formulars. Das
    duerfte aber nichts zu sagen haben?!?

    Gruss Hank
     
  7. kalweit

    kalweit Hüter der Glaskugel

    Registriert seit:
    18. April 2000
    Beiträge:
    31.469
    http://www.w3.org/TR/html401/intro/intro.html#h-2.1.2

    Gruss, Matthias
     
  8. Tux_1984

    Tux_1984 Byte

    Registriert seit:
    18. Oktober 2002
    Beiträge:
    117
    Kann auch mein Unwissen sein, aber was bitteschön hat "#Produkt1" in dem einen Tag zu suchen?

    Meine Erfahrung Anker+Netscape sind eigentlich nur positiv, allerdings bin ich bis jetzt immer innerhald des Dokuments geblieben. Verwende doch einfach mal statt target mal name.

    <a href="#1">bla</a>
    ...
    <a name="1"></a>
     
  9. kalweit

    kalweit Hüter der Glaskugel

    Registriert seit:
    18. April 2000
    Beiträge:
    31.469
    Außer der Groß- und Kleinschreibung von "products.htm" kann ich nichts erkennen (wenn die eigentliche Datei tatsächlich großgeschrieben ist). Hab damit auch noch nie Probleme gehabt. Allerdings kann ich nicht sagen, ob deine eigenwillige Reihenfolge der Attribute im <a>-Tag darauf einen Einfluß hat. Poste mal die Version vom Netscape.

    Gruss, Matthias
    [Diese Nachricht wurde von kalweit am 26.12.2002 | 13:43 geändert.]
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen