Treiber erneuern?

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von Doofchen, 21. November 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Doofchen

    Doofchen Kbyte

    Registriert seit:
    30. August 2003
    Beiträge:
    277
    Hallo Admins und sonstige Experten,

    ich habe einem Bekannten bei seinem XP-Problem Hilfe angeboten und habe mich damit auf's Glatteis begeben, insofern, dass auch ich nun ein Problem habe - ich komme nicht mehr weiter.
    Fehler #1:
    sein DVD-Laufwerk wird seit kurzem im Gerätemanager als Problemgerät ausgeklammert und ist daher im System nicht mehr anzusprechen (vor kurzem war alles ok).
    Unter DOS funktioniert das Gerät einwandfrei und auch in einem 'nackten' XP-Home.
    Wiederherstellung war nicht möglich, da vom User abeschaltet.
    Maßnahmen als Admin angemeldet:
    deinstallieren und automatisch die entsprechenden Treiber nachinstallieren lassen - Pustekuchen.
    Plattentests alles ok (übrigens wurde das nackte System auf die identische Platte installiert).
    Nach der Kopie von \i386 auf eine andere Partition der manuelle Versuch aus dem Driver-CAB diese zu nachzuinstallieren - Pustekuchen.
    Via cmd-shell Umbenennen der Treiber und kopieren der Treibertroika cdrom.sys, redbook.sys und storprop.dll in die entsprechenden Pfade (Quelle: das nackte XP) - wieder nichts.
    Identische Versuche aus dem abgesicherten Modus (*) und der Wiederherstellungskonsole - negativ.
    Unter msconfig: 'Datei erweitern' einen Rettungsversuch der Treiber versucht - kein Erfolg.
    Interessant ist, dass die in den Pfaden umbenannten (geretteten) alten Treiber unter den gewählten Namen nicht zu finden sind - keiner! Das lässt den Schluß zu dass XP beim Start
    das Verzeichnis neu kopiert oder nur unbekanntes eliminiert(?)! Ausserdem sind die alten defekten Treiber wieder an Ort und Stelle.

    Fehler#2:
    nach Austritt aus dem abgesicherten Modus sind statt einem Admin und einem Benutzer immer nur noch der Admin UND der Administrator vorhanden! Auch hier bin ich ratlos.

    Was ist zu tun Freunde?
    Das aufgesetzte System funktioniert sonst einwandfrei und sollte bestehen bleiben.

    Danke im voraus für Eure Mühe Doofchen.
     
  2. Doofchen

    Doofchen Kbyte

    Registriert seit:
    30. August 2003
    Beiträge:
    277
    @Kukkuck
    dein Tipp brachte mir SFP näher (auch ein Erfolg).
    Das Kopieren der korrekten Treiber unter der Recovery Console nach \system32\dllcache und zugleich an deren Ursprungsorte brachte leider nicht den gewünschten Erfolg - trotzdem vielen Dank.

    @ManniBear
    mit deiner Vermutung und dem Link zu deinem Beitrag vom 03.10.03 hast Du in's Schwarze getroffen. Der User hatte zwischendurch den UDF-Reader von Adaptec installiert um seine alten UDF's lesen zu können. Nach Nichtfunktion des Lesers hat er ihn wieder deinstalliert.
    Das war tatsächlich die Ursache!

    Quintessenz:
    es ist also vom UDFReader unter XP Abstand zu nehmen. In wie weit das DVD-Laufwerk seinen Teil dazu beigetragen hat - bleibt im Dunkeln.

    ManiBaer(chen;-)) , vielen, vielen Dank für den Tipp.

    Jetzt muss ich mich nur noch um das 2. Phänomen kümmern.


    Schöne Grüße Doofchen
     
  3. ManniBear

    ManniBear Megabyte

    Registriert seit:
    23. Februar 2002
    Beiträge:
    1.970
    Wird im Geräte-Manager irgendein Fehlercode angezeigt?

    Das DVD-Laufwerk ist im Arbeitsplatz / Explorer wahrscheinlich nicht mehr vorhanden. Tritt das Problem nur beim DVD-Laufwerk auf oder ist noch ein anderes CD-Laufwerk betroffen? Schau dann auch noch mal hier:

    http://forum.pcwelt.de/showthread.php?s=&threadid=95028

    Mfg Manni
     
  4. bigzorro

    bigzorro Byte

    Registriert seit:
    23. September 2002
    Beiträge:
    84
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen