Verzeichnis entfernen - Frustrationslevel 9/10, XP Pro NTFS

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von No Aloha, 8. September 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. No Aloha

    No Aloha Halbes Megabyte

    Registriert seit:
    14. August 2003
    Beiträge:
    724
    Ich weiß, es gibt dieses Thema schon merfach, und nicht nur hier im Board. Ich kenne auch die Artikel aus MS' "Knowledge Base". Die waren nur leider für meinen Fall so hilfreich wie ein Loch im Kopf.
    Dieses Verzeichnis ist wie eingebrannt. Entstanden ist das bei einer mißglückten Entpack-Aktion aus einem SFX Archiv. Die brach mit einer Fehlermeldung ab (Datei kann nicht erstellt werden, o.ä. - kann mich nicht mehr an den genauen Wortlaut erinnern) und seitdem habe ich dieses Verzeichnis, daß sämtliche Zugriffe mit "Zugriff verweigert" ablehnt. Ich habe selbstverständlich alle Rechte und habe es auch mehrfach von der Wiederherstellungskonsole als Admin versucht - immer dieselbe Meldung.
    Jetzt meine Frage: Gibt es eine Möglichkeit, diesem hartnäckigen Fall beizukommen? Ich stelle mir da sowas vor, wie z.B. eine Art Formatierung, die man auf eine Stelle beschränken kann.
    BTW: Selbst mit NTFSDOS Pro war da nichts zu machen - Zugriff verweigert".

    Glücklicherweise ist das nur eine "Krempel" Partition - keine Programme darauf installiert, ich könnte sie notfalls auch komplett formatieren. Ich habe bloß absolut keinen Nerv darauf, weil das bedeuten würde, mir 25 DVD-RW's kaufen zu müssen.
     
  2. mokum23

    mokum23 Kbyte

    Registriert seit:
    20. April 2001
    Beiträge:
    303
    Geht doch! :jump:
     
  3. No Aloha

    No Aloha Halbes Megabyte

    Registriert seit:
    14. August 2003
    Beiträge:
    724
    Diese Option habe ich bisher übersehen. Ich hatte mich schon gewundert, daß ich so wenig Kontrolle über die Rechteverwaltung habe. Wo ich das doch so übersichtlich von W2000 kannte.

    JOINKS !!! Er ist wech! Das war der Tip, den ich brauchte. Super, vielen Dank, das war wahrlich eine Heldentat. :D
     
  4. autum

    autum Kbyte

    Registriert seit:
    17. Dezember 2002
    Beiträge:
    330
    Probier es doch mal im abgesicherten Modus (beim Start F8). Bei XpHome kommst Du so an die Sicherheitseinstellungen. XpPro kann ich i.M. nicht testen.
    Gruß autum
     
  5. mokum23

    mokum23 Kbyte

    Registriert seit:
    20. April 2001
    Beiträge:
    303
    @Heatseeker:
    Ich war schneller, sprich du mit der Hand ;)

    MFG
     
  6. mokum23

    mokum23 Kbyte

    Registriert seit:
    20. April 2001
    Beiträge:
    303
    Geh in die Ordneroptionen und entferne im Register Ansicht den Haken bei Einfache Dateifreigabe verwenden dann gehts wie oben beschrieben mit der Besitzübernahme. :jump:
     
  7. No Aloha

    No Aloha Halbes Megabyte

    Registriert seit:
    14. August 2003
    Beiträge:
    724
    @autum
    Ich bin mir recht sicher, daß ich als admin angemeldet bin. Das Konto heißt zwar nicht "Admin", hat aber Admin-Rechte und das sollte doch aufs selbe 'rauskommen, oder? Und NTFS ist das Dateisystem, daran besteht kein Zweifel.
    Die Ordnereigenschaften sehen dann so aus. Da gibt es keine anderen Einstellungen.
    Ich kenne das mit den Benutzerfreigaben von W2000. Da ist dann diese Liste, wo man Benutzer hinzufügen, bzw. entfernen kann. Das ist hier aber anders.

    @franzkat
    Das hört sich für mich ziemlich riskant an. Da werde ich wohl doch nicht um die 25 RW's herumkommen.
     
  8. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Wenn du sogar mit NTFS Pro nichts machen kannst, dann siehts zunächst mal finster aus, denn das kümmert sich nicht um Zugriffsrechte oder ähnliches.Möglicherweise liegt hier ein Fehler in der Master File Table vor. Hier läge auch ein Ansatz, um doch noch das ominöse Verzeichnis los zu werden.
    Es gibt ein Programm namens 'Runtime's DiskExplorer for NTFS', mit dem ein direkter Zugrifrf auf die Verzeichniseinträge und die MFT möglich ist. Damit müßte man eigentlich Erfolg haben.
     
  9. autum

    autum Kbyte

    Registriert seit:
    17. Dezember 2002
    Beiträge:
    330
    Welche Option gibt es nicht? -> Sicherheitseinstellungen?
    Bei keinem Deiner Ordner? Bist Du *ganz* sicher, dass Du als Admin angemeldet bist?
    Falls alles ja: Bist Du ebenfalls ganz sicher, dass die HD wirklich NTFS-formatiert ist oder doch FAT/FAT32?
    Gruß autum
     
  10. No Aloha

    No Aloha Halbes Megabyte

    Registriert seit:
    14. August 2003
    Beiträge:
    724
    Diese Option gibts da nicht. Wahrscheinlich ist das aber "Lokale Freigabe und Sicherheit", könnte ich mir vorstellen. Funktioniert leider auch nicht - "Zugriff verweigert"

    Wenn ich wenigstens wüßte, wo sich der Ordner genau auf der Festplatte befindet, dann könnte ich das Stück mit einer Laubsäger heraussägen ....
     
  11. autum

    autum Kbyte

    Registriert seit:
    17. Dezember 2002
    Beiträge:
    330
    Besitz übernehmen:
    Als Admin anmelden, Rechte Maustaste auf den Ordner-> Kontextmenü/Eigenschaften/Sicherheitseinstellungen/Erweitert/Besitzer/Besitzer ändern auf
    So geht es bei Win2k. Bei WinXp sollte es das Selbe sein.
    Gruß autum
     
  12. No Aloha

    No Aloha Halbes Megabyte

    Registriert seit:
    14. August 2003
    Beiträge:
    724
    @autum
    wie mache ich dieses "Besitz übernehmen"? Das hatte ich in der knowledge base schon gelesen, bin aber daraus nicht schlau geworden.

    @Tueftli
    Habe ich alles schon probiert.

    Mit einer Stardiskette und NTFS ist das so eine Sache. Du bekommst damit ja nur Lesezugriff und für den Schreibzugriff gibt es, soweit ich weiß, nur eine Möglichkeit: NTFSDOS Pro. Habe es mir von einem Kollegen 'mal ausgeborgt - "Zugriff verweigert".

    Das Verzeichnis befindet sich glücklicherweise nochmal in einem Verzeichnis. Das wäre ja eigentlich eine ideale Voraussetzung für den Trick mit rmdir /s - "Zugriff verweigert".
     
  13. Tueftli

    Tueftli Kbyte

    Registriert seit:
    4. Dezember 2001
    Beiträge:
    276
    Hi!

    So ein Problem hatte ich auch schon öfters, das ließ sich bei mir aber schon dadurch lösen (damals noch unter Win98SE), dass ich den Comp in der Eingabeaufforderung neu gestartet hab und von da aus ließ sich das Ding löschen!

    Probiers mal mit ner Startdiskette, von der aus du auf die Partition zugreifen kannst

    Befindet sich die Datei in einem Verzeichnis, das du entbehren kannst, könnte auch noch der Befehl rmdir /s helfen (in der XP-Eingabeaufforderung) oder DEL bzw. ERASE.

    Ciao!
    Flo
     
  14. autum

    autum Kbyte

    Registriert seit:
    17. Dezember 2002
    Beiträge:
    330
    Du hast so viel probiert, dass ich mich fast nicht traue zu fragen: Wie sieht es mit Besitz übernehmen aus?
    Gruß autum
     
  15. Heatseeker

    Heatseeker Guest

    Penner! :p


    Aber jetzt lass ihm helfen! Kenne das mit den Ordnern auch aber immer nur bis zum nächsten Neustart!

    Nur kann ja immer n paar Tage dauern! :cool:
     
  16. Heatseeker

    Heatseeker Guest

    Hast du in den Ordneroptionen unter Ansicht den Hacken bei

    "Einfache Dateifreigabe verwenden (empfohlen)"

    entfernt?


    Dann kommt man auch auf die Sicherheitseinstellungen!


    Leih dir doch ne Platte aus dann brauchst du keine 25 RWs


    mfg Chris
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen