verzögertes schreiben deaktivieren

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von MarcinMc, 14. November 2001.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. MarcinMc

    MarcinMc Byte

    Registriert seit:
    8. Januar 2001
    Beiträge:
    13
    hallo,

    weiss jemand wie ich unter w2k das verzögerte schreiben auf alle Laufwerke (HD) deaktivieren kann?

    Danke
    Gruß
    MArcinMc
     
  2. MarcinMc

    MarcinMc Byte

    Registriert seit:
    8. Januar 2001
    Beiträge:
    13
    Danke.

    Gruß
    MarcinMc
     
  3. kazhar

    kazhar Viertel Gigabyte

    Registriert seit:
    21. Juni 2001
    Beiträge:
    4.420
    In dem Fall hast\' natürlich recht! Aber es könnte auch ein Programm im Hintergrund sein, das hie und da die Systemresourcen kurzzeitig an sich reißt. (Indexerstellung usw) Versuch einfach ein paar verschiedene Cache-Größen. Möglicherweise hilft auch ein kleiner Cache? Ganz abschalten würde ich ihn nicht!

    Viel Erfolg, KazHar
     
  4. MarcinMc

    MarcinMc Byte

    Registriert seit:
    8. Januar 2001
    Beiträge:
    13
    ja das ist richtig. Aber das Problem ist ja dass mein System nicht voll ausgelastet ist sondern noch ne gute reserve hat. und wenn der bus von vornherein belastet ist dann habe ich im endeffekt weniger reserve aber keine Framedrops. Wenn aber der Cache vor Buffert und dann auf einmal einen großen Datenstrom auf die Platte schiebt, geht der Bus kurzzeitig in die knie. ohne Cache wird der bus zwar permanent, aber meiner Meinung nach nicht so stark belastet.

    Das ist der Effekt wenn z.B. viele Lichter und der Kühlschrank an einer Phase hängen. Geht der Kühlschrank an, flackern die Lichter kurz auf. und eben dieses "kurze Flackern" (hier der schreibvorgang auf die Platte) verursacht die Framedrops.

    denke ich.

    danke, Gruß
    MarcinMc
     
  5. kazhar

    kazhar Viertel Gigabyte

    Registriert seit:
    21. Juni 2001
    Beiträge:
    4.420
    Dieses "verzögerte schreiben" ist der Schreib-Cache des Systems.
    Den kann man mit den normalen Einstellungen der Systemsteuerung meines Wissens nicht abschalten.
    Möglicherweise hilft Dir WinInBlack oder JDTricks weiter. Dort kann man die Schreib-Cache Größe ändern. Setzt man die auf 0kB schaltet man den Cache ganz ab.
    Meiner Meinung nach solltest Du aber mit einem größeren Cache experimentieren! Die Frameausfälle entstehen nämlich, weil der Datenstrom vom RAM zur Festplatte den Bus offenbar voll auslastet. Wenn Du den Cache abschaltest würde ständig ein Datenstrom zur Platte fließen und dadurch den Bus zwar nicht ganz aber doch stark in Beschlag nehmen -> mehr Framedrops sind IMHO die Folge.

    mfg KazHar
     
  6. MarcinMc

    MarcinMc Byte

    Registriert seit:
    8. Januar 2001
    Beiträge:
    13
    Also, unter w98 gibt es eine Option die heisst "verzögertes schreiben auf Laufwerke abschalten" was soviel bedeutet dass Windows die Daten vorBuffert und dann irgendwann später bei weniger performance auf die Platte schreibt. Gibt`s das unter w2k auch? ist das die Cache option??

    Wenn man Filme aufnimmt und gleichzeitig in Divx und MP3 codiert passiert es manchmal dass das Buffer auf die Platte schreiben FrameDrops verursacht. Trotz etwa 40-50 % Leistungsreserve!!
     
  7. kazhar

    kazhar Viertel Gigabyte

    Registriert seit:
    21. Juni 2001
    Beiträge:
    4.420
    Warum zur Hölle willst Du den Cache abschalten???
    Dadurch wird der Rechner ja zur Schnecke!
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen