W-Lan nur auf wlan0 nicht auf eth1

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von it-praktikant, 16. Januar 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. it-praktikant

    it-praktikant Megabyte

    Registriert seit:
    5. August 2002
    Beiträge:
    1.176
    Hallo,

    endlich ist sie angekommen, meine W-Lan PCMCIA Karte von Acer.

    Leider gibt Acer nur Treiber f"ur Windows mit. Also habe ich herausgefunden, dass die Acer Karte einen Chipsatz von Realtek den rtl8180 besitzt.

    Ich habe mir dann den Treiber von Realtek f"ur Linux herunter geladen und neu kompiliert, weil der vorkompilierte Treiber ausschliesslich f"ur den Kernel 2.4.10 war.

    Also soweit bin ich gekommen. Die Karte ist da. Der Treiber ist installiert. mithilfe von iwconfig ist sie aber nur auf wlan0 aktiv, aber es steht auch 'unknown device' da.

    per ifconfig sehe ich die Karte gar nicht und in netconf kann ich die Karte bl"oderweise auch nicht einstellen, weil das Modul, das ich angebe nicht gefunden wird.

    Wie komme ich also an meine W-Lan Karte, sodass sie auf eth1 l"auft.

    Auf eth0 ist meine 100MBit-Kabel-Netzwerkkarte, und die l"auft auch.


    allgemein
    wenn ich mit 'lspci -v' mir meine Hardware ausgeben lasse, dann steht da h"aufiger 'unknown device', zum Beispiel auch bei meiner Maus, die allerdings gut funktioniert.
    Hat das was zu sagen?
    Wie muss ich vorgehen, damit ich da keine Fehler mehr bekomme?

    Ciao it.
     
  2. moechtgernlinux

    moechtgernlinux Byte

    Registriert seit:
    18. September 2003
    Beiträge:
    79
    Hi it-praktikant,

    muss die auf eth1 laufen?
    Als wlan0 laeuft das Teil bei mir mit folgendem script:
    Code:
    #Load module
    /sbin/insmod -f rtl8180_2420SuSE
    
    #Set SSID
    /usr/sbin/iwpriv wlan0 wlan_para ssid2scan=.........Net
    /usr/sbin/iwpriv wlan0 wlan_para networktype=infra
    /usr/sbin/iwpriv wlan0 wlan_para channel=3
    /usr/sbin/iwpriv wlan0 wlan_para authtype=sharedkey
    #/usr/sbin/iwpriv wlan0 wlan_para wepkeyid=0
    /usr/sbin/iwpriv wlan0 wlan_para wepmode=wep104
    /usr/sbin/iwpriv wlan0 wlan_para wepkey104_1=wepkeyinhex
    
    #Enable wireless lan driver
    /usr/sbin/iwpriv wlan0 enable
    
    #Configure wlan0 IP address
    #/sbin/ifconfig wlan0
    #/sbin/dhcpcd wlan0 -rd
    #echo "$(/sbin/ifconfig wlan0)"
    
    /sbin/ifdown-dhcp wlan0
    /sbin/ifup-dhcp wlan0
    
    
    das auskommentierte ifconfig laeuft bei mir nicht, soll aber bei anderen schon funktionieren, frag bitte nicht, warum :)
     
  3. simDos

    simDos Kbyte

    Registriert seit:
    17. Juli 2001
    Beiträge:
    201
    Ich hatte auch solche probleme, habs aber geschafft. leider weiss ich nicht mehr, was ich genau AN DIESEM PUNKT so alles angestellt habe.

    Wenn ich das naechste mal bei dieser installation (steht nicht bei mir, werde aber in den naechsten 1-2 tagen da sein) bin, kann ich mal nachschauen & werde das dann hier ausfuehrlich posten.
     
  4. letscho

    letscho Byte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    79
    Dieses Prob hatte ich auch und ich bin daran zerbrochen. Ich konnte nichtmal die Treiber übersetzen.
    Ich habe allerding SuSE 9.0.
    Ich habe mir geholfen, das ich mir ne unterstützte Karte gekauft habe, kein guter Trost, oder?
    Habe mich 2 Tage durchs web geklickt und dann habe ich mir eine Karte mit dem Orinoco-Chipsatz, Silber, gekauft. Hersteller ist Proxim.
    Die Karte wurde sofort erkannt als wlan-pcmcia und alle Einstellungen wie Verschlüsselung usw. haben geklappt. Genutzt wird sie tatsächlich als wlan0.

    Problem war nur, das die Karte nur auf Kanal 14 irgendwo um die 5GHz gefunkt hat. Das hab ich mit iwconfig herausbekommen. Einstellen kann man das indem man iwconfig wlan0 channel2 eingibt. Weiterhin kann man auch die Übertragungsrate eingeben, ungefähr so:
    iwconfig wlan0 rate 11M auto
    Heisst; nimm 11Mbit oder automatisch angepasst. Gleiches gilt für den Modus:
    iwconfig mode Managed oder Ad-hoc
    Nach dem Anpassen der Firewall hat die Verbindung zum W-Lan-Router tatsächlich geklappt.

    Versuch das mal, eigentlich dürfte der Name des Gerätes nicht sooo sehr von Interesse sein.

    PS:
    Die Orinoco Karten sind nicht billig, aber leistungsstark. Musst ja keine Orinoco-Gold nehmen, Silber geht auch.
    Habe meine bei ebay für knapp 35EUR gekauft. Im Laden kosten die Dinger schonmal 100-130EUR.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen