Wenn Funktion in Excel

Dieses Thema im Forum "Office-Programme" wurde erstellt von soetzel, 20. Mai 2006.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. soetzel

    soetzel ROM

    Registriert seit:
    5. November 2005
    Beiträge:
    4
    Hallo,

    ich habe folgendes Problem:

    In der 1. Spalte beinhaltet jede Zeile einen kleinen Text. Ich möchte nun in der 2. Spalte für jede Zeile prüfen, ob ein bestimmtes Wort (Apple) in der 1. Spalte vorkommt. Wenn es vorkommt soll eine 1 stehen, ansonsten 0. Meine Funktion:

    =WENN(C2="Apple";1;0)

    leider zeigt er nur 0 an.

    Gruß
     
  2. Scasi

    Scasi Ganzes Gigabyte

    Registriert seit:
    1. August 2004
    Beiträge:
    19.425
    Deine Funktion liefert nur eine 1, wenn der Inhalt von C2 = "Apple" ist, aber auch eine 0 bei z.B. "das ist ein Apple"!

    also musst Du erstmal prüfen, ob "Apple" im gesamten Text vorkommt! hierzu kann man die Funktion "FINDEN" nehmen, die aber bei Nichtvorhandensein einen Fehler ausgibt, den man wiederum abfragen muss

    das sieht dann (ziemlich krückenmäßig) so aus, aber funktioniert:

    =WENN(ISTFEHLER(FINDEN("Apple";C2));0;1)

    hth, ;)
     
  3. soetzel

    soetzel ROM

    Registriert seit:
    5. November 2005
    Beiträge:
    4
    Hat super geklappt. Danke!

    Habe aber noch folgendes Problem:

    Ich habe in einer Spalte Eintagungen eines Datums. Manche in der Form 11.03.2005 und andere haben die Form 10/23/2005.

    Ich möchte nun wissen, was für ein Wochentag das jeweilige Datum war.

    Habe dazu das erste Datumsformat (11.03.2005) in die Form Freitag, 11. März 2005 umwandeln können mit Hilfe Format/Zellen Formatieren/Zahlen/Datum. Bei der 2. Form funktioniert die Umwandlung allerdings nicht.

    Um zu schauen, ob das das Datum ein Freitag war (nur für das umgewandelte Datumsformat), habe ich folgende Funktion eingeben, die eine 1 zeigen soll, falls der Tag ein Freitag ist.

    =WENN(ISTFEHLER(FINDEN("Freitag";B2));0;1)

    Es erscheinen allerdings immer nur 0er.

    Über Hilfe würde ich mich sehr freuen

    Gruß
     
  4. Scasi

    Scasi Ganzes Gigabyte

    Registriert seit:
    1. August 2004
    Beiträge:
    19.425
    wandel doch erstmal Deine Datumsangaben in ein einheitliches Format um - dann kannst Du die einfache Wochentag-Funktion nutzen! ;)
     
  5. soetzel

    soetzel ROM

    Registriert seit:
    5. November 2005
    Beiträge:
    4
    Manche Datumsangaben stehen in der Form 25/12/2004 in den Spalten. Habe versucht die Spalte umzuformatieren, aber Excel ändert das Format nicht.
     
  6. MIKAPet

    MIKAPet Kbyte

    Registriert seit:
    16. Dezember 2003
    Beiträge:
    306
    Hallo soetzel,
    erstell mal in einer freien Zelle z.B. Zelle C2 die Formel:
    =WOCHENTAG(B2) Nun wird nur der Wochentag der Zelle B2 angezeigt.
    Ändere in deiner Formel den Wert "Freitag" in 6 um
    =WENN(ISTFEHLER(FINDEN(6;C2));0;1)
    Nun müsste es eigentlich hinhauen.
     
  7. First Evangelist

    First Evangelist Kbyte

    Registriert seit:
    19. Juni 2004
    Beiträge:
    333
    Hi soetzel,
    wenn ich das richtig sehe, liegt Dein Problem z.Z. in der Umwandlung des Datums mit Querstrich.
    Sollte wie in Beitrag #5 das Datum so: 12/25/2005 aussehen, musst Du lediglich mit Bearbeiten/Ersetzen den / durch einen Punkt ersetzen.
    Sollte das Datum aber, was ich glaube, im amerik. Format wie in Beitrag #3 so sein: 12/25/2005, so fällt das ganze etwas umständlicher aus. Hierzu solltest Du zunächst hinter der Datumsspalte 4 Hilfsspalten einfügen, die Du später wieder löschen kannst. Nach einfügen der Hilfsspalten ,markierst Du das Datum und gehst dann über Daten/Text in Spalten/Punkt vor getrennt machen und auf "Weiter" klicken. Hier Häkchen vor "Andere" setzen und / eingeben. Anschließend auf "Fertig stellen". Nun hast Du Deine drei Komponenten säuberlich getrennt und musst sie nun, im richtigen Format wieder zusammenfügen. Vorausgesetzt Dein Datum stand zuvor in "A2", so hast Du es jetzt auf A2, B2 und C2 verteilt. In D2 gibst Du jetzt die Formel: =B2 & "." & A2 & "." & C2 ein und Du hast Dein fertiges Datum. Dieses kopierst Du nun und gehst in die Ursprungszelle (also hier A2) und fügst sie mit "Bearbeiten / Inhalte einfügen", Häkchen vor "Werte" in die ursprüngliche Zelle ein. Zum Schluß löscht Du noch deine Hilfsspalten.

    Fertisch :) FE
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen