Win2k an einen samba server anmelden

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Steinmetz, 18. April 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Steinmetz

    Steinmetz ROM

    Registriert seit:
    18. April 2002
    Beiträge:
    3
    Bei dem Versuch einen Win2k-Rechner an einem Linux-Server anzumelden, auf dem Samba Version 2.2 läuft, funzt das nicht wirklich, aber unter win 98 funzt es 100%ig was kann ich machen?
     
  2. cf30154

    cf30154 Kbyte

    Registriert seit:
    7. März 2002
    Beiträge:
    324
    Danke für den Link. Da steht ja einiges nützliche drin für Linux Starter wie mich :)

    Grüße

    MT
     
  3. iCebird

    iCebird Kbyte

    Registriert seit:
    20. November 2001
    Beiträge:
    316
    t samba to act as a logon-server for your windows 95/98
    # clients, so uncomment the following:
    ; domain logons = Yes
    ; domain master = Yes
    # For a specific logon script per user
    ; logon script = %U.bat
    # For a specific logon script per machine
    ; logon script = %m.bat

    # Where to store the logon scripts.
    ;[netlogon]
    ; comment = Network Logon Service
    ; path = /var/lib/samba/netlogon

    # Where profiles of Windows 9x systems are stored.
    # First example for a centralized place.
    ; logon home = \\%L\profiles\%U
    # Second example for a subdirectory of the users home.
    ; logon home = \\%L\%U\profile
    # Where profiles of Windows NT systems are stored.
    ; logon path = \\%L\profiles\%U

    # Extra share for profiles. Default is the home of the user.
    ;[profiles]
    ; comment = Network Profiles Service
    ; path = /var/lib/samba/profiles
    ; browseable = No

    # Set these two parameters to your DOS code page and appropriate UNIX
    # character set. These values are for west European languages (Latin-9)
    # UNIX character and MS-DOS Latin 1 code page.
    character set = ISO8859-15
    client code page = 850

    [homes]
    comment = Home Directories
    read only = No
    create mask = 0640
    directory mask = 0750
    browseable = No

    # The following share gives all users access to the Server\'s CD drive,
    # assuming it is mounted under /media/cdrom. To enable this share,
    # please remove the semicolons before the lines
    ;[cdrom]
    ; comment = Linux CD-ROM
    ; path = /media/cdrom
    ; locking = No

    [printers]
    comment = All Printers
    path = /var/tmp
    create mask = 0600
    printable = Yes
    browseable = No
     
  4. Leitwolf

    Leitwolf ROM

    Registriert seit:
    18. April 2002
    Beiträge:
    5
    Bei win2k geht das halt nicht so einfach, win2k verweigert jeede art anmeldung an unseren samba server
     
  5. Schugy

    Schugy Viertel Gigabyte

    Registriert seit:
    10. Juli 2001
    Beiträge:
    2.587
    Hm, bei mir melden sich Win ME und 98 mit verschlüsselten Passwörtern am Samba an.

    Dabei macht Samba die NT-Domäne. Demnach funzt das so auch mit Win2k.

    MfG

    Schugy
     
  6. Leitwolf

    Leitwolf ROM

    Registriert seit:
    18. April 2002
    Beiträge:
    5
    danke schon mal voraus für deinen mühe
     
  7. iCebird

    iCebird Kbyte

    Registriert seit:
    20. November 2001
    Beiträge:
    316
    Hi,

    hab im Moment zwar keinen Samba Server im Einsatz, werd mich heute Abend aber mal dranmachen.
    Meine WS läuft auch unter W2K.
    Ich schreib dann mal alles mit und wenn ich\'s geschafft hab poste ich hier den Lösungsweg.

    Gruß Ralf
     
  8. Leitwolf

    Leitwolf ROM

    Registriert seit:
    18. April 2002
    Beiträge:
    5
    Es ging uns nicht um die anmeldung eines win 95 oder 98 rechner an linux das hat bie uns schon super fuktioniert, es gig viel mehr darum win2k zu überreden sich an den samba server anzumelden, was bei uns nicht wirklich fuktioniert hat, trozdem danke
     
  9. Bio-logisch

    Bio-logisch Halbes Megabyte

    Registriert seit:
    18. Februar 2002
    Beiträge:
    708
    Hi!

    Unter der URL http://www.pc-magazin.de/pclinux/common/page/page.php?table=pg&id=161
    gibt es eine Anleitung zum Konfigurieren von samba, vielleicht hilft das weiter?

    MFG, Bio-logisch
     
  10. Schugy

    Schugy Viertel Gigabyte

    Registriert seit:
    10. Juli 2001
    Beiträge:
    2.587
    Ja, Win 98 sagen, dass es sich an einer NT-Domäne anmelden soll, dann auf der Linuxkiste Passwort mit
    smbpasswd -a username
    hinzufügen und mit Win2k und Win98 glücklich sein.

    Gaaaaaaaaaaanz Easy :-)

    MfG

    Schugy

    Also nicht bei Win2k die Verschlüsselung wegnehmen, sondern Win 98 verschlüsseln *g*
    [Diese Nachricht wurde von Schugy am 18.04.2002 | 18:30 geändert.]
     
  11. Leitwolf

    Leitwolf ROM

    Registriert seit:
    18. April 2002
    Beiträge:
    5
    hn1 danke für den hinweis, aber unser problem lag äher darin das wir uns nicht an unseren samba server anmelden konnten, und nicht das wir ihn nicht gesehen haben, wir haben ihn gesehen bloß es trat halt ein fehler bei der domän anmeldung auf, trozdem danke
     
  12. hn01

    hn01 ROM

    Registriert seit:
    19. Juni 2000
    Beiträge:
    2
    Ich hoffe was gefunden zu haben!

    Schau mal die Url an:

    http://www.tippscout.de/tshow.php3?f_tid=1435
     
  13. hn01

    hn01 ROM

    Registriert seit:
    19. Juni 2000
    Beiträge:
    2
    Ich bin sehr gespannt über diese Lösungen. Habe als Neuling Suse 8.0 gekauft und könnte jeden Hinweis gebrauchen.
    Ansonsten bin ich sehr angetann von Linux.
     
  14. Steinmetz

    Steinmetz ROM

    Registriert seit:
    18. April 2002
    Beiträge:
    3
    Dein vorschlag hat nicht so richtig gefunzt, habt ihr vielleicht noch ein paar ideen wie ich das zum laufen bekommen?
     
  15. Steinmetz

    Steinmetz ROM

    Registriert seit:
    18. April 2002
    Beiträge:
    3
    Ok ich versuch das mal danke, ich meld mich nachert noch mal und sag ob es gefunzt hat
     
  16. iCebird

    iCebird Kbyte

    Registriert seit:
    20. November 2001
    Beiträge:
    316
    Hi,

    wie Adrian schon bemerkte, bei encrypt Passwords = yes
    nimmt Samba die Passwörter in PlainText entgegen und vergleicht diese mit der smbpasswd Datei. Diese Einstellung benötigt man um W9x WfW oder DOS-Clients Zugang zu gewähren.
    W2K übermittelt die Passwörter verschlüsselt.

    Versuch doch mal in W2K
    die Reg-Datei die in /usr/share/doc/packages/samba
    liegt einzufügen.
    Anschließend Neustart von W2K.
    Vorher Registry sichern um diese wieder einspielen zu können.
    Dieser Schlüssel aktiviert die PlainText-Übermittlung der Kennwörter.
    Wenn das funktioniert und Du keine Bedenken hast das jemand in Eurem Netzwerk die Passwortübergabe abhören könnte kannst Du es so lassen.
    Sollte es nicht funktionieren die alte Registry wieder einspielen, oder den Schlüssel von Hand ändern.
    Anschließend mal Encrypt Passwords deaktivieren und Samba neustarten. Anschließend testen ob es funktioniert.
    Halt die Geschichte mit der Passwortübergabe abklären.

    Gruß Ralf
    [Diese Nachricht wurde von iCebird am 18.04.2002 | 13:10 geändert.]
     
  17. Adi4Web

    Adi4Web Byte

    Registriert seit:
    29. Mai 2001
    Beiträge:
    86
    Hallo,

    Nur paar Frage:
    Ist in "/etc/samba/smb.conf" der Schlüssel encrypt passwords = yes?

    Wie sind die IPs konfiguriert?
    Überhapt, _was_ geht nicht?

    Gruss,
    Adi
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen