win95 startet nicht nach neuinstallation

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von Timppa1988, 9. Januar 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Habe gestern Windows 95 auf einem anderen PC neuinstalliert. Nach dem neustart erhielt ich die Fehlermeldungen "Fehler beim laden von explorer.exe Windows muss neu installiert werden" und "Die mit der explorer.exe verbundene datei (irgendwas).dll kann nicht gefunden werden" (so genau weiss ich die zweite Fehlermeldung nicht mehr). Nach der Fehlermeldung geht gar nichts mehr. Hab bei der Installatin einen Bootdiskete erstellt weiss aber nicht wie die mir helfen könnte.

    Bitte um Hilfe: Timo
     
  2. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo Timo !

    Bei so wenig RAM würde ich an Deiner Stelle den IE4 nicht installieren (mit dabei bei einer Normalinstallation von Win 95 ist wohl IE3x), denn es werden wichtige Komponenten des IE4 in das System geladen, was eine ganze Menge Speicher kostet;wahrscheinlich sind auch darauf Deine Probleme zurückzuführen gewesen.Ich würde stattdessen mit einer weniger speicherfressenden Browseralternative arbeiten, denn sonst kommst Du mit 16MB nicht weit (wenig Speicher benötigt z.B. Opera).

    franzkat
     
  3. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Hallo

    Vielen Dank für alle Hilfe, der PC läuft wieder!
    Nur noch eine Frage. Ich hatte vor der Drüberinstallation den IE 4.0 installiert der lief allerdings ziehmlich instabiel (Vielleicht war es ne Beta?). Da ich jetzt den IE neuinsatllieren muss würde ich auch gerne wissen welche Version Sich für Win95 auf einem 133er mit 16mb RAM am besten eignet?

    Vielen Dank: Timo
     
  4. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Rename soll hier nur bedeuten, dass man der Datei einen beliebigen anderen Namen gibt, damit sie vom System nicht erkannt wird.Es reicht als völlig, wenn Du nur einen Buchstaben austauschst.

    franzkat
     
  5. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Welche Win95-Version hast Du denn ?

    franzkat
     
  6. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Hallo

    Ich hab mich schon mal dranngemacht die MS Prozedur durchzuführen aber anscheinen existiert bei mir die integr~1.dat nicht. Jedenfalls wird sie nicht gefunden.
    Daher die Idee alles auszutauschen. aber da muss ich wohl nen anderen Weg suchen.
    Oops. Hab den Zweiten weg nioch nicht Probiert.
    Aber da steht: Rename the Explorer.exe file (if it exists) in the Windows folder, and then rename the Shell32.dll file (if it exists) in the Windows\System folder.
    Alles klar aber rename zu was???

    Timo
    [Diese Nachricht wurde von Timppa1988 am 12.01.2003 | 11:02 geändert.]
     
  7. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Siehst Du, ist so wie ich vermutet habe.Das heißt, wenn Du tatsächlich das System retten willst, mußt Du wahrscheinlich die von MS vorgeschlagenen Prozedur machen.Jede Datei auszutauschen, macht keinen Sinn.Das sind zu viele; der Aufwand ist zu groß.

    franzkat
     
  8. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Hallo

    Super, ich hab eine neue Version der SHLWAPI.DLL runtergeladen und draufgespielt. Jetzt kommt die nächste Fehlermeldung:
    Explorer.exe ist fehlerhaft installieren sie diese Datei erneut.
    Könnte ich die Fehlenden Dateien nacheinander neu aufspielen und das System so zum Laufen bringen?
    Könnte ich die Explorer.EXE von einem Win 98 system verwenden?

    Timo

    P.s:Es handelt sich um Win 95b
    [Diese Nachricht wurde von Timppa1988 am 12.01.2003 | 10:54 geändert.]
     
  9. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Hallo

    Du meinst wenn ich die Datei durch eine neuere ersetze bekomme ich die Fehlermeldung der nächsten?
    Werds versuchen.

    Timo
     
  10. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo Timo !

    Also zu :

    1.

    133Mhz bei 98 geht gerade noch.Sollte aber 64MB Speicher haben.

    2.

    Programme müßten neu installiert werden.Mailadreseen ließen sich vorher sichern

    3.

    Problem wäre gelöst.

    4.

    Richtig.Deshalb müßten ja auch die Programme neu installiert werden.

    Mir wird jetzt erst so einiges klar.In diesem Fall ist nicht neu installiert, sondern "drüberinstalliert" worden.Das heißt : Eine Win95(a oder b ?) Version mit IE 4 soll erneuert werden:Beim Drüberinstallieren werden IE4-bedingte Systemdateien durch ältere von der CD ersetzt.Dass es da Konflikte geben muss, ist klar.Wahrscheinlich ist dann diese dll auch gar ich das einzige Problem.Wahscheinlich würden auch noch andere Systemdateien Zicken machen.(Hast Du\'s denn mal mit einem einfachen Austauschen dieser einen dll versucht ?).Auf diesem Hintergrund werde ich mir doch noch mal die von MS vorgeschlagenen Vorgehensweise mit dem Austasch des Windows-Ordners anschauen.

    franzkat
    [Diese Nachricht wurde von franzkat am 12.01.2003 | 10:12 geändert.]
    [Diese Nachricht wurde von franzkat am 12.01.2003 | 10:57 geändert.]
     
  11. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Hallo

    Eine Überlegung wert wäre das schon.
    Aber:
    1. Der PC ist Uralt (P1 133MHZ)
    2. Könnte ich dann alle Programme und Mailadressen weiterbenutzen?
    3. Wäre das problem gelöst? (Wahrscheinlich schon da Win 98 ja den IE mitinstalliert im gegesatz zu Win 95 wo man (ich jedenfalls) ihn nachinstallieren muss)
    4. Windows 95 benutzt FAT-16 und Win 98 FAT-32. Müsste ich die Festpaltte neu formatieren (da würden dann auch alle Daten verloren gehen)

    Gruss Timo
     
  12. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo Timo !

    Das klingt ja vielleicht ein wenig ketzerisch.Aber wäre es in dieser Situation nicht eine Überlegung Wert, statt diese Verrenkungen mit Win 95 zu machen, Win 98 auf dem Rechner zu installieren und dann z.B. auch einen IE 6-Browser benutzen zu können ?

    franzkat
     
  13. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Hmm der dritte Link Funktioniert nicht.
    Inhalt:

    Name: Roger Clough
    Date: November 23, 1999 at 02:39:18
    Subject: Error loading Explorer.exe

    Comment:

    I tried to reinstall Windows 95, which failed, saying "Error
    loading Explorer.exe. You must reinstall Windows". I click OK and the following box comes up "Error Starting Program. The EXPLORER.EXE file is linked to missing export SHLWAPI.DLL:SHRegGetUSValueA". The OK button is disabled, so I have to reboot.
    When I put the system disk in and restart the computer, it seems not to recognise the cd drive, so how can I reinstall Windows as it suggests?
    Any suggsetions please?
    Roger Clough.

    Response Number 1

    Name: Al

    Date: November 23, 1999 at 05:41:52
    Subject: Error loading Explorer.exe

    Reply:

    Roger,

    Hate to be the one to tell you, but you are in deeper than you know. This error results from re-installing Windows 95B on a system that has Internet explorer 4 installed, without first uninstalling IE4. You are past the point of being able to do it right. The only fix at this point, is to either format and start fresh, or delete your entire windows folder (deltree c:\windows /s) from the c: prompt. this will save all other programs, but lose windows links to the programs and they will have to be reinstalled to work. Use a windows 95 boot floppy with CDRom support to boot computer, and start setup from there. E-mail me if you have any questions.
    Al

    Der Zweite geht auch nicht aber da kommt man auch über die erste Seite hin.

    Sorry
    Timo
     
  14. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Hallo franzkat

    Das Problem mit dem Scanner ist schon länger gelöst.
    Außerdem war das an einem anderen PC.

    Mein jetztiges Problem ist dadurch entstanden dass ich Windows neuinstalliert habe. Jetzt Bootet der Computer nur noch bis ich den Desktophintergrund sehen kann und verabschiedet sich dann mit der Meldung die ich schon vorher beschrieben habe.
    Auf den Seiten von Microsoft hab ich was gefunden was eher mit meinem Prob. übereinstimmt aber der lösungswerg funktioniert nicht. Siehe: http://support.microsoft.com/?kbid=174549
    Auf http://support.microsoft.com/default.aspx?scid=kb;EN-US;174265 ist beschrieben wie man IE von der Platte putzen kann
    (wenn man das Glück hat das es geht, dort steht dass es manchmal nicht geht ohne windows in einen anderen Ordner zu Installieren).
    Ausserdem habe ich dies gefunden: http://www.computing.net/windows95/wwwboard/forum/14987.html. Daher meine Idee von der etwas komplizierten Neuinstallation.

    mfg Timo
     
  15. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo Timo !

    Habe mir nochmal Deine früheren Postings angeschaut und festgestellt, dass Du hier etwas von einem Problem mit einem Canon-Scanner schreibst.Das ist aber genau das Problem, was im MS-Support beschrieben wird.Wahrscheinlich ist die MS-dll durch eine veraltete Canon-dll überschrieben worden.Im Grunde müßte es völlig ausreichen, die alte dll durch eine neuere zu ersetzen.Wenn der Scanner funktionieren soll, mußt Du genauso vorgehen wie im MS-Support beschrieben.Die gleichnamige dll im Canon-Ordner umbenennen.Die - inzwischen aktualisierte dll- aus dem System-Ordner in den Canon-Ordner kopieren.

    franzkat
     
  16. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo Timo !

    Ich glaube nicht, dass das so funktionieren würde.Ich kann mir auch nicht vorstellen, dass hier tatsächlich die Ursache liegt, denn IE4 war schon so mit dem Betriebssystem verwoben, dass hier gar keine Deinstallation des Browsers mehr möglich war(höchstens mit speziellen Tools).Ich kann mir nur vorstellen, dass die dll nicht die richtige Versionsnummer hat und durch einfachen Austausch funktionsfähig gemacht werden kann.Versuch doch mal die Versionsnummer herauszufinden, die die dll hat (einfach auf einen anderen Rechgner kopieren, dort umbennen,).Ich habe auch noch zwei Win 95-Systeme auf zwei Rechnern und würde Dir dann mal die aktuelle Variante der dll schicken.

    franzkat
     
  17. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Hallo franzkat!

    Erstmal danke für die Tipps haben aber leider beide nicht funktioniert.

    Die Google Suche ergab dass das Problem ensteht weil man Windows neu Installiert hat ohne den Internet Explorer 4.0 vorher zu deinstallieren und das man das Problem nur beheben kann indem man die Festplatte formatiert oder den Ordner C:\windows löscht.

    Daher hab ich mir den folgenden Lösungsweg ausgedacht weiss aber nicht ganz ob und wie er funktioniert:

    1. Registry exportieren:(dass kann ich unter dos nicht)
    und auf diskette kopieren (sicherheit)

    2. Windows Ordner umbenennen zum Beispiel in "95Windows95" (nicht löschen):
    (ren c:\windows 95windows95)

    3.Windows neu installieren

    4.Internet Explorer 4.0 neu installieren

    5.Registry löschen und alte Registry neu aufspielen (damit alle Programme wieder funktionieren):
    (das müsste man mir auch noch erklären)

    6.Alten Windows Ordner löschen

    Danach müsste ich wieder den Zustand haben den ich vor der ersten Windows Neuinstalltion hatte. Kein Gewinn aber immerhin liefe die kiste.

    Kannst du mir sagen ob das geht und die paar Einzelheiten erklären?

    Danke im Vorraus Timo
     
  18. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo Timo !

    Hier noch einmal ein Lösungsweg, den ich speziell zu Deiner Fehlermeldung beim Microsoft-Support gefunden habe :

    http://support.microsoft.com/?kbid=226546

    mfg franzkat
     
  19. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hallo Timo !

    Also die Fehlermeldung bedeutet, dass eine Fubktion innerhalb der Datei für explorer.exe nicht zur Verfügung steht.Du sagst, dass die dll vorhanden sei.Versuch, die dll mal manuell für die Registry zu registrieren, indem Du folgenden Befehl unter Ausführen eingibst :

    regsvr32 c:\windowd\system\shlwapi.dll
     
  20. Timppa1988

    Timppa1988 Byte

    Registriert seit:
    21. Januar 2002
    Beiträge:
    56
    Hallo Franzkat

    Die Genaue Fehlermeldung lautet "Die Datei Explorer.exe ist mit dem fehlenden Export-SHLWAPI.DLL:SHRegGetUSValueA verknüpft"
    Die suche am dos-promt ergab dass sich die shlwapi.dll im ordner c:\windows\system befindet. Eine bessere alternative kann ich nicht finden. Ausserdem habe ich Windows jetzt schon 4 mal neuinstalliert aber die Fehlermeldung erscheint immer wieder.

    Gruß Timo
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen