Win98 hat den MBR anekdiert

Dieses Thema im Forum "Windows NT / 95 / 98 / 2000 / ME" wurde erstellt von MsVirus95, 1. Februar 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. MsVirus95

    MsVirus95 Byte

    Registriert seit:
    25. November 2002
    Beiträge:
    10
    wunderschönen Tag allerseits,

    ich möchte von einer 3GB Platte wahlweise Win98 oder SuSE-Linux6.1 booten. Dazu hab ich die Platte partitioniert, in Anlehnung an die Empfehlungen im Linux- Benutzerhandbuch:
    hda1: primär 1,8 GB als Fat für Win98
    hda2: extendet 1,2 GB
    davon hda5 128 MB als Linux-Swap;
    hda6 8MB als Linux-native für /boot
    und den Rest hda7(ca. 1GB) als Linux-native für /root
    Nun wollte ich Lilo installieren. Sowohl bei Installation im MBR als auch in /boot erscheint eine Fehlermeldung der lilo.cfg. wird aber scheinbar trotzdem ausgeführt.
    Beim Neustart ist allerdings nichts von Lilo zu sehen.
    Sofort bootet wieder Windoof98.
    Dann hab ich versucht den PTS Bootmanager 2000 zu installieren. Die Installation unter Windows läuft ohne Probleme (oder zumindest ohne Fehlermeldung). Nach kurzer Installation meldet das setup-Programm: PTS-BM erfolgreich installiert.
    Beim Neustart kann ich mich davon aber schwer davon überzeugen, da sofort wieder Win98 gestartet wird.
    Ist zwar jetzt kein schwerwiegendes Problem aber ich habe aber keine Lust Linux jedes mal mit Bootdiskette zu starten, sondern möchte den Rechner mit einem der beiden Bootmanager (vorzugsweise PTS-BM) starten und zwischen Win98 und Linux auswählen. Wie bekomme ich das hin?
    über nützliche Hinweise wäre ich sehr dankbar.

    mfG.
    Schwindelinside
     
  2. franzkat

    franzkat CD-R 80

    Registriert seit:
    16. Juni 2002
    Beiträge:
    9.246
    Hast du vielleicht die Antivirus-Funktion im BIOS aktiviert ? Die verhindert das Überrschreiben des MBR-Codes und damit auch die Einrichtung eines Bootmanagers.
     
  3. MsVirus95

    MsVirus95 Byte

    Registriert seit:
    25. November 2002
    Beiträge:
    10
    Danke für den Tip.
    Aber hätte da nicht eine Fehlermeldung beim Installieren von PTS-BM kommen müssen?
     
  4. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Hallo MsVirus95,

    so wie Du die Situation schilderst (direktes Booten von Windows), scheint es tatsächlich so zu sein, dass sich lilo nie in den MBR geschrieben hat.
    Selbst bei fehlerhafter Konfiguration solltest Du wenigstens l oder li zu Gesicht bekommen, wenn schon nicht das vollständige lilo.:D

    Wenn tatsächlich der MBR-Schreibschutz aktiviert ist, kann sich kein Programm (auch nicht der pts-Bootmanager) dorthin kopieren. Abhängig vom Hersteller und der BIOS-Version findest Du die entsprechende Option z.B. unter Anti-Virus Protection im Menü BIOS Features Setup (Award-BIOS) oder unter Boot Sector Virus Protection im Menü Main (Amibios). Die Option muss auf disabled gesetzt werden.

    MfG
    Rattiberta
     
  5. Taesi

    Taesi Kbyte

    Registriert seit:
    19. Juli 2003
    Beiträge:
    267
    @MsVirus95
    Zeig' uns doch mal die LILO.CONF ...

    @Rattiberta
    Was Du über den MBR-Schreibschutz schreibst, sollte zwar prinzipiell so sein, jedoch habe ich schon mehrere Programme gesehen, die sich den Teufel drum scheren, und trotzdem drauf schreiben ...

    MfG Taesi
     
  6. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Falls sich in dem Rechner eine zweite Festplatte befindet, eröffnet sich eine weitere Fehlermöglichkeit: Lilo könnte versehentlich in den MBR dieser Platte installiert worden sein.

    Desweiteren sollte man in der Beschreibung des Bootmanagers von PTS nachschauen, ob er in der Lage ist, Linux direkt zu booten oder ob dies über lilo (dann in der Bootpart. installiert) erfolgen muß.

    So oder so sollte sich beim Start ein installierter Bootmanager blicken lassen.:)

    MfG
    Rattiberta
     
  7. Rattiberta

    Rattiberta Halbes Gigabyte

    Registriert seit:
    22. März 2003
    Beiträge:
    5.526
    Ups, ein Gespräch mit jemandem, "der sich auskennt" hat ergeben, dass Du recht hast! :o

    MfG
    Rattiberta
     
  8. MsVirus95

    MsVirus95 Byte

    Registriert seit:
    25. November 2002
    Beiträge:
    10
    Hallo allerseits,

    erstmal dankeschön für die Antworten. Hab nachgeschaut. die Funktion "Virus Warning" war im Award Bios definitif auf "disabled" gesetzt. Hab's jetzt zwar geschafft den PTS BootManager 2000 mittels Startdiskette zu installieren aber der findet das Linux nicht. Also bin ich vielleicht doch auf lilo angewiesen.
    Eine zweite Platte hab ich nicht drin.
    Ich muss nich noch koprrigieren:
    hda5 ist die /boot- Partition von Linux. Dort sollte Lilo eigentlich installiert werden. Sollte die besser Dos oder Linux-Dateisystem haben? Und muss das eine primäre Partition sein?
    hda6 ist die linux-swap-Partition

    Grüße
    MSVirus95
     
  9. Taesi

    Taesi Kbyte

    Registriert seit:
    19. Juli 2003
    Beiträge:
    267
    Also, außer LILO oder GRUB kenne ich fast nichts, was einen Linux-Kernel direkt starten kann, einzig der sog. GUJIN-Bootmanager, der mal auf der UBCD war, fiele mir ein.

    Auf 'disabled' gestellt ist schon mal sicherer, aber daran liegen wirds wohl kaum, ich führe '/sbin/lilo' immer mit aktivierter Warnung aus, und es gab noch nie Probleme.

    Aber nochmal: wie sieht Deine Datei /etc/lilo.conf aus?

    Primärpartition ist nicht unbedingt nötig, würde aber ein Linux-Dateisystem nehmen!

    MfG Taesi
     
  10. letscho

    letscho Byte

    Registriert seit:
    24. Juni 2003
    Beiträge:
    79
    Ist das ein Schreibfehler oder meint er tatsächlich 1 GB für /root ??

    Dann hat er kein / angegeben und es geht natürlich nicht....

    Ich glaube eher 1GB für / (Wurzelverzeichnis incl /root ....)
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen