Win98-Platte ist unter WinXP leer

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von Alex30, 9. August 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Alex30

    Alex30 Byte

    Registriert seit:
    5. September 2002
    Beiträge:
    29
    Hallo,

    ich habe hier ein kurioses, mir unverständliches Problem und hoffe darauf, dass jemand dieses Problem auch schon mal hatte und erfolgreich gelöst hat.

    Das Problem:
    Ich habe seit einigen Tagen einen neuen PC (selbst zusammen gezimmert). Ich habe WinXP Prof. drauf und will nun Dateien von meinem alten PC mit Win98 auf dem neuen sichern. Dazu habe ich die Platte (IBM, 20 GB, FAT32, unter Win98 Bootplatte) an den neuen PC (IDE Primary Master und auch schon Slave versucht) angeschlossen. Das BIOS erkennt die Platte immer problemlos. Unter XP wird die Platte angezeigt, wobei XP der Platte einen anderen Namen gibt, als sie unter Win98 hatte. Die Platte wird angezeigt und ist laut XP leer. Was aber definitiv nicht der Fall ist. Es sollte vielleicht noch erwähnen, dass XP die Platte in den "Eigenschaften" als SCSI Disk Device deklariert, was natürlich falsch ist. Vielleicht ist das ja das Problem.

    Kann mir jemand helfen?

    Grüße
    Alex
     
  2. Alex30

    Alex30 Byte

    Registriert seit:
    5. September 2002
    Beiträge:
    29
    Ich muss zugeben, dass ich das nicht wirklich kontrolliert und probiert habe, weil ich davon ausgegangen bin, dass die Platte korrekt eingestellt wird, wenn sie sofort mit dem richtigen Namen (bzw. Modellnummer) beim Booten anezeigt wird. Meiner eigenen Erfahrung nach, werden Platten vom BIOS gar nicht erst erkannt und in Windows auch nicht angezeigt, wenn sie falsch konfiguriert sind. Meine Platte wurde aber beim Booten und auch in WinXP angezeigt, nur war sie eben (fast) leer. Ich habe später erst festgestellt, dass im Hauptverzeichnis der Platte insgesamt 4 Dateien angezeigt werden. Drei davon waren versteckte bzw. Systemdateien.

    Grüße
    Alex
     
  3. Alex30

    Alex30 Byte

    Registriert seit:
    5. September 2002
    Beiträge:
    29
    Hallo,

    und doch, die Platte war schon am Prim. Master angeschlossen. Der Raid-Controller ist auf dem Asus A7N8X nur bei den S-ATA Platten vorhanden, nicht aber bei den Standard-IDE Controllern. Was ich da gesehen habe, war definitiv nicht eine Partition einer anderen Platte.

    Danke für Deine Antwort.

    Grüße
    Alex
     
  4. Alex30

    Alex30 Byte

    Registriert seit:
    5. September 2002
    Beiträge:
    29
    Hallo und danke erstmal für die Antwort,

    ich komm leider erst jetzt dazu zu antworten. Also, ich bin mir nicht sicher ob ich das alles verstanden habe was Du schreibst. Wenn ich es richtig verstanden habe, dann meinst Du, wenn die Platte bisher als Primary Master betrieben wurde, dann erwartet sie das auch in einem anderen PC?

    Was ich bisher wohl noch nicht so deutlich gesagt habe: Das Mainboard in meinem neuen PC ist ein Asus A7N8X Deluxe, welches u.a. über zwei Standard-IDE-Controller und darüber hinaus über zwei weitere S-ATA Controller verfügt. An einem S-ATA Controller kann nur eine Platte betrieben werden. Als ich WinXP installiert hatte, war an beiden S-ATA Controllern eine Platte angeschlossen. Von den IDE-Controllern war nur der Sec. Master belegt, und zwar mit einem DVD+-RW Laufwerk.

    Mir ist dann noch etwas aufgefallen, was die ganze Sache noch merkwürdiger macht, wie ich finde. Ich konnte auf der mysteriösen Platte aus dem alten Rechner auf dem neuen XP-PC insgesamt 4 Dateien in der Ebene C:\ sehen. Drei davon waren versteckte bzw. Systemdateien.

    Wie auch immer. Ich hätte gerne gewusst, warum sich das ganze so komisch verhält. Letztlich habe ich jedoch resigniert und die Daten auf anderem Wege auf den neuen PC gezogen. Einmal indem ich die noch kleinere 8 GB Platte als Wechselmedium missbraucht habe und neuerdings durch eine LAN-Verbindung mit einem neu erstandenen Crossover-Kabel.

    So wird wohl auch dieses Kapitel in die unzählige Reihe ungelöster Fälle der X(P)-Akten eingehen. ;-)

    Danke für Deine Hilfe.

    Grüße
    Alex
     
  5. DarkChaoS

    DarkChaoS Byte

    Registriert seit:
    8. August 2003
    Beiträge:
    28
    so sinnvoll warst du nu auch wieder nicht *g
    (sorry wegen dem mist da oben .. bin nur halb am denken immo)
    (so nebenbei die dau website is goil :) )

    und ja xp unterstützt alles aber windoof 98 ned :)
    [Diese Nachricht wurde von DarkChaoS am 11.08.2003 | 10:31 geändert.]
     
  6. kazhar

    kazhar Viertel Gigabyte

    Registriert seit:
    21. Juni 2001
    Beiträge:
    4.420
    Kann es sein, dass das BIOS des älteren Rechners die Platte in einem anderen Modus anspricht das neue?

    Schau mal nach, wieviele Cylinders, Heads, Sectors die Platte im alten Rechner hat und ob der Rechner den LBA- oder den Sector-Zugriffsmodus verwendet.
     
  7. Zirkon

    Zirkon Megabyte

    Registriert seit:
    28. November 2001
    Beiträge:
    1.210
    Ich würde auf folgendes tippen:
    Du hast die Win98-Platte nicht wirklich am primären Controller angeschlossen, sondern am zusätzlichen Onboard-Raid des Mobos (diese werden oft als SCSI-Device angezeigt). Da nun für diesen Controller kein Treiber installiert ist, wird die Platte überhaupt nicht gelesen, das, was Du dafür hälst, ist wahrscheinlich lediglich eine Partition einer anderen Platte.
    Möglicherweise ist ihr auch einfach nur kein Laufwerksbuchstabe zugewiesen (solle bei einer bestehenden Formatierung und vorhandenem Treiber aber eigentlich automatisch passieren).
    Geh doch mal in der Computerverwaltung auf die Datenträgerverwaltung, da sollten alle Platten, Partitionen und Laufwerksbuchstabenzuweisungen angezeigt werden.
     
  8. Zirkon

    Zirkon Megabyte

    Registriert seit:
    28. November 2001
    Beiträge:
    1.210
    Blos nicht, XP kann selbstverständlich neben NTFS auch FAT und FAT32 lesen und schreiben.
     
  9. DarkChaoS

    DarkChaoS Byte

    Registriert seit:
    8. August 2003
    Beiträge:
    28
    *dumme antwort lösch* ;)
    [Diese Nachricht wurde von DarkChaoS am 11.08.2003 | 10:33 geändert.]
     
  10. Alex30

    Alex30 Byte

    Registriert seit:
    5. September 2002
    Beiträge:
    29
    Hallo,

    danke für Deine Antwort und nein erstmal. Win98 wird/wurde nicht gebootet. Dies hab ich im BIOS entsprechend eingestellt, damit das nicht passieren kann. Was auch ungeahnte Folgen hätte, weil Win98 plötzlich auch ganz andere Hardware vorfinden würde. Es wurde immer WinXP gebootet.

    Die Platte ist von IBM (genaue Bezeichnung weiß ich gerade nicht), hat 20 GB, besitzt nur eine Partition und wurde im alten PC am Primary Master betrieben, als einziges BS, eben mit Win98. Ich habe die Platte auch schon mal als Primary Slave unter WinXP betrieben (mit umgestecktem Jumper natürlich), was aber nichts an dem Problem geändert hätte, weder positiv noch negativ.

    Nun arbeitete im alten PC eine noch ältere Platte mit 8 GB, auch IBM, mit zwei Partitionen. Diese hab ich nun ebenfalls mal angeschlossen, weil ich auch von dieser Daten überspielen wollte, was bereits geschehen ist. Die Platte hat XP korrekt mit beiden Partitionen und den richtigen Namen ins System eingebunden. Interessanterweise wird auch diese Platte als SCSI-Device deklariert. Das kann also nicht das Problem sein.

    Vielleicht ist der Bootsektor das Problem?

    Grüße
    Alex
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen