Windows-Systemzeit hinkt hinterher ...

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von Verge3000, 26. Februar 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Verge3000

    Verge3000 Byte

    Registriert seit:
    19. Dezember 2002
    Beiträge:
    72
    Ja dieses Problem hatte ich schon einmal und es ging irgendwann aus irgendeinem Grund auch wieder weg, aber nun ist es schon wieder über längere Zeit da und es bringt meine Instant Messenger gewaltig durcheinander. Die Windows-Systemzeit unten rechts in der Taskleiste hinkt hinterher und läuft zu langsam. Manchmal denke ich sogar das sie plötzlich so 5 Minutensprünge oder so zurückmacht. Die Bioszeit ist richtig eingestellt und die Zeit wird in Windows auch eigentlich richtig synchronisiert, sie läuft einfach nur zu langsam. Woran kann das liegen?
     
  2. Wolfgang77

    Wolfgang77 Ganzes Gigabyte

    Registriert seit:
    1. Oktober 2002
    Beiträge:
    20.804
    Hallo,

    wie hoch ist die CPU-Last (Taskmanager) wenn diese Sprünge auftreten...?.

    Zudem solltest du die Zeit über einen Zeitserver (Atomuhr, amtliche Zeit) synchronisieren, wer stellt heute noch eine Uhr manuell wenn ein Internetzugang vorhanden ist:

    Einfach unter ->Systemsteuerung ->Datum und Uhrzeit -> Internetzeit "ptbtime1.ptb.de" eingeben ..

    Wolfgang77
     
  3. Verge3000

    Verge3000 Byte

    Registriert seit:
    19. Dezember 2002
    Beiträge:
    72
    Also auf die CPU-Last kann ich nun wirklich nicht achten, denn die Sprünge sind echt total willkürlich. Gerade ist die Zeit für ne halbe Stunde richtig gelaufen. Dann bin ich nach unten. Als ich wieder kam stand sie 2 Stunden zurück. Bei der Synchonisierung steht immer das ein Fehler aufgetreten ist sobald ich aktualisiere. Sehr komisch.
     
  4. Wolfgang77

    Wolfgang77 Ganzes Gigabyte

    Registriert seit:
    1. Oktober 2002
    Beiträge:
    20.804
    Hallo,

    überprüfe ob der Dienst gestartet ist und auf automatisch starten steht:

    Der Zeitdienst findet sich unter Verwaltung/Dienste als "Windows-Zeitgeber"; er sollte mit dem Autostarttyp "Automatisch" gestartet werden.

    Den Zeitserver hast du angegeben: ptbtime1.ptb.de ??.

    Schaue einmal in der Ereignisanzeige (Computerverwaltung) ob es Hinweise zu der Sache gibt (Fehlermeldungen).

    Schreibe dir einmal eine kleine Batch-Datei (uhr.bat mit folgendem Inhalt)

    @echo off
    net time /setsntp:ptbtime1.ptb.de
    w32tm -once

    wo der Smileys ist muss ein Doppelpunkt hin, furchtbar diese Dinger ! ohne die Leerzeichen die ich jetzt eingefügt habe..
    net time /setsntp : ptbtime1.ptb.de

    Was passiert wenn du die ausführst ??
    Läuft auf der Maschine eine Software-Firewall ??
    Vielleicht wird das Network Time Protocol (NTP) geblockt, bzw. die Ports.

    Wolfgang
     
  5. Verge3000

    Verge3000 Byte

    Registriert seit:
    19. Dezember 2002
    Beiträge:
    72
    Der Autostarttyp des "Windows-Zeitgeber" steht auf automatisch ja. Wenn ich diese Batch-Datei ausführe erscheint folgende Meldung "Befehl wurde erfolgreich ausgeführt".

    In der Ereignisanzeige stehen keinerlei Hinweise zu dem Fehler.

    Nein es läuft auf meinem System keinerlei Software-Firewall.
     
  6. Stphspeedy

    Stphspeedy Kbyte

    Registriert seit:
    12. Februar 2005
    Beiträge:
    149
  7. Verge3000

    Verge3000 Byte

    Registriert seit:
    19. Dezember 2002
    Beiträge:
    72
    Auch das hat alles nichts geholfen. Heute saß ich wieder vorm PC und die Uhr lief die ganze Zeit richtig. Dann war ich kurz für ne halbe Stunde vorm PC weg, kam dann wieder und die Uhr stand plötzlich 1 Stunde zurück. lol .. is alles recht komisch.
     
  8. Ace Piet

    Ace Piet Computerversteher

    Registriert seit:
    7. September 2004
    Beiträge:
    3.325
    (Geraten) Uhren-Sprünge lassen sich auf Treiber-Probleme (allg.Art) zurückführen. Im Kernel-Mode darf sich ein Treiber Zeit lassen solange er will, dabei gehen die Uhren-Interrupts (8) verloren. Die Folge sind Sprünge.

    Ansonsten sind auch MoBo-Uhren-Chip-Probleme denkbar. Die Systemzeit leitet sich im laufenden Betrieb vom Perform.-/Tickcounter ab.

    Uhren-Logs helfen, dem Fehler auf die Spur zu kommen...
    http://www.netcult.ch/elmue/ElmueSoft-de.htm
    _________________________

    (FYI) Anhang (PTB-Sync-Logs):

    Der Normalfall...
    Windows 19:01:51'993 | Chip -0,1 Sek | Performance +0,373 Sek | Tick +0,374 Sek
    Windows 19:11:50'992 | Chip -0,1 Sek | Performance +0,385 Sek | Tick +0,387 Sek
    Windows 19:21:50'002 | Chip -0,1 Sek | Performance +0,397 Sek | Tick +0,398 Sek
    Windows 19:31:49'992 | Chip -0,1 Sek | Performance +0,409 Sek | Tick +0,411 Sek
    Windows 19:41:49'002 | Chip -0,1 Sek | Performance +0,421 Sek | Tick +0,422 Sek
    Windows 19:51:48'992 | Chip -0,1 Sek | Performance +0,434 Sek | Tick +0,435 Sek

    PTBSync hat die Uhrzeit korrigiert: Abweichung: -0,00 Sekunden = -0,01 Sekunden pro Tag [ntps1-1.cs.tu-berlin.de]

    Windows 19:52:47'498 | Chip -0,0 Sek | Performance +0,000 Sek | Tick +0,000 Sek
    Windows 20:02:47'018 | Chip -0,0 Sek | Performance +0,013 Sek | Tick +0,012 Sek

    Bemerkung: Leider kann ich aus meinen Logs nicht mehr bieten. - Mein Netz geht halt (Überraschung ;) auf Zehntel genau...

    Hier ein Beispiel für einen Last-Einbruch...
    Windows 18:53:00'993 | Chip +0,1 Sek | Performance +0,241 Sek | Tick +0,242 Sek
    Windows 19:03:00'003 | Chip +0,1 Sek | Performance +0,253 Sek | Tick +0,253 Sek
    Windows 19:12:59'993 | Chip +0,1 Sek | Performance +4,952 Sek | Tick +0,266 Sek
    Windows 19:22:59'003 | Chip +0,0 Sek | Performance +4,964 Sek | Tick +0,277 Sek
    Windows 19:32:58'993 | Chip +0,1 Sek | Performance +4,976 Sek | Tick +0,290 Sek
    Windows 19:42:57'992 | Chip +0,1 Sek | Performance +4,989 Sek | Tick +0,303 Sek
    Windows 19:52:57'002 | Chip +0,1 Sek | Performance +5,001 Sek | Tick +0,314 Sek

    (Geheimnis) Von ca. 4 - 12 hardwareweisen vorhandenen Gurken erbringt eine 350 MHz-Gurke die geringste Drift, halt handverlesen. Den nehme ich als lokalen Time-Server...
     
  9. Verge3000

    Verge3000 Byte

    Registriert seit:
    19. Dezember 2002
    Beiträge:
    72
    Nun sieh sich das mal einer an. Das Log der PTBSync Atomuhr meint, das ein anderes Programm oder Windows die Uhrzeit ändert. Hier das Log:

    Do not delete this file !

    **** Start (Version 4.5e) ****
    Erklärung dieser Datei siehe Fragezeichen-Knopf im Atomuhr Fenster !
    Betriebssystem = Win XP professional
    Performance Counter Frequenz = 3,579545 MHz
    Clock Interrupt 10,0144 ms (= 99,856 Hz)
    Internet: RAS
    Korrektur der Drift der Windows Uhr: +0,000 Sekunden / Tag

    Datum 28.2.2005
    Windows 09:29:04'611 | Chip -973,2 Sek | Performance +0,000 Sek | Tick +0,000 Sek

    PTBSync hat die Uhrzeit korrigiert: Abweichung: -23 Stunden und 55 Minuten [0.pool.ntp.org]


    Datum 1.3.2005
    Windows 09:25:23'379 | Chip -1,9 Sek | Performance +0,000 Sek | Tick +0,000 Sek

    Ein anderes Programm oder Windows hat die Uhr gestellt.

    Windows 09:25:45'850 | Chip -5,4 Sek | Performance +0,000 Sek | Tick +0,000 Sek
    Windows 09:30:45'030 | Chip -304,6 Sek | Performance -0,002 Sek | Tick +0,001 Sek

    PTBSync hat die Uhrzeit korrigiert: Abweichung: +0,02 Sekunden (manuelles Stellen) [1.pool.ntp.org]

    Windows 09:31:42'952 | Chip -2,5 Sek | Performance +0,000 Sek | Tick +0,000 Sek
    Windows 09:36:42'042 | Chip -301,8 Sek | Performance -0,006 Sek | Tick +0,000 Sek
    Windows 09:41:42'013 | Chip -601,6 Sek | Performance -0,009 Sek | Tick +0,000 Sek
    Windows 09:46:42'004 | Chip -901,7 Sek | Performance -0,008 Sek | Tick +0,001 Sek
    Windows 09:51:42'006 | Chip -1201,9 Sek | Performance -0,009 Sek | Tick +0,000 Sek
    Windows 09:56:42'007 | Chip -1501,8 Sek | Performance -0,008 Sek | Tick +0,000 Sek
    Windows 10:01:42'008 | Chip -1801,6 Sek | Performance -0,008 Sek | Tick +0,001 Sek

    Ein anderes Programm oder Windows hat die Uhr gestellt.

    Windows 09:31:45'764 | Chip -5,6 Sek | Performance +0,000 Sek | Tick +0,000 Sek
    Windows 09:36:45'035 | Chip -304,8 Sek | Performance -0,005 Sek | Tick -0,001 Sek
    Windows 09:41:45'006 | Chip -604,7 Sek | Performance -0,004 Sek | Tick +0,000 Sek
    Windows 09:46:45'007 | Chip -904,6 Sek | Performance -0,005 Sek | Tick +0,000 Sek
    Windows 09:51:45'149 | Chip -1204,9 Sek | Performance -0,001 Sek | Tick +0,010 Sek
    Windows 09:56:45'030 | Chip -1504,6 Sek | Performance -0,005 Sek | Tick +0,000 Sek
    Windows 10:01:45'011 | Chip -1804,6 Sek | Performance -0,005 Sek | Tick +0,000 Sek
    Windows 10:06:45'013 | Chip -2104,7 Sek | Performance -0,005 Sek | Tick -0,001 Sek

    PTBSync hat die Uhrzeit korrigiert: Abweichung: -30 Minuten und 27,98 Sekunden (manuelles Stellen) [1.pool.ntp.org]

    Windows 10:41:00'858 | Chip -2,4 Sek | Performance +0,000 Sek | Tick +0,000 Sek
     
  10. MuellerLukas

    MuellerLukas Halbes Megabyte

    Registriert seit:
    27. April 2004
    Beiträge:
    562
    Könnte auch sein, dass die BIOS-Batterie langsam leer wird.
    Würde ich mal probehalber austauschen.
     
  11. Ace Piet

    Ace Piet Computerversteher

    Registriert seit:
    7. September 2004
    Beiträge:
    3.325
    Nein. - Sprünge in der Systemzeit (während des Betriebes) haben NIE mit mit der Hardware-Uhr oder seiner Batterie zu tun.

    Die Systemzeit wird einmalig (beim Booten) initialisiert und driftet danach mit der Ganggenauigkeit des Perform.- oder Tickcounters (im Normalfall).
     
  12. Verge3000

    Verge3000 Byte

    Registriert seit:
    19. Dezember 2002
    Beiträge:
    72
    Vielleicht hilft wem mein HijackThis Log?

    Logfile of HijackThis v1.97.7
    Scan saved at 18:16:05, on 01.03.2005
    Platform: Windows XP (WinNT 5.01.2600)
    MSIE: Internet Explorer v6.00 (6.00.2600.0000)

    Running processes:
    C:\WINDOWS\System32\smss.exe
    C:\WINDOWS\system32\winlogon.exe
    C:\WINDOWS\system32\services.exe
    C:\WINDOWS\system32\lsass.exe
    C:\WINDOWS\system32\svchost.exe
    C:\WINDOWS\System32\svchost.exe
    C:\WINDOWS\System32\logonui.exe
    C:\WINDOWS\system32\spoolsv.exe
    C:\WINDOWS\Explorer.EXE
    D:\Programme\Creative\SBAudigy2ZS\DVDAudio\CTDVDDET.EXE
    D:\Programme\Creative\SBAudigy2ZS\Surround Mixer\CTSysVol.exe
    C:\WINDOWS\System32\CTHELPER.EXE
    C:\Programme\Logitech\MouseWare\system\em_exec.exe
    D:\Programme\PTBSync\PTBSync.exe
    C:\Programme\Gemeinsame Dateien\Real\Update_OB\realsched.exe
    C:\Programme\AVPersonal\AVWUPSRV.EXE
    C:\WINDOWS\System32\CTsvcCDA.exe
    C:\Programme\Gemeinsame Dateien\Microsoft Shared\VS7DEBUG\MDM.EXE
    C:\WINDOWS\System32\nvsvc32.exe
    C:\WINDOWS\System32\svchost.exe
    C:\WINDOWS\System32\MsPMSPSv.exe
    C:\Programme\Gemeinsame Dateien\Softwin\BitDefender Communicator\xcommsvr.exe
    C:\Programme\Gemeinsame Dateien\Softwin\BitDefender Scan Server\bdss.exe
    D:\Programme\Raxco\PerfectDisk\PDSched.exe
    D:\Programme\Softwin\BitDefender8\vsserv.exe
    D:\Programme\BitComet\BitComet.exe
    D:\Programme\Miranda IM\miranda32.exe
    C:\Programme\Mozilla Firefox\firefox.exe
    D:\PROGRA~1\WINZIP\winzip32.exe
    C:\Dokumente und Einstellungen\Verge3000\Lokale Einstellungen\Temp\HijackThis.exe

    R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar = http://google.icq.com/search/search_frame.php
    R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://google.icq.com
    R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.google.de/
    R3 - URLSearchHook: ICQ Toolbar - {855F3B16-6D32-4fe6-8A56-BBB695989046} - D:\Programme\ICQToolbar\toolbaru.dll
    O2 - BHO: (no name) - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - D:\Programme\Adobe\Acrobat 5.0\Acrobat\ActiveX\AcroIEHelper.ocx
    O2 - BHO: (no name) - {AA58ED58-01DD-4d91-8333-CF10577473F7} - c:\programme\google\googletoolbar1.dll
    O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx
    O3 - Toolbar: &Google - {2318C2B1-4965-11d4-9B18-009027A5CD4F} - c:\programme\google\googletoolbar1.dll
    O3 - Toolbar: ICQ Toolbar - {855F3B16-6D32-4fe6-8A56-BBB695989046} - D:\Programme\ICQToolbar\toolbaru.dll
    O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\System32\NvCpl.dll,NvStartup
    O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
    O4 - HKLM\..\Run: [CTDVDDET] D:\Programme\Creative\SBAudigy2ZS\DVDAudio\CTDVDDET.EXE
    O4 - HKLM\..\Run: [CTSysVol] D:\Programme\Creative\SBAudigy2ZS\Surround Mixer\CTSysVol.exe /r
    O4 - HKLM\..\Run: [SBDrvDet] C:\Programme\Creative\SB Drive Det\SBDrvDet.exe /r
    O4 - HKLM\..\Run: [Logitech Utility] Logi_MwX.Exe
    O4 - HKLM\..\Run: [CTHelper] CTHELPER.EXE
    O4 - HKLM\..\Run: [PTBSync] D:\Programme\PTBSync\PTBSync.exe /Start
    O4 - HKLM\..\Run: [MSConfig] C:\WINDOWS\PCHealth\HelpCtr\Binaries\MSConfig.exe /auto
    O8 - Extra context menu item: &Google Search - res://C:\Programme\Google\GoogleToolbar1.dll/cmsearch.html
    O8 - Extra context menu item: &ICQ Toolbar Search - res://D:\Programme\ICQToolbar\toolbaru.dll/SEARCH.HTML
    O8 - Extra context menu item: Im Cache gespeicherte Seite - res://C:\Programme\Google\GoogleToolbar1.dll/cmcache.html
    O8 - Extra context menu item: Nach Microsoft &Excel exportieren - res://D:\PROGRA~1\MICROS~1\OFFICE11\EXCEL.EXE/3000
    O8 - Extra context menu item: Sothink SWF Catcher - C:\Programme\Gemeinsame Dateien\SourceTec\SWF Catcher\InternetExplorer.htm
    O8 - Extra context menu item: Verweisseiten - res://C:\Programme\Google\GoogleToolbar1.dll/cmbacklinks.html
    O8 - Extra context menu item: Ähnliche Seiten - res://C:\Programme\Google\GoogleToolbar1.dll/cmsimilar.html
    O9 - Extra 'Tools' menuitem: Sun Java Konsole (HKLM)
    O9 - Extra button: ICQ Lite (HKLM)
    O9 - Extra 'Tools' menuitem: ICQ Lite (HKLM)
    O9 - Extra button: Sothink SWF Catcher (HKLM)
    O9 - Extra 'Tools' menuitem: Sothink SWF Catcher (HKLM)
    O9 - Extra button: Messenger (HKLM)
    O9 - Extra 'Tools' menuitem: Windows Messenger (HKLM)
    O16 - DPF: {02BF25D5-8C17-4B23-BC80-D3488ABDDC6B} (QuickTime Object) - http://www.apple.com/qtactivex/qtplugin.cab
    O16 - DPF: {0A5FD7C5-A45C-49FC-ADB5-9952547D5715} (Creative Software AutoUpdate) - http://www.creative.com/su/ocx/15009/CTSUEng.cab
    O16 - DPF: {33564D57-0000-0010-8000-00AA00389B71} - http://download.microsoft.com/download/F/6/E/F6E491A6-77E1-4E20-9F5F-94901338C922/wmv9VCM.CAB
    O16 - DPF: {8E0D4DE5-3180-4024-A327-4DFAD1796A8D} (MessengerStatsClient Class) - http://messenger.zone.msn.com/binary/MessengerStatsClient.cab31267.cab
    O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab
    O16 - DPF: {F6ACF75C-C32C-447B-9BEF-46B766368D29} (Creative Software AutoUpdate Support Package) - http://www.creative.com/su/ocx/15010/CTPID.cab
    O17 - HKLM\System\CCS\Services\Tcpip\..\{312FF05A-5602-4268-976B-530F7D24877C}: NameServer = 217.237.151.225 217.237.150.225
     
  13. Ace Piet

    Ace Piet Computerversteher

    Registriert seit:
    7. September 2004
    Beiträge:
    3.325
    Was, woher kommt "nvsvc32.exe"? - Gibt es (bei NETSTAT -an) viele 445-TCP-Verbindungen?

    -Ace- ________________________[​IMG]
    ________________________________Meine Uhr
    PS.: Hijack-Log. - Yup. Die Teile sind lang, erzeugen also Traffic. Besser ist das, die auf der Hijack-Site zu erzeugen und dort abzuspeichern und hier nur den Link abzugeben. ATZE hats Dir abgenommen, wäre also angesagt, den Beitrag (ändern-> löschen) mit dem Log zu killen. - @Graf: Ich hab den Hinweis (nochmals) in mein bevorstehendes 'Best-Of' aufgenommen ;-)
     
  14. ATZE1

    ATZE1 Kbyte

    Registriert seit:
    19. Juli 2004
    Beiträge:
    379
  15. Ace Piet

    Ace Piet Computerversteher

    Registriert seit:
    7. September 2004
    Beiträge:
    3.325
    Dein PTB-Log sagt mir ff.:

    Deine Systemzeit, die sich vom Perform.-/ Tick-Counter ableitet, geht für (im obigen Bsp.) 30 Min. normal, ABER der Chip _steht_ bzw. wird falsch ausgelesen. Die Differenz ist genau die vergangene Zeit.

    Ob der Chip wirklich steht, erkennst Du im BIOS. - Vermutung: Da läuft er richtig.

    Dann wird die Systemzeit mit der (stehengebliebenen) Chip-Differenz zurückkorrigiert. - An dieser Stelle denke ich über einen 2-ten Zeitdienst nach (w32time), der zudem falsch konf. sein könnte (UTC), defektes SNTP oder defekte MoBo-Chipsatz-Treiber bzw. fehlgeschlag. BIOS-Update. - Prüfe dies mal nach!

    BTW: Wenn PTB-Sync läuft, steht der Zeitgeberdienst (W32time) auf 'nicht gestartet' und 'manuell'

    -Ace-
    _____________________

    (FYI)- Gesammeltes...

    [1] http://support.microsoft.com/kb/q223184/
    [2] http://support.microsoft.com/kb/323621
    [3] http://support.microsoft.com/kb/323621
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen