WinXP: Disk Write Caching Disabled Was tun?

Dieses Thema im Forum "Windows XP / Server 2003/2008 / Vista" wurde erstellt von rawig, 5. November 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. rawig

    rawig Byte

    Registriert seit:
    12. Juni 2003
    Beiträge:
    115
    .
    Hi Folks!

    Auf meinem ansonsten super laufenden System gibt BootVis mir für die Festplatte die Meldung:

    "Warning! Disk write caching is disabled"

    Nun finde ich in der 'Systemsteuerung/Hardware' keine Möglichkeit, das Disk Write Caching zu 'Enabeln'.
    Wie kann ich diese Funktion nun wieder herstellen?
    Kann mir da bitte jemand einen Tip geben?

    Vielen Dank!
    .
     
  2. pilotw

    pilotw Kbyte

    Registriert seit:
    1. April 2003
    Beiträge:
    216
    Deinstalliere den IAA (Intel Application Accelerator) und Du kannst wieder an die Optionen des Laufwerks ran.

    Allerdings würde ich BootVis mit seiner Aussage ohnehin nicht vertrauen. Bei Nichtstandard-Treibern für Controller kann dieses Programm nicht feststellen, wie die angeschlossenen Laufwerke tatsächlich eingestellt sind.
     
  3. rawig

    rawig Byte

    Registriert seit:
    12. Juni 2003
    Beiträge:
    115
    .
    Hi pilotw,

    danke für Deinen Thread!

    Ich habe keine S-ATA-Festplatte, ganz gewöhnliches 80-Pin-Kabel an der Festplatte (IBM Deskstar, 7200 Upm, 80-Pin).

    Chipsatz: Intel 845E

    Memory-Controller: 82845E

    I/O-Controller: 82801DB (ICH4)

    Keine RAID-Konfiguration!

    Neuester Intel-Chipsatz-Treiber ist installiert.


    Den Intel Application Accelerator habe ich allerdings installiert und ausgeführt, bin mir aber gar nicht sicher, ob der irgendetwas geändert hat. Da gibt es irgendwie überhaupt keinen Schalter zum 'Optimieren'.

    Liebe Grüße,
    Rainer
    .
     
  4. pilotw

    pilotw Kbyte

    Registriert seit:
    1. April 2003
    Beiträge:
    216
    Hast Du S-ATA-Festplatten? Und welches Board hast Du?
    Wenn Du beispielsweise ein Board mit 865/875 Chipsatz hast, S-ATA-Festplatten an den ICH5/ICH5R angeschlossen hast, eventuell noch eine RAID0 oder 1 Konfiguration besitzt und den Intel Application Accelerator installiert hast dann wäre es mir schon klar, warum BootVis diese Meldung ausgibt.
    Poste doch mal.
     
  5. rawig

    rawig Byte

    Registriert seit:
    12. Juni 2003
    Beiträge:
    115
    .
    Stimmt, Freunde!

    Der Tipp klappt nicht. Trotzdem vielen Dank.
    Mein Problem ist wohl, dass die Richtlinien bei mir grau unterlegt sind und ich sie somit nicht anwählen kann.
    Zudem gibt es bei mir in den grau unterlegten Richtlinien zwar die Punkte 'Für schnelles Entfernen optimieren' und 'Für Leistung optimieren'; nicht jedoch die Auswahl 'Schreibcache aktivieren' !!!

    Da muss ich doch bestimmt in der Registry irgendwo einen Wert verändern, oder?

    Liebe Grüße rundum,

    Rainer
    .
     
  6. Plinius

    Plinius Viertel Gigabyte

    Registriert seit:
    18. Oktober 2001
    Beiträge:
    2.811

    Diesen Tipp bekam Rainer von mir vor 25 Stunden. Laut seiner Aussage funktioniert das auch nicht bei ihm. (Alles hier nachzulesen)

    salve
     
  7. CowboyPeter

    CowboyPeter Byte

    Registriert seit:
    5. November 2003
    Beiträge:
    10
    Hallo Rainer!
    Versuch mal folgendes.
    Rechtsklick auf Arbeitsplatz >
    Linksklick auf Eigenschaften >
    Linksklick auf Registerkarte Hardware >
    Linksklick auf Gerätemanager >
    Klick auf +Zeichen vor Laufwerke ( zeigt die installierten Laufwerke an) >
    Rechtsklick auf Festplatte ( in meinem Fall ist das ne Maxtor) >
    Linksklick auf Eigenschaften >
    Klick auf Registerkarte Richtlinien,
    Dort müßtest du die Punkte
    für Entfernen optimieren und für Leistung optimieren finden
    Ganz unten müßte stehen:
    Schreibcache auf dem Datenträger aktivieren
    Davor setzt du einen Haken!
    Dann das ganze mit OK beenden.
    Gerätemanager beenden.
    In Arbeitsplatz Eigenschaften auf Übernehmen klicken und dann auf OK.
    Eventuell mußt Du den Computer neu starten um die Einstellungen zu übernehmen.
    Gruß vom
    Cowboy Peter
    aus dem Schönen Freising
     
  8. rawig

    rawig Byte

    Registriert seit:
    12. Juni 2003
    Beiträge:
    115
    .
    Hallo AMDUser,

    vielen Dank für Deine Mühe!

    Es öffnet sich also ein Fenster 'Eigenschaften von Primary IDE Channel'. Darin befinden sich drei Register:

    1. Allgemein:
    Angaben zu Gerätetyp, Hersteller, Ort und Gerätestatus; aber nichts zum Verändern. Schalter zur Problembehandlung, aber hier steht nichts über den Write Cache.

    2. Treiber:
    Wiederum diverse Angaben zum Treiber und 4 Schaltflächen zu Treiberdetails und zur Treiberinstallation; wiederum nichts zum Verändern.

    3. Ressourcen:
    Angaben zur Ressourceneinstellung und Hinweis, dass keine Konflikte vorliegen. Wiederum nichts zum Verändern.


    Und weil hier nirgendwo etwas zu verändern ist und bei den 'Eigenschaften des Laufwerks' die Einträge unter dem Register 'Richtlinien' grau unterlegt und somit nicht anwählbar sind, bin ich mit meinem Latein so ziemlich am Ende!

    Nochmals vielen Dank für Deine Mühe,

    Rainer
    .
     
  9. AMDUser

    AMDUser Ganzes Gigabyte

    Registriert seit:
    17. Juni 2002
    Beiträge:
    11.958
    Wenn ich das noch richtig aus einem anderen Beitrag von dir weiss, hattest du geschrieben ...Intel 82801DB Ultra ATA Controller - richtig?

    Darunter findest du doch Primärer Kanal und Sekundärer Kanal entweder in Deutsch oder Englisch. Klick doch mit ?nem Rechtklicks auf den Primären-Kanal und dann runter auf Eigenschaften. Dann Linksklick auf Eigenschaften und dann erscheint ein neues Fenster.

    Was findest du in dem neuen Fenster alles an Einträgen vor?
     
  10. rawig

    rawig Byte

    Registriert seit:
    12. Juni 2003
    Beiträge:
    115
    .
    Hey Experten,

    das ist ja echt abgepfiffen, auf welch hohem Niveau ihr da kommuniziert! Verstehe nur noch Bahnhof!

    Gibt es denn nach Eurer Meinung nun eine gangbare Lösung für mein Problem?

    Bei Rechtsklick auf das Laufwerk (nicht dem IDE-Controller)komme ich natürlich in die Registerkarte 'Richtlinien', die dortigen Angaben können gelesen werden, sind auch passend, jedoch grau unterlegt und können somit nicht angewählt werden.

    Da ich selber aktiv nichts verändert habe, denke ich, dass das 'Disabling' durch die Installation des Treibers meiner Digitalkamera verursacht wurde.

    Frage: Wie kann ich die Nichtanwählbarkeit der Parameter unter 'Richtlinien' so ändern, dass ich das Häkchen (bzw. bei WinXP: den Punkt) wieder setzen kann?
    .
     
  11. AMDUser

    AMDUser Ganzes Gigabyte

    Registriert seit:
    17. Juni 2002
    Beiträge:
    11.958
    Hallo Siegfried,

    das kommt darauf an wie du z.B. den Chipsatztreiber installiert hast - beim nForce2 hast du ja insges. 3 Möglichkeiten die IDE-Unterstützung zu aktivieren (anwählbar bei manueller Installation der/des Treibers) und entsprechend findet man dann den Untereintrag unter "IDE ATA/ATAPI-Controller" im Gerätemanager wieder

    - Windows eigener Treiber, dann "schimpft" sich der Controller "Standard 2-Kanal PCI-/IDE-Controller"

    - Filtertreiber, dann "schimpft" sich der Controller "NForce2 MCP2 IDE-Controller"

    - Miniporttreiber, dann "schimpft" sich der Controller "NVidia nForce2 SPP/IGP ATA-Controller"


    und davon abhängig ist dann auch widerum die Aktivierung des Schreibcaches an anderer Stelle vorzufinden.

    Je nach Art des installierten Treibers kann die Performance und CPU-Last der IDE-Geräte variieren.

    Gruss aus dem sonnigen Ruhrgebiet

    Andreas
     
  12. rawig

    rawig Byte

    Registriert seit:
    12. Juni 2003
    Beiträge:
    115
    .
    Vielen Dank für die vielen Antworten!

    Unten den Eigenschaften meines IDE/ATAPI-Controller (hier: Intel 82801DB Ultra ATA Controller) kann ich gar nichts machen, da wird nichts angeboten.

    Bei Rechtsklick auf das Laufwerk komme ich in die Registerkarte 'Richtlinien', die dortigen Angaben können gelesen werden, sind auch passend, jedoch grau unterlegt und können somit nicht angewählt werden.

    Da ich selber aktiv nichts verändert habe, denke ich, dass das 'Disabling' durch die Installation des Treibers meiner Digitalkamera verursacht wurde.

    Frage: Wie kann ich die Nichtanwählbarkeit der Parameter unter 'Richtlinien' so ändern, dass ich das Häkchen (bzw. bei WinXP: den Punkt) wieder setzen kann?
    .
     
  13. mschuetzda

    mschuetzda Megabyte

    Registriert seit:
    5. September 2001
    Beiträge:
    1.131
    Es kann ein Risiko sein das Disk write caching einzuschalten, wenn man z.B. mit Datenbanken arbeitet und der PC sich verabschiedet (Stromausfall u.a.) wenn noch nicht alles aus dem Cache physikalisch ind die datenbank geschrieben wurde.

    Wenns nur um Schnelligkeit geht enablen wenns um die Datensicherheit geht disablen.
     
  14. Plinius

    Plinius Viertel Gigabyte

    Registriert seit:
    18. Oktober 2001
    Beiträge:
    2.811
    Naja, vielleicht wäre hier eine Auflistung aller Möglichkeiten auch nicht schlecht ;) ;)


    salve
     
  15. AMDUser

    AMDUser Ganzes Gigabyte

    Registriert seit:
    17. Juni 2002
    Beiträge:
    11.958
    Diese Variante erlaubt bei mir keinerlei Auswahl.

    Die Varaiante wie und wo man das An-/ Abwählen kann, ist vom Chipsatz und Chipsatz-Treiber bzw. der Variante ob nun Windows eigener Treiber, Filtertreiber oder Miniport-Treiber installiert ist, abhängig.

    Pack doch mal einer seine Glaskugel aus, damit wir den Chipsatz und installierten Treiber beim Threadstarter vorhersagen können ;) :p :D
     
  16. Plinius

    Plinius Viertel Gigabyte

    Registriert seit:
    18. Oktober 2001
    Beiträge:
    2.811
    Bei mir ist es im Gerätemanager (aktuelles Gerät Laptop/XP Home) unter LAUFWERKE----Rechtsklick auf das Plattenmodell----EIGENSCHAFTEN----RICHTLINIEN (Dialogbox zum Häkchensetzen)


    salve
     
  17. AMDUser

    AMDUser Ganzes Gigabyte

    Registriert seit:
    17. Juni 2002
    Beiträge:
    11.958
    Bei mir ist?s im Unterpunkt Eigenschaften vom IDE/ATAPI-Controller (hier Nvidia nForce2 SPP/IGP Controller) im Gerätemanager aufgeführt und mit Häkchen versehen.
     
  18. ossilotta

    ossilotta Ehren-Moderator

    Registriert seit:
    1. Juli 2001
    Beiträge:
    8.646
    Hallo Andreas,

    danke für die Information, man lernt immer wieder dazu.
    vilee Grüße aus dem sonnigen Köln.

    mfg Siegfried
     
  19. ossilotta

    ossilotta Ehren-Moderator

    Registriert seit:
    1. Juli 2001
    Beiträge:
    8.646
    im gerätemanager das laufwerk mit rechts anklicken, eigenschaften - richtlinien - häkchen bei schreibcache setzen
    mfg ossilotta

    also nicht unter ide controller
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen