Wlan unter Mandriva LE 2005

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von mr.aldei, 18. Mai 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. mr.aldei

    mr.aldei Halbes Megabyte

    Registriert seit:
    18. April 2005
    Beiträge:
    594
    Hallo,

    Hab mir letzte Woche Mandriva Linux LE gekauft, um mal was neues auszuprobieren und verzweifele an der Einrichtung der Wlan-karte. Erst war Freude, Karte erkannt, installiert dann folgende Fehlermeldung "n wpa_supplicant rpm not found at/usr/bin/perl-install/install_steps.pm line 416. Das sagt mir nicht wirklich viel. Also mal hier nachgeschaut, HOWTO ausprobiert, immer irgendwo eine Fehlermeldung. Versuch ichs ohne Verschlüsselung klappt das reibungslos. Liegt offensichtlich daran. Die Karte hat einen Ralink RT2500 Chip, der Router ist die Fritzboxfon Wlan.

    Kann jemand helfen.

    P.S. hab im Moment nur einen Rechner zur Verfügung und betrete absolutes Neuland. :( :aua:
     
  2. Affirmation

    Affirmation Kbyte

    Registriert seit:
    16. März 2005
    Beiträge:
    152
  3. mr.aldei

    mr.aldei Halbes Megabyte

    Registriert seit:
    18. April 2005
    Beiträge:
    594
    Hallo,

    danke für den Tip, hab ich ausprobieren wollen, brach dann ab mit der Meldung "Einige der gewünschten Pakete können nicht installiert werden. wpa_supplicant.0.3.8-7mdki586 (wegen nicht erfüllter Abhängikeiten von libpcsolite.so.0).
    Und ohne das Paket scheint es ja wohl nicht zu gehen wie eingentlich überall zu lesen ist.

    Naja, und das mit dem kompilieren schieb ich als Anfänger noch ein bisschen vor mir her.

    Trotzdem danke, vielleicht kommen ja noch ein paar andere Vorschläge, wenn ihr mehr Infos braucht, stehe ich gerne zur Verfügung, aber erst wieder ab heute abend, muß gerne arbeiten.
     
  4. Affirmation

    Affirmation Kbyte

    Registriert seit:
    16. März 2005
    Beiträge:
    152
  5. mr.aldei

    mr.aldei Halbes Megabyte

    Registriert seit:
    18. April 2005
    Beiträge:
    594
    Ausprobiert, nichts. Iwconfig aufgerufen - keine no wireless extension. Linux komplett gelöscht, neu aufgesetzt, beide Pakete vor der Neztwerkkonfiguration installiert, kleiner Fortschritt, ra0 erkannt und SSID erkannt aber immer noch keine Verbindung zum Router geschweige denn ins Internet. Und wie gesagt ohne Verschlüsselung funkioniert das. Ist halt etwas umständlich immer Linux runter, Windows rauffahren, Verschlüsselung ein Verschlüsselung aus. Aber ich nähere mich langsam an, drei Jahre noch und das läuft, oder doch lieber auf Suse 9.3. bauen.
     
  6. Affirmation

    Affirmation Kbyte

    Registriert seit:
    16. März 2005
    Beiträge:
    152
    Hast du auch alles richtig gesetzt?

    Also ESSID (=SSID unter Windows) etc...

    Du kannst die Settings bei Mandrake manuell setzen, in dem du die /etc/sysconfig/network-scripts/ifcfg-ra0 entsprechend konfigurierst:

    WIRELESS_MODE=Managed
    WIRELESS_ESSID=deine_essid
    WIRELESS_ENC_KEY=xxxxxxxxxxxxxxxxxxxxxxxxxx
    WIRELESS_IWCONFIG='Paramter für iwconfig'

    Und dann in rc.local:

    insmod treibername
    ifconfig ra0 up #wichtig: bei vielen Karten gehen extensions nur, wenn das Device UP ist
    iwconfig ra0 key [1] WEP-KEY
    iwconfig ra0 enc restrict
    iwconfig ra0 mode Managed
    iwconfig ra0 essid deine_essid
    ifconfig ra0 netzwerk_parameter
    ip route add default gateway_ip dev ra0
     
  7. mr.aldei

    mr.aldei Halbes Megabyte

    Registriert seit:
    18. April 2005
    Beiträge:
    594
    So, hab jetzt mal die ifcfg-ra0 und rc.local angehangen, ist da ein Fehler drin? Weil noch funkioniert es nicht
     
  8. Affirmation

    Affirmation Kbyte

    Registriert seit:
    16. März 2005
    Beiträge:
    152
    Einen direkten Fehler erkenne ich nicht.

    Hast du mal überprüft, ob der Treiber die Werte angenommen hat?
    Es kann auch sein, dass da ein Problem mit dem Treiber vorliegt.
    Eventuell lohnt es sich einmal den Maintainer des Treibers bzw. die zugehörige Mailinglist anzuschreiben und da mal nachzufragen - weil die wissen in jedem Fall viel mehr als ich ;)
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen