Wo ist die deutsche Tastatur??

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von Bamm-Bamm, 7. Juni 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Hallo!

    Es war einmal ein kleines Suse Linux 7.2. Das wollte mehr von der Welt sehen. Dafür ging es in den Wald zu Sax (Sax2 wollte nicht mit ihm reden, da es kein x4, sondern nur x3 hatte. Angeblich). Dort bekam es sofort eine höhere Bildschirmauflösung. Als es wieder zuhause war, freute es sich nicht lange. Denn das "z" sah nun aus wie ein "y" und auch das "ö" und "ä" waren verschwunden.
    Da begab es sich wieder in Wald zu Sax. Wählte ein 104 Tasten Layout eine germanische Tastatur. Klickte auf "apply" und testete gleich an Ort und Stelle. Und siehe da, all die vermißten Buchstaben waren wieder da. Jetzt noch alles speichern. Der mächtige Sax sagte ihm, dass er bis jetzt nichts gespeicht habe (mh?). Vielleicht doch auf Next? Besser nicht, wer weiss was dem dem leicht senilen Sax noch für Fehler unterlaufen. Schließlich hat er schon mein kleines "ö" verscheucht. Schnell noch das Programm beenden. Da tauchte, wie aus dem Nichts, eine seltsame Grafik auf. Mit Lobeshymnen auf ein tolles Betriebssystem. Verschwand aber so schnell, wie es gekommen ist.
    Dann wurde es ganz plötzlich Nacht. Nur ein einsamer länglicher Stern blinkt in der Mitte. Wie damals, als der einfältige Dos noch regierte (später kam es mit dem mächtigen Root nochmal vorbei. Da waren an dieser Stelle viele Worte, die es kaum Verstand, aber vom Booten her kannte). Aber es kannte den Weg nach Hause ins vertraute KDE2 und drückte Ctrl+Alt+F7. Es war ganz aufgeregt und wollte gleich nochmal nachschauen, ob die kleinen Buchstaben noch alle da waren. Oh nein, sie waren nicht mitgekommen. Vielleicht hilft ein Reboot? In den alten wilden Zeiten, wo noch gefensterlt wurde, half das, um die wilde Bande zur Ordnung zu rufen. Aber auch das hat diesmal nichts genützt.
    So lebte es einsam ohne deutsche Tastatur und wußte sich keinen Rat mehr.

    Leider kein Märchen. Wie bekomme ich wieder meine deutsche Tastatur unter KDE 2? Konsole ist normal. Bei der Installation war das so einfach, und nu?

    Wer mir einen Tipp geben kann, hat drei Wünsche frei. Zur Erfüllung wenden Sie sich bitte an eine Fee ihres Vertrauens ;-)

    mfg
    Raphael
    [Diese Nachricht wurde von Bamm-Bamm am 07.06.2002 | 12:41 geändert.]
     
  2. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Diesmal stand "us" drin. In "de" geändert et voilà jetzt klappt\'s auch mit der deutschen Tastatur.

    VIELEN Dank!

    ach, und mit dem Kontrollzentrum: Bei der nächsten Havarie schau ich rein, aber vorerst: "Never change a running system!"

    mfg
    Raphael
     
  3. quereller

    quereller Kbyte

    Registriert seit:
    22. Juni 2001
    Beiträge:
    277
    für Xfree86 4.x ist es zuerst die /etc/X11/XF86Config-4.
    Möglich das bei Suse ein anderer Pfad ist.

    Heh bist du sicher das nicht der windowmanager falsch ist benutze mal twm oder so. (in konsole startx twm -- :1 glaube ich).
    [Diese Nachricht wurde von quereller am 07.06.2002 | 14:53 geändert.]
     
  4. tosa

    tosa Byte

    Registriert seit:
    10. Mai 2001
    Beiträge:
    33
    die Konfigurationsdatei von 3.0 liegt in /etc/XF86Config

    Hast du mal im Kontrollzentrum unter Angeschlossene Geräte/Tastatur nachgeschaut, was da für ein Layout eingestellt ist ??

    gruß tosa
     
  5. Bamm-Bamm

    Bamm-Bamm Kbyte

    Registriert seit:
    11. Februar 2002
    Beiträge:
    491
    Hallo Tosa!

    Ich hab mir mein Remote geschnappt und hab die allwissende Konsole befragt. Und was soll ich sagen ?

    Sch...e. Pustekuchen, da steht "de".

    Nur jedesmal wenn ich mit sax (nicht sax2, weil es sagt, dass es nicht gut sei. Falsche x-Version) anfange, steht dort bei Keyboard als Sprache (zu Deutsch: Language) irgendwas mit englisch.

    Aber ganz oben in xf86config steht auch xfree 4.0 Gibt\'s das auch für 3.0? Ich kenn mich bei Märchen besser als bei Linux aus. Und bei Märchen bin ich nicht besonders.

    Wichtige Konfigurationsdateien? Ich kenn grad mal drei vier Stück. Ich weiß nicht wieviele es gibt und wo die sich alle rumlümmeln.

    mfg
    Raphael
     
  6. tosa

    tosa Byte

    Registriert seit:
    10. Mai 2001
    Beiträge:
    33
    Hallo Raphael
    Ist ja wirklich ein nettes posting!!

    Wenn sich der mächtige Sax nicht überreden lässt, editiere einfach mal deine /etc/X11/XF86Config. Der Abschnitt für die Tastatur sollte eigentlich so aussehen:
    Section "InputDevice"
    Driver "keyboard"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbKeyCodes" "xfree86"
    Option "XkbLayout" "de"
    Option "XkbModel" "pc104"
    Option "XkbRules" "xfree86"
    Option "XkbVariant" "nodeadkeys"

    Nach dem, was du schreibst, müsste bei dir bei Layout "us" stehen.
    Ändere das entsprechend ab und speichere. Falls das nicht hilft musst du dich eben nochmal melden.

    Für solche Fälle ist es ganz gut, wenn man von den wichtigsten Konfigurationsdateien einen Sicherungskopie hat . Mache ich immer, wenn ich ein System neu installiert habe.

    Viel Glück tosa
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen