WOL mit SuSE 7.3

Dieses Thema im Forum "Linux-Distributionen" wurde erstellt von magic, 18. September 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. magic

    magic Byte

    Registriert seit:
    18. April 2000
    Beiträge:
    51
    Ich will meinen Linux - Server durch wake on LAN starten. Hardwaretechnisch ist alles OK, denn unter Win startet er auch doch Suse 7.3 deaktiviert die Funktion und nach dem herunterfahren lässt sich der Server nicht mehr aufwecken. Ich hab jetzt herausgefunden, dass aus Sicherheitsgründen die Funktion deaktiviert wird. https://ullstar.homeip.net/ullstar/linux_wol.jsp . Die Lösung die hier vorgeschlagen wird klappt bei mir nicht. Kennt jemand eine andere? Bei mir wird die Änderung der lilo.conf ignoriert.

    Gruß

    Michael
     
  2. magic

    magic Byte

    Registriert seit:
    18. April 2000
    Beiträge:
    51
    Könntest Du noch mal bitte einen Blick auf den Treiber werfen? Ich benutze den 8139too.o Treiber. Ich hab die Datei mit dem Editor geöffnet, finde aber keinen Eintrag zu WOL ( der von SuSE mitgelieferte Treiber ), es müßte aber einen geben, da ja irgendwo die WOL-Funktion deaktiviert werden muß.

    Gruß

    Michael
     
  3. wickey

    wickey Megabyte

    Registriert seit:
    8. Januar 2002
    Beiträge:
    1.126
    Wie Du den Treiber Patcht ist auf der von Dir genannten Website beschrieben.

    Suche Dir den Treiber für Deine Netzwerkkarte in /lib/modules/Kernelversion/kernel/drivers/net
    (welcher Treiber das ist, bekommst Du mit lsmod heraus.

    In dieser Treiberdatei steht dann (bei meinem Treiber) der Punkt:

    Turn on Wake-on-LAN for adapter(s)

    Was da aber jetzt genau wo und wie zu ändern ist, leider keine Ahnung.

    grüße wickey
     
  4. magic

    magic Byte

    Registriert seit:
    18. April 2000
    Beiträge:
    51
    Hätte ich selbst drauf kommen müssen. Ich hab aber festgestellt, dass es sehr unpraktisch so ist. Ich würde gerne WOL für immer aktivieren, aber wie? Wie patch ich den Treiber der Netzwerkkarte, der die Funktion deaktiviert?

    Gruß

    Michael
     
  5. wickey

    wickey Megabyte

    Registriert seit:
    8. Januar 2002
    Beiträge:
    1.126
    Um die Änderungen in der lilo.conf zu aktivieren musst Du Lilo neu installieren.

    Befehl dazu:

    lilo

    grüße wickey
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen