Zeichenkette auslesen und dann etwas tun

Dieses Thema im Forum "Office-Programme" wurde erstellt von radioman, 23. April 2002.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. radioman

    radioman ROM

    Registriert seit:
    23. April 2002
    Beiträge:
    1
    Hallo zusammen!

    Ich habe ein Problem mit einer Formel. Die Formel soll

    Folgendermaßen funktionieren.



    In einer Zelle steht eine Zeichenkette

    (z.b) DIMM DDR-RAM 256MB, PC266 CL2.5 PC2100

    - Jetzt soll in dieser Zelle gesucht werden, ob DDR vorhanden ist
    - Falls Ja, dann soll er etwas machen?
    - Falls Nein, dann etwas anderes




    Ich habe das folgendermaßen gelöst:



    =WENN(ISTZAHL(FINDEN("DDR";A1));24;WENN(ISTZAHL(FINDEN("CDRW";A1));15;NIX))



    Diese Formel funktioniert auch bestens bis auf ein großes Manko!



    Ich kann nur 7 Verschachtelungen der Wenn Funktion vornehmen. Das ist vielleicht auch gut gedacht von MS, da es dann ziemlich unübersichtlich wird.
    Ich brauche aber mindestens 22 Verschachtelungen, da ich nach 22 verschiedenen Werten in einer Formel suchen muss und dann etwas passieren soll!



    Welche Formel oder Funktion soll ich denn sonst benutzen?

    Da hier sich bestimmt sehr gute Excel Cracks befinden, hoffe ich, dass Ihr mir weiterhelfen könnt.

    In verschiedenen Internet Foren habe ich leider keine anständige Lösung bekommen.

    Ich danke Euch für Eure Mühe



    Beste Grüße

    Bart
     
  2. Geertakw

    Geertakw Kbyte

    Registriert seit:
    25. Februar 2001
    Beiträge:
    418

    \'
    End Function

    Als Benutzerdefinierte Funktion im VB-Editor generieren
    In der Tabelle eintragen: =testen(ZS)

    Abfrage nach Teiltexten kann nahezu beliebig forgesetzt werden.
    Wenn man für jede Abfrage eine Zweierpotenz addiert,
    sind beliebige Kombinationen der Fundergebnisse zu
    differenzieren.

    Rückfragen: geert.jacob@gmx.de

    Viel spass

    Geert
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen