Zeilenvrknüpfung in Excel

Dieses Thema im Forum "Office-Programme" wurde erstellt von zentrifuge, 25. April 2003.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. zentrifuge

    zentrifuge ROM

    Registriert seit:
    24. April 2003
    Beiträge:
    2
    Hallo ,

    ich möchte mit Excel eine Tabelle erstellen. Eine Spalte soll nur Eingabefelder enthalten , die nicht gesperrt sind. Es soll eine Eingabe von ganzen Zahlen erfolgen z.B. von 1-10. Nach der Eingabe soll in der Splalte daneben ein Text ausgegeben werden , der im Tabellenblatt2 oder in einer Textdatei hinterlegt ist. Ich suche also eine Verknüpfung (z.B. Logisch mit Wenn ) um einen eingegebnen Wert einen Begleittext zuzuordnen . Die ganze Geschichte sollte auch beliebig erweiterbar sein. , sodass z.B. die Autokorrktur wegfällt. Auch Access denkbar ???!!!

    Bedanke mich im voraus.

    MfG.
    zentrifuge
     
  2. zentrifuge

    zentrifuge ROM

    Registriert seit:
    24. April 2003
    Beiträge:
    2
    Genau das habe ich gesucht. Klappt prima. Vielen Dank für die schnelle Hilfe.

    schönes Wochenende
    /zentrifuge
     
  3. mkl

    mkl Kbyte

    Registriert seit:
    9. August 2000
    Beiträge:
    345
    Hi,

    was Du suchst, ist, glaube ich, folgendes: In Zelle B1 des ersten Tabellenblattes trägst Du ein:
    =INDEX(Tabelle2!$B:$B;VERGLEICH(A2;Tabelle2!$A:$A;0))
    Auf dem 2. Tabellenblatt muß dann in Spalte A der entsprechende Zahlenwert und in Spalte B der zugeordnete Text stehen.
    Sollte der Fall möglich sein, daß Werte vorkommen, die nicht im zweiten Blatt definiert sind, sollte die Formel wie folgt aussehen:
    =WENN(ISTNV(VERGLEICH(A1;Tabelle2!$A:$A;0));"undefiniert";INDEX(Tabelle2!$B:$B;VERGLEICH(A1;Tabelle2!$A:$A;0)))
    Dadurch wird der Text "undefiniert" an den entsprechenden Stellen eingeblendet (kann natürlich durch einen anderen Text ersetzt werden).

    Hilft Dir das weiter ?

    Und tschüx
     
  4. imogen

    imogen Kbyte

    Registriert seit:
    20. August 2002
    Beiträge:
    243
    =wenn......dann..Tabelle2!Xyy\'. Wobei Xyy für das Feld steht (z.B. A26). So erscheint in Tabelle1 der Text von Tabelle2.
    Sie sollten jedoch beachten: Wenn in Tabelle1 die Textspalte nicht geschützt ist und dort Felder verschoben werden, stimmt die Zuordnung nicht mehr. Beim Kopieren schon.
    Hilft Ihnen das oder habe ich etwas falsch verstanden?
    ciao
    imogen
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen